Introduction

Médiacad (Médiathèque académique) est une application web qui permet l'envoi, l'encodage, le stockage, le partage et la diffusion (streaming, affichage et téléchargement) de médias (vidéos, sons, images et livres numériques) à visée pédagogique.

Pour plus d'informations, vous pouvez consulter le site vitrine de Médiacad .

Créé avec HelpNDoc Personal Edition: Créer de la documentation iPhone facilement

Copyright © 2013-2015 by ce.dsi@ac-bordeaux.fr. All Rights Reserved.


SAdmins

Cette partie est divisées en trois sous-parties :

  1. L'installation initiale de Médiacad .
  2. La mise à jour de Médiacad .
  3. La diffusion de médias dans des sites tiers .

Créé avec HelpNDoc Personal Edition: Générateur gratuit de livres électroniques et documentation


Installation

SAdmins ››

Durée de l'installation

L'installation de Médiacad en production prend plusieurs heures, en fonction du nombre de serveurs dédiés à l'encodage notamment. Le développement éventuel d'adaptateurs spécifiques pour l'authentification et l'annuaire peut fortement allonger la durée d'intégration de l'application.

En revanche, la mise à jour de l'application est habituellement beaucoup plus rapide, de l'ordre d'une vingtaine de minutes.

Configuration requise

Vérifier la configuration requise par Médiacad .

Étapes de l'installation

  1. Installation du serveur web .
  2. Installation du serveur de fichiers .
  3. Installation du (des) serveur(s) d'encodage .
  4. Installation des applications externes (sur le serveur web et les serveurs d'encodage).
  5. Création d'un adaptateur d'authentification .
  6. Création d'un adaptateur et d'un formateur d'annuaire .
  7. Modification du fichier de configuration .
  8. Modification éventuelle des contrôles d'accès (ACL) .
  9. Mise en œuvre des tâches de maintenance et de mise à jour des établissements et des utilisateurs .

Ouf ! C'est fini !

Créé avec HelpNDoc Personal Edition: Outil de création d'aide complet


Configuration requise

SAdmins ›› Installation ››

Préalable

Médiacad est une application web prévue pour une utilisation en environnement professionnel. Elle n'est pas adaptée à une installation sur serveur mutualisé par un informaticien amateur.

Par exemple, la configuration minimale conseillée en production prévoit au moins trois serveurs dédiés (serveur web, serveur(s) d'encodage, serveur de fichiers).

Serveurs

Même si en développement, il est possible d'utiliser un seul serveur, ce n'est pas sérieux en production.

La configuration conseillée est de trois serveurs dédiés minimum :

  • un serveur dédié pour l'application web ;
  • un serveur dédié pour les fichiers ;
  • un (ou plusieurs) serveur(s) dédié(s) pour l'encodage des médias ; Médiacad permet la répartition des tâches d'encodage entre plusieurs serveurs, gère le nombre de processus, la file d'attente, les risques de collisions et les tâches liées.

Serveur web

  • Apache 2.2+ (si possible : 2.4+).
  • PHP 5.3+.
  • MySql : version compatible avec celle de PHP, par exemple 5.5+.

L'utilisation de l'https est fortement conseillée.

Serveur de fichiers

Le serveur de fichiers peut éventuellement être présent sur la même machine que le serveur web. Attention dans ce cas aux accès disques.

Serveur(s) d'encodage

Soigner particulièrement les processeurs et la RAM.

Sauvegardes

Une sauvegarde de la base de données, de l'index et des médias doit être prévue. Un webservice permet de verrouiller l'index pendant la sauvegarde.

Créé avec HelpNDoc Personal Edition: Écrire des livres électroniques ePub pour l'iPad


Serveur web

SAdmins ›› Installation ››

Installation d'Apache

Version minimale

Apache 2.2+ (si possible : 2.4+).

Modules

  • mod_rewrite
  • mod_xsendfile ( https://tn123.org/mod_xsendfile ), version conseillée : 1.0 beta1
  • mod_deflate
  • mod_cache

Virtualhost

  1. Intégrer le virtualhost en le modifiant en fonction de votre environnement :
  • Virtualhost pour Apache 2.2+
  • Virtualhost pour Apache 2.4+

Copie des sources

  1. Récupérer la dernière version publiée des sources de production ( http://web.ac-bordeaux.fr/mediacad/telecharger.php ).
  2. Copier dans le répertoire web indiqué dans le virtualhost les dossiers /application, /library, /local et /public.
  3. Faites bien attention à faire pointer le répertoire web vers le dossier /public, sous peine d'ouvrir un gouffre de sécurité.

Droits sur les dossiers et fichiers

  1. Donner les droits de lecture / exécution à Apache sur les dossiers et fichiers de /application, /library et /public.
  2. Donner les droits de lecture / exécution / écriture / suppression à Apache sur les dossiers et fichiers de /local.

Installation de PHP

Version minimale

PHP 5.3+.

Extensions minimales

Apc, ctype, curl, dom, fileinfo, gd2, hash, iconv, json, libxml, mbstring, mysqli, openssl, pcre, pdo, pdo_mysql, posix, reflexion, session, simplexml, sockets, SPL, standard, xml, zip, zlib.

php.ini

Voir l'exemple du php.ini du serveur de production de Médiacad pour l'académie de Bordeaux.

Installation de MySQL

Version minimale

La plus récente compatible avec la version de PHP. Par exemple : MySQL 5.5.24.

Base de données et tables

  1. Créer une base de données ("mediacad" par exemple). Noter le nom de la base et l'host pour le fichier de configuration.
  2. Injecter dans cette base de données les scripts d'installation SQL (/application/config/install/tables.install.sql).
  3. Si vous souhaitez un jeu de données de test (à ne pas utiliser en production), vous pouvez utiliser le script /application/config/install/testData.install.sql.

Users

  1. Créer un user (par exemple "usermediacad") avec les droits SELECT, INSERT, UPDATE, DELETE sur la base mediacad. Cet user sera celui utilisé par défaut par l'application. Noter le nom et de mot de passe de l'user pour le fichier de configuration.
  2. Créer un user (par exemple "adminmediacad") avec les droits ALL PRIVILEGES (pas de GRANT) sur la base mediacad. Cet user sera utilisé par l'application uniquement lors des procédures d'update. Noter le nom et de mot de passe de l'user pour le fichier de configuration.

Créé avec HelpNDoc Personal Edition: Générateur de documentation d'aide HTML gratuit


Virtualhost Apache 2.2+

SAdmins ›› Installation ›› Serveur web ››

# Médiacad

# Modifier les chaînes ***xxx*** en fonction de votre environnement

Listen ***server_name***:80

NameVirtualHost ***server_name***:80

<VirtualHost ***server***:80>

ServerAdmin ***mail_sadmin***

DocumentRoot "***path_de_Médiacad***/public"

ServerName ***server_name***

SetEnvIf Request_URI "^/ws/encode/getnexttask$" dontlog

ErrorLog "***path+nom_fichier_de_log***"

CustomLog "***path+nom_fichier_de_log_access***" common env=!dontlog

XSendFile On

XSendFilePath ***path_des_fichiers_medias***/

Options -Indexes

<Directory "***path_de_Médiacad***/public">

Options -Indexes +FollowSymlinks

DirectoryIndex index.php

Order deny,allow

Allow from all

</Directory>

<Location />

RewriteEngine on

RewriteCond %{REQUEST_FILENAME} -s [OR]

RewriteCond %{REQUEST_FILENAME} -l [OR]

RewriteCond %{REQUEST_FILENAME} -d

RewriteRule ^.*$ - [NC,L]

RewriteRule ^.*$ index.php [NC,L]

</Location>

# valeurs possibles : development|production

SetEnv APPLICATION_ENV production

# valeurs possibles : on|off

SetEnv APPLICATION_DEBUG on

# valeurs possibles : normal|update

SetEnv APPLICATION_MODE normal

# valeurs possibles : warning|files|database

SetEnv APPLICATION_UPDATE_STEP warning

php_value date.timezone "Europe/Paris"

php_value error_reporting 6143

php_value iconv.input_encoding "UTF-8"

php_value iconv.internal_encoding "UTF-8"

php_value iconv.output_encoding "UTF-8"

php_value mbstring.language "UTF-8"

php_value mbstring.internal_encoding "UTF-8"

php_value mbstring.http_input "UTF-8"

php_value mbstring.http_output "UTF-8"

php_value mbstring.detect_order "UTF-8"

php_value session.cookie_lifetime 0

#Optimisations : mod_deflate et mod_cache

AddOutputFilter DEFLATE js css htm html xml php

ExpiresActive On

ExpiresByType image/gif "access plus 7 days"

ExpiresByType image/jpg "access plus 7 days"

ExpiresByType image/jpeg "access plus 7 days"

ExpiresByType image/png "access plus 7 days"

ExpiresByType image/swf "access plus 7 days"

ExpiresByType application/pdf "access plus 7 days"

ExpiresByType application/zip "access plus 7 days"

ExpiresByType application/bz2 "access plus 7 days"

ExpiresByType application/gz "access plus 7 days"

ExpiresByType text/html "access plus 7 days"

ExpiresByType text/htm "access plus 7 days"

ExpiresByType text/js "access plus 30 days"

ExpiresByType text/x-js "access plus 30 days"

ExpiresByType text/javascript "access plus 30 days"

ExpiresByType text/css "access plus 30 days"

ExpiresByType text/ico "access plus 30 days"

ExpiresByType text/txt "access plus 30 days"

</VirtualHost>

Créé avec HelpNDoc Personal Edition: Créer des documents d'aide CHM facilement


Virtualhost Apache 2.4+

SAdmins ›› Installation ›› Serveur web ››

# Médiacad

# Modifier les chaînes ***xxx*** en fonction de votre environnement

Listen ***server_name***:80

NameVirtualHost ***server_name***:80

<VirtualHost ***server***:80>

ServerAdmin ***mail_sadmin***

DocumentRoot "***path_de_Médiacad***/public"

ServerName ***server_name***

SetEnvIf Request_URI "^/ws/encode/getnexttask$" dontlog

ErrorLog "***path+nom_fichier_de_log***"

CustomLog "***path+nom_fichier_de_log_access***" common env=!dontlog

XSendFile On

XSendFilePath ***path_des_fichiers_medias***/

Options -Indexes

<Directory "***path_de_Médiacad***/public">

Options -Indexes +FollowSymlinks

DirectoryIndex index.php

Order deny,allow

Allow from all

</Directory>

<Location />

RewriteEngine on

RewriteCond %{REQUEST_FILENAME} -s [OR]

RewriteCond %{REQUEST_FILENAME} -l [OR]

RewriteCond %{REQUEST_FILENAME} -d

RewriteRule ^.*$ - [NC,L]

RewriteRule ^.*$ index.php [NC,L]

</Location>

# valeurs possibles : development|production

SetEnv APPLICATION_ENV production

# valeurs possibles : on|off

SetEnv APPLICATION_DEBUG on

# valeurs possibles : normal|update

SetEnv APPLICATION_MODE normal

# valeurs possibles : warning|files|database

SetEnv APPLICATION_UPDATE_STEP warning

# ATTENTION : penser à rajouter le path si Médiacad n'est pas à la racine du site

# Par exemple, pour une uri du type ent2d.ac-bordeaux.fr/mediacad/pr/media...,

# indiquer <If "%{THE_REQUEST} =~ m#^POST /mediacad/pr/media/(add|edit)#">

# MODIFIER les valeurs en fonction de la config de Médiacad

<If "%{THE_REQUEST} =~ m#^(GET|POST) /pr/media/(add|edit)#">

php_value post_max_size "520M"

php_value upload_max_filesize "520M"

</If>

<If "%{THE_REQUEST} =~ m#^POST /pr/media/(add|edit)#">

php_value max_input_time 3600

php_value max_execution_time 4500

php_value memory_limit -1

</If>

php_value date.timezone "Europe/Paris"

php_value error_reporting 6143

php_value iconv.input_encoding "UTF-8"

php_value iconv.internal_encoding "UTF-8"

php_value iconv.output_encoding "UTF-8"

php_value mbstring.language "UTF-8"

php_value mbstring.internal_encoding "UTF-8"

php_value mbstring.http_input "UTF-8"

php_value mbstring.http_output "UTF-8"

php_value mbstring.detect_order "UTF-8"

php_value session.cookie_lifetime 0

#Optimisations : mod_deflate et mod_cache

AddOutputFilter DEFLATE js css htm html xml php

ExpiresActive On

ExpiresByType image/gif "access plus 7 days"

ExpiresByType image/jpg "access plus 7 days"

ExpiresByType image/jpeg "access plus 7 days"

ExpiresByType image/png "access plus 7 days"

ExpiresByType image/swf "access plus 7 days"

ExpiresByType application/pdf "access plus 7 days"

ExpiresByType application/zip "access plus 7 days"

ExpiresByType application/bz2 "access plus 7 days"

ExpiresByType application/gz "access plus 7 days"

ExpiresByType text/html "access plus 7 days"

ExpiresByType text/htm "access plus 7 days"

ExpiresByType text/js "access plus 30 days"

ExpiresByType text/x-js "access plus 30 days"

ExpiresByType text/javascript "access plus 30 days"

ExpiresByType text/css "access plus 30 days"

ExpiresByType text/ico "access plus 30 days"

ExpiresByType text/txt "access plus 30 days"

</VirtualHost>

Créé avec HelpNDoc Personal Edition: Générateur de documentation et EPub facile


php.ini

SAdmins ›› Installation ›› Serveur web ››

[PHP]

;;;;;;;;;;;;;;;;;;;

; About php.ini ;

;;;;;;;;;;;;;;;;;;;

; PHP's initialization file, generally called php.ini, is responsible for

; configuring many of the aspects of PHP's behavior.

; PHP attempts to find and load this configuration from a number of locations.

; The following is a summary of its search order:

; 1. SAPI module specific location.

; 2. The PHPRC environment variable. (As of PHP 5.2.0)

; 3. A number of predefined registry keys on Windows (As of PHP 5.2.0)

; 4. Current working directory (except CLI)

; 5. The web server's directory (for SAPI modules), or directory of PHP

; (otherwise in Windows)

; 6. The directory from the --with-config-file-path compile time option, or the

; Windows directory (C:\windows or C:\winnt)

; See the PHP docs for more specific information.

; http://www.php.net/manual/en/configuration.file.php

; The syntax of the file is extremely simple. Whitespace and Lines

; beginning with a semicolon are silently ignored (as you probably guessed).

; Section headers (e.g. [Foo]) are also silently ignored, even though

; they might mean something in the future.

; Directives following the section heading [PATH=/www/mysite] only

; apply to PHP files in the /www/mysite directory. Directives

; following the section heading [HOST=www.example.com] only apply to

; PHP files served from www.example.com. Directives set in these

; special sections cannot be overridden by user-defined INI files or

; at runtime. Currently, [PATH=] and [HOST=] sections only work under

; CGI/FastCGI.

; http://www.php.net/manual/en/ini.sections.php

; Directives are specified using the following syntax:

; directive = value

; Directive names are *case sensitive* - foo=bar is different from FOO=bar.

; Directives are variables used to configure PHP or PHP extensions.

; There is no name validation. If PHP can't find an expected

; directive because it is not set or is mistyped, a default value will be used.

; The value can be a string, a number, a PHP constant (e.g. E_ALL or M_PI), one

; of the INI constants (On, Off, True, False, Yes, No and None) or an expression

; (e.g. E_ALL & ~E_NOTICE), a quoted string ("bar"), or a reference to a

; previously set variable or directive (e.g. ${foo})

; Expressions in the INI file are limited to bitwise operators and parentheses:

; | bitwise OR

; ^ bitwise XOR

; & bitwise AND

; ~ bitwise NOT

; ! boolean NOT

; Boolean flags can be turned on using the values 1, On, True or Yes.

; They can be turned off using the values 0, Off, False or No.

; An empty string can be denoted by simply not writing anything after the equal

; sign, or by using the None keyword:

; foo = ; sets foo to an empty string

; foo = None ; sets foo to an empty string

; foo = "None" ; sets foo to the string 'None'

; If you use constants in your value, and these constants belong to a

; dynamically loaded extension (either a PHP extension or a Zend extension),

; you may only use these constants *after* the line that loads the extension.

;;;;;;;;;;;;;;;;;;;

; About this file ;

;;;;;;;;;;;;;;;;;;;

; PHP comes packaged with two INI files. One that is recommended to be used

; in production environments and one that is recommended to be used in

; development environments.

; php.ini-production contains settings which hold security, performance and

; best practices at its core. But please be aware, these settings may break

; compatibility with older or less security conscience applications. We

; recommending using the production ini in production and testing environments.

; php.ini-development is very similar to its production variant, except it's

; much more verbose when it comes to errors. We recommending using the

; development version only in development environments as errors shown to

; application users can inadvertently leak otherwise secure information.

; This 2 files are provided, by RPM, in /usr/share/doc/php-common-*/

; File used by RPM (the /etc/php.ini) is mainly the php.ini-production

;;;;;;;;;;;;;;;;;;;

; Quick Reference ;

;;;;;;;;;;;;;;;;;;;

; The following are all the settings which are different in either the production

; or development versions of the INIs with respect to PHP's default behavior.

; Please see the actual settings later in the document for more details as to why

; we recommend these changes in PHP's behavior.

; allow_call_time_pass_reference

; Default Value: On

; Development Value: Off

; Production Value: Off

; display_errors

; Default Value: On

; Development Value: On

; Production Value: Off

; display_startup_errors

; Default Value: Off

; Development Value: On

; Production Value: Off

; error_reporting

; Default Value: E_ALL & ~E_NOTICE

; Development Value: E_ALL | E_STRICT

; Production Value: E_ALL & ~E_DEPRECATED

; html_errors

; Default Value: On

; Development Value: On

; Production value: Off

; log_errors

; Default Value: Off

; Development Value: On

; Production Value: On

; magic_quotes_gpc

; Default Value: On

; Development Value: Off

; Production Value: Off

; max_input_time

; Default Value: -1 (Unlimited)

; Development Value: 60 (60 seconds)

; Production Value: 60 (60 seconds)

; output_buffering

; Default Value: Off

; Development Value: 4096

; Production Value: 4096

; register_argc_argv

; Default Value: On

; Development Value: Off

; Production Value: Off

; register_long_arrays

; Default Value: On

; Development Value: Off

; Production Value: Off

; request_order

; Default Value: None

; Development Value: "GP"

; Production Value: "GP"

; session.bug_compat_42

; Default Value: On

; Development Value: On

; Production Value: Off

; session.bug_compat_warn

; Default Value: On

; Development Value: On

; Production Value: Off

; session.gc_divisor

; Default Value: 100

; Development Value: 1000

; Production Value: 1000

; session.hash_bits_per_character

; Default Value: 4

; Development Value: 5

; Production Value: 5

; short_open_tag

; Default Value: On

; Development Value: Off

; Production Value: Off

; track_errors

; Default Value: Off

; Development Value: On

; Production Value: Off

; url_rewriter.tags

; Default Value: "a=href,area=href,frame=src,form=,fieldset="

; Development Value: "a=href,area=href,frame=src,input=src,form=fakeentry"

; Production Value: "a=href,area=href,frame=src,input=src,form=fakeentry"

; variables_order

; Default Value: "EGPCS"

; Development Value: "GPCS"

; Production Value: "GPCS"

;;;;;;;;;;;;;;;;;;;;

; php.ini Options ;

;;;;;;;;;;;;;;;;;;;;

; Name for user-defined php.ini (.htaccess) files. Default is ".user.ini"

;user_ini.filename = ".user.ini"

; To disable this feature set this option to empty value

;user_ini.filename =

; TTL for user-defined php.ini files (time-to-live) in seconds. Default is 300 seconds (5 minutes)

;user_ini.cache_ttl = 300

;;;;;;;;;;;;;;;;;;;;

; Language Options ;

;;;;;;;;;;;;;;;;;;;;

; Enable the PHP scripting language engine under Apache.

; http://www.php.net/manual/en/apache.configuration.php#ini.engine

engine = On

; This directive determines whether or not PHP will recognize code between

; <? and ?> tags as PHP source which should be processed as such. It's been

; recommended for several years that you not use the short tag "short cut" and

; instead to use the full <?php and ?> tag combination. With the wide spread use

; of XML and use of these tags by other languages, the server can become easily

; confused and end up parsing the wrong code in the wrong context. But because

; this short cut has been a feature for such a long time, it's currently still

; supported for backwards compatibility, but we recommend you don't use them.

; Default Value: On

; Development Value: Off

; Production Value: Off

; http://www.php.net/manual/en/ini.core.php#ini.short-open-tag

short_open_tag = Off

; Allow ASP-style <% %> tags.

; http://www.php.net/manual/en/ini.core.php#ini.asp-tags

asp_tags = Off

; The number of significant digits displayed in floating point numbers.

; http://www.php.net/manual/en/ini.core.php#ini.precision

precision = 14

; Enforce year 2000 compliance (will cause problems with non-compliant browsers)

; http://www.php.net/manual/en/ini.core.php#ini.y2k-compliance

y2k_compliance = On

; Output buffering is a mechanism for controlling how much output data

; (excluding headers and cookies) PHP should keep internally before pushing that

; data to the client. If your application's output exceeds this setting, PHP

; will send that data in chunks of roughly the size you specify.

; Turning on this setting and managing its maximum buffer size can yield some

; interesting side-effects depending on your application and web server.

; You may be able to send headers and cookies after you've already sent output

; through print or echo. You also may see performance benefits if your server is

; emitting less packets due to buffered output versus PHP streaming the output

; as it gets it. On production servers, 4096 bytes is a good setting for performance

; reasons.

; Note: Output buffering can also be controlled via Output Buffering Control

; functions.

; Possible Values:

; On = Enabled and buffer is unlimited. (Use with caution)

; Off = Disabled

; Integer = Enables the buffer and sets its maximum size in bytes.

; Default Value: Off

; Development Value: 4096

; Production Value: 4096

; http://www.php.net/manual/en/outcontrol.configuration.php#ini.output-buffering

output_buffering = 4096

; You can redirect all of the output of your scripts to a function. For

; example, if you set output_handler to "mb_output_handler", character

; encoding will be transparently converted to the specified encoding.

; Setting any output handler automatically turns on output buffering.

; Note: People who wrote portable scripts should not depend on this ini

; directive. Instead, explicitly set the output handler using ob_start().

; Using this ini directive may cause problems unless you know what script

; is doing.

; Note: You cannot use both "mb_output_handler" with "ob_iconv_handler"

; and you cannot use both "ob_gzhandler" and "zlib.output_compression".

; Note: output_handler must be empty if this is set 'On' !!!!

; Instead you must use zlib.output_handler.

; http://www.php.net/manual/en/outcontrol.configuration.php#ini.output-handler

;output_handler =

; Transparent output compression using the zlib library

; Valid values for this option are 'off', 'on', or a specific buffer size

; to be used for compression (default is 4KB)

; Note: Resulting chunk size may vary due to nature of compression. PHP

; outputs chunks that are few hundreds bytes each as a result of

; compression. If you prefer a larger chunk size for better

; performance, enable output_buffering in addition.

; Note: You need to use zlib.output_handler instead of the standard

; output_handler, or otherwise the output will be corrupted.

; http://www.php.net/manual/en/zlib.configuration.php#ini.zlib.output-compression

zlib.output_compression = Off

; http://www.php.net/manual/en/zlib.configuration.php#ini.zlib.output-compression-level

;zlib.output_compression_level = -1

; You cannot specify additional output handlers if zlib.output_compression

; is activated here. This setting does the same as output_handler but in

; a different order.

; http://www.php.net/manual/en/zlib.configuration.php#ini.zlib.output-handler

;zlib.output_handler =

; Implicit flush tells PHP to tell the output layer to flush itself

; automatically after every output block. This is equivalent to calling the

; PHP function flush() after each and every call to print() or echo() and each

; and every HTML block. Turning this option on has serious performance

; implications and is generally recommended for debugging purposes only.

; http://www.php.net/manual/en/outcontrol.configuration.php#ini.implicit-flush

implicit_flush = Off

; The unserialize callback function will be called (with the undefined class'

; name as parameter), if the unserializer finds an undefined class

; which should be instantiated. A warning appears if the specified function is

; not defined, or if the function doesn't include/implement the missing class.

; So only set this entry, if you really want to implement such a

; callback-function.

unserialize_callback_func =

; When floats & doubles are serialized store serialize_precision significant

; digits after the floating point. The default value ensures that when floats

; are decoded with unserialize, the data will remain the same.

serialize_precision = 100

; This directive allows you to enable and disable warnings which PHP will issue

; if you pass a value by reference at function call time. Passing values by

; reference at function call time is a deprecated feature which will be removed

; from PHP at some point in the near future. The acceptable method for passing a

; value by reference to a function is by declaring the reference in the functions

; definition, not at call time. This directive does not disable this feature, it

; only determines whether PHP will warn you about it or not. These warnings

; should enabled in development environments only.

; Default Value: On (Suppress warnings)

; Development Value: Off (Issue warnings)

; Production Value: Off (Issue warnings)

; http://www.php.net/manual/en/ini.core.php#ini.allow-call-time-pass-reference

allow_call_time_pass_reference = Off

; Safe Mode

; http://www.php.net/manual/en/ini.sect.safe-mode.php#ini.safe-mode

safe_mode = Off

; By default, Safe Mode does a UID compare check when

; opening files. If you want to relax this to a GID compare,

; then turn on safe_mode_gid.

; http://www.php.net/manual/en/ini.sect.safe-mode.php#ini.safe-mode-gid

safe_mode_gid = Off

; When safe_mode is on, UID/GID checks are bypassed when

; including files from this directory and its subdirectories.

; (directory must also be in include_path or full path must

; be used when including)

; http://www.php.net/manual/en/ini.sect.safe-mode.php#ini.safe-mode-include-dir

safe_mode_include_dir =

; When safe_mode is on, only executables located in the safe_mode_exec_dir

; will be allowed to be executed via the exec family of functions.

; http://www.php.net/manual/en/ini.sect.safe-mode.php#ini.safe-mode-exec-dir

safe_mode_exec_dir =

; Setting certain environment variables may be a potential security breach.

; This directive contains a comma-delimited list of prefixes. In Safe Mode,

; the user may only alter environment variables whose names begin with the

; prefixes supplied here. By default, users will only be able to set

; environment variables that begin with PHP_ (e.g. PHP_FOO=BAR).

; Note: If this directive is empty, PHP will let the user modify ANY

; environment variable!

; http://www.php.net/manual/en/ini.sect.safe-mode.php#ini.safe-mode-allowed-env-vars

safe_mode_allowed_env_vars = PHP_

; This directive contains a comma-delimited list of environment variables that

; the end user won't be able to change using putenv(). These variables will be

; protected even if safe_mode_allowed_env_vars is set to allow to change them.

; http://www.php.net/manual/en/ini.sect.safe-mode.php#ini.safe-mode-protected-env-vars

safe_mode_protected_env_vars = LD_LIBRARY_PATH

; open_basedir, if set, limits all file operations to the defined directory

; and below. This directive makes most sense if used in a per-directory

; or per-virtualhost web server configuration file. This directive is

; *NOT* affected by whether Safe Mode is turned On or Off.

; http://www.php.net/manual/en/ini.sect.safe-mode.php#ini.open-basedir

;open_basedir =

; This directive allows you to disable certain functions for security reasons.

; It receives a comma-delimited list of function names. This directive is

; *NOT* affected by whether Safe Mode is turned On or Off.

; http://www.php.net/manual/en/ini.sect.safe-mode.php#ini.disable-functions

disable_functions =

; This directive allows you to disable certain classes for security reasons.

; It receives a comma-delimited list of class names. This directive is

; *NOT* affected by whether Safe Mode is turned On or Off.

; http://www.php.net/manual/en/ini.sect.safe-mode.php#ini.disable-classes

disable_classes =

; Colors for Syntax Highlighting mode. Anything that's acceptable in

; <span style="color: ???????"> would work.

; http://www.php.net/manual/en/misc.configuration.php#ini.syntax-highlighting

;highlight.string = #DD0000

;highlight.comment = #FF9900

;highlight.keyword = #007700

;highlight.bg = #FFFFFF

;highlight.default = #0000BB

;highlight.html = #000000

; If enabled, the request will be allowed to complete even if the user aborts

; the request. Consider enabling it if executing long requests, which may end up

; being interrupted by the user or a browser timing out. PHP's default behavior

; is to disable this feature.

; http://www.php.net/manual/en/misc.configuration.php#ini.ignore-user-abort

;ignore_user_abort = On

; Determines the size of the realpath cache to be used by PHP. This value should

; be increased on systems where PHP opens many files to reflect the quantity of

; the file operations performed.

; http://www.php.net/manual/en/ini.core.php#ini.realpath-cache-size

;realpath_cache_size = 16k

; Duration of time, in seconds for which to cache realpath information for a given

; file or directory. For systems with rarely changing files, consider increasing this

; value.

; http://www.php.net/manual/en/ini.core.php#ini.realpath-cache-ttl

;realpath_cache_ttl = 120

;;;;;;;;;;;;;;;;;

; Miscellaneous ;

;;;;;;;;;;;;;;;;;

; Decides whether PHP may expose the fact that it is installed on the server

; (e.g. by adding its signature to the Web server header). It is no security

; threat in any way, but it makes it possible to determine whether you use PHP

; on your server or not.

; http://www.php.net/manual/en/ini.core.php#ini.expose-php

expose_php = On

;;;;;;;;;;;;;;;;;;;

; Resource Limits ;

;;;;;;;;;;;;;;;;;;;

; Maximum execution time of each script, in seconds

; http://www.php.net/manual/en/info.configuration.php#ini.max-execution-time

max_execution_time = 30

; Maximum amount of time each script may spend parsing request data. It's a good

; idea to limit this time on productions servers in order to eliminate unexpectedly

; long running scripts.

; Default Value: -1 (Unlimited)

; Development Value: 60 (60 seconds)

; Production Value: 60 (60 seconds)

; http://www.php.net/manual/en/info.configuration.php#ini.max-input-time

max_input_time = 60

; Maximum input variable nesting level

; http://www.php.net/manual/en/info.configuration.php#ini.max-input-nesting-level

;max_input_nesting_level = 64

; Maximum amount of memory a script may consume (128MB)

; http://www.php.net/manual/en/ini.core.php#ini.memory-limit

memory_limit = 128M

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

; Error handling and logging ;

;;;;;;;;;;;;;;;;;;;;;;;;;;;;;;

; This directive informs PHP of which errors, warnings and notices you would like

; it to take action for. The recommended way of setting values for this

; directive is through the use of the error level constants and bitwise

; operators. The error level constants are below here for convenience as well as

; some common settings and their meanings.

; By default, PHP is set to take action on all errors, notices and warnings EXCEPT

; those related to E_NOTICE and E_STRICT, which together cover best practices and

; recommended coding standards in PHP. For performance reasons, this is the

; recommend error reporting setting. Your production server shouldn't be wasting

; resources complaining about best practices and coding standards. That's what

; development servers and development settings are for.

; Note: The php.ini-development file has this setting as E_ALL | E_STRICT. This

; means it pretty much reports everything which is exactly what you want during

; development and early testing.

;

; Error Level Constants:

; E_ALL - All errors and warnings (includes E_STRICT as of PHP 6.0.0)

; E_ERROR - fatal run-time errors

; E_RECOVERABLE_ERROR - almost fatal run-time errors

; E_WARNING - run-time warnings (non-fatal errors)

; E_PARSE - compile-time parse errors

; E_NOTICE - run-time notices (these are warnings which often result

; from a bug in your code, but it's possible that it was

; intentional (e.g., using an uninitialized variable and

; relying on the fact it's automatically initialized to an

; empty string)

; E_STRICT - run-time notices, enable to have PHP suggest changes

; to your code which will ensure the best interoperability

; and forward compatibility of your code

; E_CORE_ERROR - fatal errors that occur during PHP's initial startup

; E_CORE_WARNING - warnings (non-fatal errors) that occur during PHP's

; initial startup

; E_COMPILE_ERROR - fatal compile-time errors

; E_COMPILE_WARNING - compile-time warnings (non-fatal errors)

; E_USER_ERROR - user-generated error message

; E_USER_WARNING - user-generated warning message

; E_USER_NOTICE - user-generated notice message

; E_DEPRECATED - warn about code that will not work in future versions

; of PHP

; E_USER_DEPRECATED - user-generated deprecation warnings

;

; Common Values:

; E_ALL & ~E_NOTICE (Show all errors, except for notices and coding standards warnings.)

; E_ALL & ~E_NOTICE | E_STRICT (Show all errors, except for notices)

; E_COMPILE_ERROR|E_RECOVERABLE_ERROR|E_ERROR|E_CORE_ERROR (Show only errors)

; E_ALL | E_STRICT (Show all errors, warnings and notices including coding standards.)

; Default Value: E_ALL & ~E_NOTICE

; Development Value: E_ALL | E_STRICT

; Production Value: E_ALL & ~E_DEPRECATED

; http://www.php.net/manual/en/errorfunc.configuration.php#ini.error-reporting

error_reporting = E_ALL & ~E_DEPRECATED

; This directive controls whether or not and where PHP will output errors,

; notices and warnings too. Error output is very useful during development, but

; it could be very dangerous in production environments. Depending on the code

; which is triggering the error, sensitive information could potentially leak

; out of your application such as database usernames and passwords or worse.

; It's recommended that errors be logged on production servers rather than

; having the errors sent to STDOUT.

; Possible Values:

; Off = Do not display any errors

; stderr = Display errors to STDERR (affects only CGI/CLI binaries!)

; On or stdout = Display errors to STDOUT

; Default Value: On

; Development Value: On

; Production Value: Off

; http://www.php.net/manual/en/errorfunc.configuration.php#ini.display-errors

display_errors = Off

; The display of errors which occur during PHP's startup sequence are handled

; separately from display_errors. PHP's default behavior is to suppress those

; errors from clients. Turning the display of startup errors on can be useful in

; debugging configuration problems. But, it's strongly recommended that you

; leave this setting off on production servers.

; Default Value: Off

; Development Value: On

; Production Value: Off

; http://www.php.net/manual/en/errorfunc.configuration.php#ini.display-startup-errors

display_startup_errors = Off

; Besides displaying errors, PHP can also log errors to locations such as a

; server-specific log, STDERR, or a location specified by the error_log

; directive found below. While errors should not be displayed on productions

; servers they should still be monitored and logging is a great way to do that.

; Default Value: Off

; Development Value: On

; Production Value: On

; http://www.php.net/manual/en/errorfunc.configuration.php#ini.log-errors

log_errors = On

; Set maximum length of log_errors. In error_log information about the source is

; added. The default is 1024 and 0 allows to not apply any maximum length at all.

; http://www.php.net/manual/en/errorfunc.configuration.php#ini.log-errors-max-len

log_errors_max_len = 1024

; Do not log repeated messages. Repeated errors must occur in same file on same

; line unless ignore_repeated_source is set true.

; http://www.php.net/manual/en/errorfunc.configuration.php#ini.ignore-repeated-errors

ignore_repeated_errors = Off

; Ignore source of message when ignoring repeated messages. When this setting

; is On you will not log errors with repeated messages from different files or

; source lines.

; http://www.php.net/manual/en/errorfunc.configuration.php#ini.ignore-repeated-source

ignore_repeated_source = Off

; If this parameter is set to Off, then memory leaks will not be shown (on

; stdout or in the log). This has only effect in a debug compile, and if

; error reporting includes E_WARNING in the allowed list

; http://www.php.net/manual/en/errorfunc.configuration.php#ini.report-memleaks

report_memleaks = On

; This setting is on by default.

;report_zend_debug = 0

; Store the last error/warning message in $php_errormsg (boolean). Setting this value

; to On can assist in debugging and is appropriate for development servers. It should

; however be disabled on production servers.

; Default Value: Off

; Development Value: On

; Production Value: Off

; http://www.php.net/manual/en/errorfunc.configuration.php#ini.track-errors

track_errors = Off

; Turn off normal error reporting and emit XML-RPC error XML

; http://www.php.net/manual/en/errorfunc.configuration.php#ini.xmlrpc-errors

;xmlrpc_errors = 0

; An XML-RPC faultCode

;xmlrpc_error_number = 0

; When PHP displays or logs an error, it has the capability of inserting html

; links to documentation related to that error. This directive controls whether

; those HTML links appear in error messages or not. For performance and security

; reasons, it's recommended you disable this on production servers.

; Default Value: On

; Development Value: On

; Production value: Off

; http://www.php.net/manual/en/errorfunc.configuration.php#ini.html-errors

html_errors = Off

; If html_errors is set On PHP produces clickable error messages that direct

; to a page describing the error or function causing the error in detail.

; You can download a copy of the PHP manual from http://www.php.net/docs.php

; and change docref_root to the base URL of your local copy including the

; leading '/'. You must also specify the file extension being used including

; the dot. PHP's default behavior is to leave these settings empty.

; Note: Never use this feature for production boxes.

; http://www.php.net/manual/en/errorfunc.configuration.php#ini.docref-root

; Examples

;docref_root = "/phpmanual/"

; http://www.php.net/manual/en/errorfunc.configuration.php#ini.docref-ext

;docref_ext = .html

; String to output before an error message. PHP's default behavior is to leave

; this setting blank.

; http://www.php.net/manual/en/errorfunc.configuration.php#ini.error-prepend-string

; Example:

;error_prepend_string = "<font color=#ff0000>"

; String to output after an error message. PHP's default behavior is to leave

; this setting blank.

; http://www.php.net/manual/en/errorfunc.configuration.php#ini.error-append-string

; Example:

;error_append_string = "</font>"

; Log errors to specified file. PHP's default behavior is to leave this value

; empty.

; http://www.php.net/manual/en/errorfunc.configuration.php#ini.error-log

; Example:

;error_log = php_errors.log

; Log errors to syslog (Event Log on NT, not valid in Windows 95).

;error_log = syslog

;;;;;;;;;;;;;;;;;

; Data Handling ;

;;;;;;;;;;;;;;;;;

; Note - track_vars is ALWAYS enabled as of PHP 4.0.3

; The separator used in PHP generated URLs to separate arguments.

; PHP's default setting is "&".

; http://www.php.net/manual/en/ini.core.php#ini.arg-separator.output

; Example:

;arg_separator.output = "&amp;"

; List of separator(s) used by PHP to parse input URLs into variables.

; PHP's default setting is "&".

; NOTE: Every character in this directive is considered as separator!

; http://www.php.net/manual/en/ini.core.php#ini.arg-separator.input

; Example:

;arg_separator.input = ";&"

; This directive determines which super global arrays are registered when PHP

; starts up. If the register_globals directive is enabled, it also determines

; what order variables are populated into the global space. G,P,C,E & S are

; abbreviations for the following respective super globals: GET, POST, COOKIE,

; ENV and SERVER. There is a performance penalty paid for the registration of

; these arrays and because ENV is not as commonly used as the others, ENV is

; is not recommended on productions servers. You can still get access to

; the environment variables through getenv() should you need to.

; Default Value: "EGPCS"

; Development Value: "GPCS"

; Production Value: "GPCS";

; http://www.php.net/manual/en/ini.core.php#ini.variables-order

variables_order = "GPCS"

; This directive determines which super global data (G,P,C,E & S) should

; be registered into the super global array REQUEST. If so, it also determines

; the order in which that data is registered. The values for this directive are

; specified in the same manner as the variables_order directive, EXCEPT one.

; Leaving this value empty will cause PHP to use the value set in the

; variables_order directive. It does not mean it will leave the super globals

; array REQUEST empty.

; Default Value: None

; Development Value: "GP"

; Production Value: "GP"

; http://www.php.net/manual/en/ini.core.php#ini.request-order

request_order = "GP"

; Whether or not to register the EGPCS variables as global variables. You may

; want to turn this off if you don't want to clutter your scripts' global scope

; with user data. This makes most sense when coupled with track_vars - in which

; case you can access all of the GPC variables through the $HTTP_*_VARS[],

; variables.

; You should do your best to write your scripts so that they do not require

; register_globals to be on; Using form variables as globals can easily lead

; to possible security problems, if the code is not very well thought of.

; http://www.php.net/manual/en/ini.core.php#ini.register-globals

register_globals = Off

; Determines whether the deprecated long $HTTP_*_VARS type predefined variables

; are registered by PHP or not. As they are deprecated, we obviously don't

; recommend you use them. They are on by default for compatibility reasons but

; they are not recommended on production servers.

; Default Value: On

; Development Value: Off

; Production Value: Off

; http://www.php.net/manual/en/ini.core.php#ini.register-long-arrays

register_long_arrays = Off

; This directive determines whether PHP registers $argv & $argc each time it

; runs. $argv contains an array of all the arguments passed to PHP when a script

; is invoked. $argc contains an integer representing the number of arguments

; that were passed when the script was invoked. These arrays are extremely

; useful when running scripts from the command line. When this directive is

; enabled, registering these variables consumes CPU cycles and memory each time

; a script is executed. For performance reasons, this feature should be disabled

; on production servers.

; Default Value: On

; Development Value: Off

; Production Value: Off

; http://www.php.net/manual/en/ini.core.php#ini.register-argc-argv

register_argc_argv = Off

; When enabled, the SERVER and ENV variables are created when they're first

; used (Just In Time) instead of when the script starts. If these variables

; are not used within a script, having this directive on will result in a

; performance gain. The PHP directives register_globals, register_long_arrays,

; and register_argc_argv must be disabled for this directive to have any affect.

; http://www.php.net/manual/en/ini.core.php#ini.auto-globals-jit

auto_globals_jit = On

; Maximum size of POST data that PHP will accept.

; http://www.php.net/manual/en/ini.core.php#ini.post-max-size

; post_max_size = 8M

post_max_size = 530M

; Magic quotes are a preprocessing feature of PHP where PHP will attempt to

; escape any character sequences in GET, POST, COOKIE and ENV data which might

; otherwise corrupt data being placed in resources such as databases before

; making that data available to you. Because of character encoding issues and

; non-standard SQL implementations across many databases, it's not currently

; possible for this feature to be 100% accurate. PHP's default behavior is to

; enable the feature. We strongly recommend you use the escaping mechanisms

; designed specifically for the database your using instead of relying on this

; feature. Also note, this feature has been deprecated as of PHP 5.3.0 and is

; scheduled for removal in PHP 6.

; Default Value: On

; Development Value: Off

; Production Value: Off

; http://www.php.net/manual/en/info.configuration.php#ini.magic-quotes-gpc

magic_quotes_gpc = Off

; Magic quotes for runtime-generated data, e.g. data from SQL, from exec(), etc.

; http://www.php.net/manual/en/info.configuration.php#ini.magic-quotes-runtime

magic_quotes_runtime = Off

; Use Sybase-style magic quotes (escape ' with '' instead of \').

; http://www.php.net/manual/en/sybase.configuration.php#ini.magic-quotes-sybase

magic_quotes_sybase = Off

; Automatically add files before PHP document.

; http://www.php.net/manual/en/ini.core.php#ini.auto-prepend-file

auto_prepend_file =

; Automatically add files after PHP document.

; http://www.php.net/manual/en/ini.core.php#ini.auto-append-file

auto_append_file =

; As of 4.0b4, PHP always outputs a character encoding by default in

; the Content-type: header. To disable sending of the charset, simply

; set it to be empty.

;

; PHP's built-in default is text/html

; http://www.php.net/manual/en/ini.core.php#ini.default-mimetype

default_mimetype = "text/html"

; PHP's default character set is set to empty.

; http://www.php.net/manual/en/ini.core.php#ini.default-charset

;default_charset = "iso-8859-1"

; Always populate the $HTTP_RAW_POST_DATA variable. PHP's default behavior is

; to disable this feature.

; http://www.php.net/manual/en/ini.core.php#ini.always-populate-raw-post-data

;always_populate_raw_post_data = On

;;;;;;;;;;;;;;;;;;;;;;;;;

; Paths and Directories ;

;;;;;;;;;;;;;;;;;;;;;;;;;

; UNIX: "/path1:/path2"

;include_path = ".:/php/includes"

;

; Windows: "\path1;\path2"

;include_path = ".;c:\php\includes"

;

; PHP's default setting for include_path is ".;/path/to/php/pear"

; http://www.php.net/manual/en/ini.core.php#ini.include-path

; The root of the PHP pages, used only if nonempty.

; if PHP was not compiled with FORCE_REDIRECT, you SHOULD set doc_root

; if you are running php as a CGI under any web server (other than IIS)

; see documentation for security issues. The alternate is to use the

; cgi.force_redirect configuration below

; http://www.php.net/manual/en/ini.core.php#ini.doc-root

doc_root =

; The directory under which PHP opens the script using /~username used only

; if nonempty.

; http://www.php.net/manual/en/ini.core.php#ini.user-dir

user_dir =

; Directory in which the loadable extensions (modules) reside.

; http://www.php.net/manual/en/ini.core.php#ini.extension-dir

; extension_dir = "./"

; Whether or not to enable the dl() function. The dl() function does NOT work

; properly in multithreaded servers, such as IIS or Zeus, and is automatically

; disabled on them.

; http://www.php.net/manual/en/info.configuration.php#ini.enable-dl

enable_dl = Off

; cgi.force_redirect is necessary to provide security running PHP as a CGI under

; most web servers. Left undefined, PHP turns this on by default. You can

; turn it off here AT YOUR OWN RISK

; **You CAN safely turn this off for IIS, in fact, you MUST.**

; http://www.php.net/manual/en/ini.core.php#ini.cgi.force-redirect

;cgi.force_redirect = 1

; if cgi.nph is enabled it will force cgi to always sent Status: 200 with

; every request. PHP's default behavior is to disable this feature.

;cgi.nph = 1

; if cgi.force_redirect is turned on, and you are not running under Apache or Netscape

; (iPlanet) web servers, you MAY need to set an environment variable name that PHP

; will look for to know it is OK to continue execution. Setting this variable MAY

; cause security issues, KNOW WHAT YOU ARE DOING FIRST.

; http://www.php.net/manual/en/ini.core.php#ini.cgi.redirect-status-env

;cgi.redirect_status_env = ;

; cgi.fix_pathinfo provides *real* PATH_INFO/PATH_TRANSLATED support for CGI. PHP's

; previous behaviour was to set PATH_TRANSLATED to SCRIPT_FILENAME, and to not grok

; what PATH_INFO is. For more information on PATH_INFO, see the cgi specs. Setting

; this to 1 will cause PHP CGI to fix its paths to conform to the spec. A setting

; of zero causes PHP to behave as before. Default is 1. You should fix your scripts

; to use SCRIPT_FILENAME rather than PATH_TRANSLATED.

; http://www.php.net/manual/en/ini.core.php#ini.cgi.fix-pathinfo

;cgi.fix_pathinfo=1

; FastCGI under IIS (on WINNT based OS) supports the ability to impersonate

; security tokens of the calling client. This allows IIS to define the

; security context that the request runs under. mod_fastcgi under Apache

; does not currently support this feature (03/17/2002)

; Set to 1 if running under IIS. Default is zero.

; http://www.php.net/manual/en/ini.core.php#ini.fastcgi.impersonate

;fastcgi.impersonate = 1;

; Disable logging through FastCGI connection. PHP's default behavior is to enable

; this feature.

;fastcgi.logging = 0

; cgi.rfc2616_headers configuration option tells PHP what type of headers to

; use when sending HTTP response code. If it's set 0 PHP sends Status: header that

; is supported by Apache. When this option is set to 1 PHP will send

; RFC2616 compliant header.

; Default is zero.

; http://www.php.net/manual/en/ini.core.php#ini.cgi.rfc2616-headers

;cgi.rfc2616_headers = 0

;;;;;;;;;;;;;;;;

; File Uploads ;

;;;;;;;;;;;;;;;;

; Whether to allow HTTP file uploads.

; http://www.php.net/manual/en/ini.core.php#ini.file-uploads

file_uploads = On

; Temporary directory for HTTP uploaded files (will use system default if not

; specified).

; http://www.php.net/manual/en/ini.core.php#ini.upload-tmp-dir

;upload_tmp_dir =

; Maximum allowed size for uploaded files.

; http://www.php.net/manual/en/ini.core.php#ini.upload-max-filesize

; upload_max_filesize = 2M

upload_max_filesize = 520M

;;;;;;;;;;;;;;;;;;

; Fopen wrappers ;

;;;;;;;;;;;;;;;;;;

; Whether to allow the treatment of URLs (like http:// or ftp://) as files.

; http://www.php.net/manual/en/filesystem.configuration.php#ini.allow-url-fopen

allow_url_fopen = On

; Whether to allow include/require to open URLs (like http:// or ftp://) as files.

; http://www.php.net/manual/en/filesystem.configuration.php#ini.allow-url-include

allow_url_include = Off

; Define the anonymous ftp password (your email address). PHP's default setting

; for this is empty.

; http://www.php.net/manual/en/filesystem.configuration.php#ini.from

;from="john@doe.com"

; Define the User-Agent string. PHP's default setting for this is empty.

; http://www.php.net/manual/en/filesystem.configuration.php#ini.user-agent

;user_agent="PHP"

; Default timeout for socket based streams (seconds)

; http://www.php.net/manual/en/filesystem.configuration.php#ini.default-socket-timeout

default_socket_timeout = 60

; If your scripts have to deal with files from Macintosh systems,

; or you are running on a Mac and need to deal with files from

; unix or win32 systems, setting this flag will cause PHP to

; automatically detect the EOL character in those files so that

; fgets() and file() will work regardless of the source of the file.

; http://www.php.net/manual/en/filesystem.configuration.php#ini.auto-detect-line-endings

;auto_detect_line_endings = Off

;;;;;;;;;;;;;;;;;;;;;;

; Dynamic Extensions ;

;;;;;;;;;;;;;;;;;;;;;;

; If you wish to have an extension loaded automatically, use the following

; syntax:

;

; extension=modulename.extension

;

; For example

;

; extension=msql.so

;

; ... or with a path:

;

; extension=/path/to/extension/msql.so

;

; If you only provide the name of the extension, PHP will look for it in its

; default extension directory.

;;;;

; Note: packaged extension modules are now loaded via the .ini files

; found in the directory /etc/php.d; these are loaded by default.

;;;;

;;;;;;;;;;;;;;;;;;;

; Module Settings ;

;;;;;;;;;;;;;;;;;;;

[Date]

; Defines the default timezone used by the date functions

; http://www.php.net/manual/en/datetime.configuration.php#ini.date.timezone

;date.timezone =

date.timezone = "Europe/Paris"

; http://www.php.net/manual/en/datetime.configuration.php#ini.date.default-latitude

;date.default_latitude = 31.7667

; http://www.php.net/manual/en/datetime.configuration.php#ini.date.default-longitude

;date.default_longitude = 35.2333

; http://www.php.net/manual/en/datetime.configuration.php#ini.date.sunrise-zenith

;date.sunrise_zenith = 90.583333

; http://www.php.net/manual/en/datetime.configuration.php#ini.date.sunset-zenith

;date.sunset_zenith = 90.583333

[filter]

; http://www.php.net/manual/en/filter.configuration.php#ini.filter.default

;filter.default = unsafe_raw

; http://www.php.net/manual/en/filter.configuration.php#ini.filter.default-flags

;filter.default_flags =

[iconv]

;iconv.input_encoding = ISO-8859-1

iconv.input_encoding = UTF-8

;iconv.internal_encoding = ISO-8859-1

iconv.internal_encoding = UTF-8

;iconv.output_encoding = ISO-8859-1

iconv.output_encoding = UTF-8

[intl]

;intl.default_locale =

[sqlite]

; http://www.php.net/manual/en/sqlite.configuration.php#ini.sqlite.assoc-case

;sqlite.assoc_case = 0

[sqlite3]

;sqlite3.extension_dir =

[Pcre]

;PCRE library backtracking limit.

; http://www.php.net/manual/en/pcre.configuration.php#ini.pcre.backtrack-limit

;pcre.backtrack_limit=100000

;PCRE library recursion limit.

;Please note that if you set this value to a high number you may consume all

;the available process stack and eventually crash PHP (due to reaching the

;stack size limit imposed by the Operating System).

; http://www.php.net/manual/en/pcre.configuration.php#ini.pcre.recursion-limit

;pcre.recursion_limit=100000

[Pdo]

; Whether to pool ODBC connections. Can be one of "strict", "relaxed" or "off"

; http://www.php.net/manual/en/ref.pdo-odbc.php#ini.pdo-odbc.connection-pooling

;pdo_odbc.connection_pooling=strict

[Phar]

; http://www.php.net/manual/en/phar.configuration.php#ini.phar.readonly

;phar.readonly = On

; http://www.php.net/manual/en/phar.configuration.php#ini.phar.require-hash

;phar.require_hash = On

;phar.cache_list =

[Syslog]

; Whether or not to define the various syslog variables (e.g. $LOG_PID,

; $LOG_CRON, etc.). Turning it off is a good idea performance-wise. In

; runtime, you can define these variables by calling define_syslog_variables().

; http://www.php.net/manual/en/network.configuration.php#ini.define-syslog-variables

define_syslog_variables = Off

[mail function]

; For Win32 only.

; http://www.php.net/manual/en/mail.configuration.php#ini.smtp

SMTP = localhost

; http://www.php.net/manual/en/mail.configuration.php#ini.smtp-port

smtp_port = 25

; For Win32 only.

; http://www.php.net/manual/en/mail.configuration.php#ini.sendmail-from

;sendmail_from = me@example.com

; For Unix only. You may supply arguments as well (default: "sendmail -t -i").

; http://www.php.net/manual/en/mail.configuration.php#ini.sendmail-path

sendmail_path = /usr/sbin/sendmail -t -i

; Force the addition of the specified parameters to be passed as extra parameters

; to the sendmail binary. These parameters will always replace the value of

; the 5th parameter to mail(), even in safe mode.

;mail.force_extra_parameters =

; Add X-PHP-Originaiting-Script: that will include uid of the script followed by the filename

mail.add_x_header = On

; Log all mail() calls including the full path of the script, line #, to address and headers

;mail.log =

[SQL]

; http://www.php.net/manual/en/ini.core.php#ini.sql.safe-mode

sql.safe_mode = Off

[ODBC]

; http://www.php.net/manual/en/odbc.configuration.php#ini.uodbc.default-db

;odbc.default_db = Not yet implemented

; http://www.php.net/manual/en/odbc.configuration.php#ini.uodbc.default-user

;odbc.default_user = Not yet implemented

; http://www.php.net/manual/en/odbc.configuration.php#ini.uodbc.default-pw

;odbc.default_pw = Not yet implemented

; Allow or prevent persistent links.

; http://www.php.net/manual/en/odbc.configuration.php#ini.uodbc.allow-persistent

odbc.allow_persistent = On

; Check that a connection is still valid before reuse.

; http://www.php.net/manual/en/odbc.configuration.php#ini.uodbc.check-persistent

odbc.check_persistent = On

; Maximum number of persistent links. -1 means no limit.

; http://www.php.net/manual/en/odbc.configuration.php#ini.uodbc.max-persistent

odbc.max_persistent = -1

; Maximum number of links (persistent + non-persistent). -1 means no limit.

; http://www.php.net/manual/en/odbc.configuration.php#ini.uodbc.max-links

odbc.max_links = -1

; Handling of LONG fields. Returns number of bytes to variables. 0 means

; passthru.

; http://www.php.net/manual/en/odbc.configuration.php#ini.uodbc.defaultlrl

odbc.defaultlrl = 4096

; Handling of binary data. 0 means passthru, 1 return as is, 2 convert to char.

; See the documentation on odbc_binmode and odbc_longreadlen for an explanation

; of uodbc.defaultlrl and uodbc.defaultbinmode

; http://www.php.net/manual/en/odbc.configuration.php#ini.uodbc.defaultbinmode

odbc.defaultbinmode = 1

;birdstep.max_links = -1

[MySQL]

; Allow or prevent persistent links.

; http://www.php.net/manual/en/mysql.configuration.php#ini.mysql.allow-persistent

mysql.allow_persistent = On

; Maximum number of persistent links. -1 means no limit.

; http://www.php.net/manual/en/mysql.configuration.php#ini.mysql.max-persistent

mysql.max_persistent = -1

; Maximum number of links (persistent + non-persistent). -1 means no limit.

; http://www.php.net/manual/en/mysql.configuration.php#ini.mysql.max-links

mysql.max_links = -1

; Default port number for mysql_connect(). If unset, mysql_connect() will use

; the $MYSQL_TCP_PORT or the mysql-tcp entry in /etc/services or the

; compile-time value defined MYSQL_PORT (in that order). Win32 will only look

; at MYSQL_PORT.

; http://www.php.net/manual/en/mysql.configuration.php#ini.mysql.default-port

mysql.default_port =

; Default socket name for local MySQL connects. If empty, uses the built-in

; MySQL defaults.

; http://www.php.net/manual/en/mysql.configuration.php#ini.mysql.default-socket

mysql.default_socket =

; Default host for mysql_connect() (doesn't apply in safe mode).

; http://www.php.net/manual/en/mysql.configuration.php#ini.mysql.default-host

mysql.default_host =

; Default user for mysql_connect() (doesn't apply in safe mode).

; http://www.php.net/manual/en/mysql.configuration.php#ini.mysql.default-user

mysql.default_user =

; Default password for mysql_connect() (doesn't apply in safe mode).

; Note that this is generally a *bad* idea to store passwords in this file.

; *Any* user with PHP access can run 'echo get_cfg_var("mysql.default_password")

; and reveal this password! And of course, any users with read access to this

; file will be able to reveal the password as well.

; http://www.php.net/manual/en/mysql.configuration.php#ini.mysql.default-password

mysql.default_password =

; Maximum time (in seconds) for connect timeout. -1 means no limit

; http://www.php.net/manual/en/mysql.configuration.php#ini.mysql.connect-timeout

mysql.connect_timeout = 60

; Trace mode. When trace_mode is active (=On), warnings for table/index scans and

; SQL-Errors will be displayed.

; http://www.php.net/manual/en/mysql.configuration.php#ini.mysql.trace-mode

mysql.trace_mode = Off

[MySQLi]

; Maximum number of links. -1 means no limit.

; http://www.php.net/manual/en/mysqli.configuration.php#ini.mysqli.max-links

mysqli.max_links = -1

; Default port number for mysqli_connect(). If unset, mysqli_connect() will use

; the $MYSQL_TCP_PORT or the mysql-tcp entry in /etc/services or the

; compile-time value defined MYSQL_PORT (in that order). Win32 will only look

; at MYSQL_PORT.

; http://www.php.net/manual/en/mysqli.configuration.php#ini.mysqli.default-port

mysqli.default_port = 3306

; Default socket name for local MySQL connects. If empty, uses the built-in

; MySQL defaults.

; http://www.php.net/manual/en/mysqli.configuration.php#ini.mysqli.default-socket

mysqli.default_socket =

; Default host for mysql_connect() (doesn't apply in safe mode).

; http://www.php.net/manual/en/mysqli.configuration.php#ini.mysqli.default-host

mysqli.default_host =

; Default user for mysql_connect() (doesn't apply in safe mode).

; http://www.php.net/manual/en/mysqli.configuration.php#ini.mysqli.default-user

mysqli.default_user =

; Default password for mysqli_connect() (doesn't apply in safe mode).

; Note that this is generally a *bad* idea to store passwords in this file.

; *Any* user with PHP access can run 'echo get_cfg_var("mysqli.default_pw")

; and reveal this password! And of course, any users with read access to this

; file will be able to reveal the password as well.

; http://www.php.net/manual/en/mysqli.configuration.php#ini.mysqli.default-pw

mysqli.default_pw =

; Allow or prevent reconnect

mysqli.reconnect = Off

[PostgresSQL]

; Allow or prevent persistent links.

; http://www.php.net/manual/en/pgsql.configuration.php#ini.pgsql.allow-persistent

pgsql.allow_persistent = On

; Detect broken persistent links always with pg_pconnect().

; Auto reset feature requires a little overheads.

; http://www.php.net/manual/en/pgsql.configuration.php#ini.pgsql.auto-reset-persistent

pgsql.auto_reset_persistent = Off

; Maximum number of persistent links. -1 means no limit.

; http://www.php.net/manual/en/pgsql.configuration.php#ini.pgsql.max-persistent

pgsql.max_persistent = -1

; Maximum number of links (persistent+non persistent). -1 means no limit.

; http://www.php.net/manual/en/pgsql.configuration.php#ini.pgsql.max-links

pgsql.max_links = -1

; Ignore PostgreSQL backends Notice message or not.

; Notice message logging require a little overheads.

; http://www.php.net/manual/en/pgsql.configuration.php#ini.pgsql.ignore-notice

pgsql.ignore_notice = 0

; Log PostgreSQL backends Noitce message or not.

; Unless pgsql.ignore_notice=0, module cannot log notice message.

; http://www.php.net/manual/en/pgsql.configuration.php#ini.pgsql.log-notice

pgsql.log_notice = 0

[Sybase-CT]

; Allow or prevent persistent links.

; http://www.php.net/manual/en/sybase.configuration.php#ini.sybct.allow-persistent

sybct.allow_persistent = On

; Maximum number of persistent links. -1 means no limit.

; http://www.php.net/manual/en/sybase.configuration.php#ini.sybct.max-persistent

sybct.max_persistent = -1

; Maximum number of links (persistent + non-persistent). -1 means no limit.

; http://www.php.net/manual/en/sybase.configuration.php#ini.sybct.max-links

sybct.max_links = -1

; Minimum server message severity to display.

; http://www.php.net/manual/en/sybase.configuration.php#ini.sybct.min-server-severity

sybct.min_server_severity = 10

; Minimum client message severity to display.

; http://www.php.net/manual/en/sybase.configuration.php#ini.sybct.min-client-severity

sybct.min_client_severity = 10

; Set per-context timeout

; http://www.php.net/manual/en/sybase.configuration.php#ini.sybct.timeout

;sybct.timeout=

;sybct.packet_size

[bcmath]

; Number of decimal digits for all bcmath functions.

; http://www.php.net/manual/en/bc.configuration.php#ini.bcmath.scale

bcmath.scale = 0

[browscap]

; http://www.php.net/manual/en/misc.configuration.php#ini.browscap

;browscap = extra/browscap.ini

[Session]

; Handler used to store/retrieve data.

; http://www.php.net/manual/en/session.configuration.php#ini.session.save-handler

session.save_handler = files

; Argument passed to save_handler. In the case of files, this is the path

; where data files are stored. Note: Windows users have to change this

; variable in order to use PHP's session functions.

;

; As of PHP 4.0.1, you can define the path as:

;

; session.save_path = "N;/path"

;

; where N is an integer. Instead of storing all the session files in

; /path, what this will do is use subdirectories N-levels deep, and

; store the session data in those directories. This is useful if you

; or your OS have problems with lots of files in one directory, and is

; a more efficient layout for servers that handle lots of sessions.

;

; NOTE 1: PHP will not create this directory structure automatically.

; You can use the script in the ext/session dir for that purpose.

; NOTE 2: See the section on garbage collection below if you choose to

; use subdirectories for session storage

;

; The file storage module creates files using mode 600 by default.

; You can change that by using

;

; session.save_path = "N;MODE;/path"

;

; where MODE is the octal representation of the mode. Note that this

; does not overwrite the process's umask.

; http://www.php.net/manual/en/session.configuration.php#ini.session.save-path

session.save_path = "/var/lib/php/session"

; Whether to use cookies.

; http://www.php.net/manual/en/session.configuration.php#ini.session.use-cookies

session.use_cookies = 1

; http://www.php.net/manual/en/session.configuration.php#ini.session.cookie-secure

;session.cookie_secure =

; This option forces PHP to fetch and use a cookie for storing and maintaining

; the session id. We encourage this operation as it's very helpful in combatting

; session hijacking when not specifying and managing your own session id. It is

; not the end all be all of session hijacking defense, but it's a good start.

; http://www.php.net/manual/en/session.configuration.php#ini.session.use-only-cookies

session.use_only_cookies = 1

; Name of the session (used as cookie name).

; http://www.php.net/manual/en/session.configuration.php#ini.session.name

session.name = PHPSESSID

; Initialize session on request startup.

; http://www.php.net/manual/en/session.configuration.php#ini.session.auto-start

session.auto_start = 0

; Lifetime in seconds of cookie or, if 0, until browser is restarted.

; http://www.php.net/manual/en/session.configuration.php#ini.session.cookie-lifetime

session.cookie_lifetime = 0

; The path for which the cookie is valid.

; http://www.php.net/manual/en/session.configuration.php#ini.session.cookie-path

session.cookie_path = /

; The domain for which the cookie is valid.

; http://www.php.net/manual/en/session.configuration.php#ini.session.cookie-domain

session.cookie_domain =

; Whether or not to add the httpOnly flag to the cookie, which makes it inaccessible to browser scripting languages such as JavaScript.

; http://www.php.net/manual/en/session.configuration.php#ini.session.cookie-httponly

session.cookie_httponly =

; Handler used to serialize data. php is the standard serializer of PHP.

; http://www.php.net/manual/en/session.configuration.php#ini.session.serialize-handler

session.serialize_handler = php

; Defines the probability that the 'garbage collection' process is started

; on every session initialization. The probability is calculated by using

; gc_probability/gc_divisor. Where session.gc_probability is the numerator

; and gc_divisor is the denominator in the equation. Setting this value to 1

; when the session.gc_divisor value is 100 will give you approximately a 1% chance

; the gc will run on any give request.

; Default Value: 1

; Development Value: 1

; Production Value: 1

; http://www.php.net/manual/en/session.configuration.php#ini.session.gc-probability

session.gc_probability = 1

; Defines the probability that the 'garbage collection' process is started on every

; session initialization. The probability is calculated by using the following equation:

; gc_probability/gc_divisor. Where session.gc_probability is the numerator and

; session.gc_divisor is the denominator in the equation. Setting this value to 1

; when the session.gc_divisor value is 100 will give you approximately a 1% chance

; the gc will run on any give request. Increasing this value to 1000 will give you

; a 0.1% chance the gc will run on any give request. For high volume production servers,

; this is a more efficient approach.

; Default Value: 100

; Development Value: 1000

; Production Value: 1000

; http://www.php.net/manual/en/session.configuration.php#ini.session.gc-divisor

session.gc_divisor = 1000

; After this number of seconds, stored data will be seen as 'garbage' and

; cleaned up by the garbage collection process.

; http://www.php.net/manual/en/session.configuration.php#ini.session.gc-maxlifetime

session.gc_maxlifetime = 1440

; NOTE: If you are using the subdirectory option for storing session files

; (see session.save_path above), then garbage collection does *not*

; happen automatically. You will need to do your own garbage

; collection through a shell script, cron entry, or some other method.

; For example, the following script would is the equivalent of

; setting session.gc_maxlifetime to 1440 (1440 seconds = 24 minutes):

; cd /path/to/sessions; find -cmin +24 | xargs rm

; PHP 4.2 and less have an undocumented feature/bug that allows you to

; to initialize a session variable in the global scope, even when register_globals

; is disabled. PHP 4.3 and later will warn you, if this feature is used.

; You can disable the feature and the warning separately. At this time,

; the warning is only displayed, if bug_compat_42 is enabled. This feature

; introduces some serious security problems if not handled correctly. It's

; recommended that you do not use this feature on production servers. But you

; should enable this on development servers and enable the warning as well. If you

; do not enable the feature on development servers, you won't be warned when it's

; used and debugging errors caused by this can be difficult to track down.

; Default Value: On

; Development Value: On

; Production Value: Off

; http://www.php.net/manual/en/session.configuration.php#ini.session.bug-compat-42

session.bug_compat_42 = Off

; This setting controls whether or not you are warned by PHP when initializing a

; session value into the global space. session.bug_compat_42 must be enabled before

; these warnings can be issued by PHP. See the directive above for more information.

; Default Value: On

; Development Value: On

; Production Value: Off

; http://www.php.net/manual/en/session.configuration.php#ini.session.bug-compat-warn

session.bug_compat_warn = Off

; Check HTTP Referer to invalidate externally stored URLs containing ids.

; HTTP_REFERER has to contain this substring for the session to be

; considered as valid.

; http://www.php.net/manual/en/session.configuration.php#ini.session.referer-check

session.referer_check =

; How many bytes to read from the file.

; http://www.php.net/manual/en/session.configuration.php#ini.session.entropy-length

session.entropy_length = 0

; Specified here to create the session id.

; http://www.php.net/manual/en/session.configuration.php#ini.session.entropy-file

;session.entropy_file = /dev/urandom

session.entropy_file =

; http://www.php.net/manual/en/session.configuration.php#ini.session.entropy-length

;session.entropy_length = 16

; Set to {nocache,private,public,} to determine HTTP caching aspects

; or leave this empty to avoid sending anti-caching headers.

; http://www.php.net/manual/en/session.configuration.php#ini.session.cache-limiter

session.cache_limiter = nocache

; Document expires after n minutes.

; http://www.php.net/manual/en/session.configuration.php#ini.session.cache-expire

session.cache_expire = 180

; trans sid support is disabled by default.

; Use of trans sid may risk your users security.

; Use this option with caution.

; - User may send URL contains active session ID

; to other person via. email/irc/etc.

; - URL that contains active session ID may be stored

; in publically accessible computer.

; - User may access your site with the same session ID

; always using URL stored in browser's history or bookmarks.

; http://www.php.net/manual/en/session.configuration.php#ini.session.use-trans-sid

session.use_trans_sid = 0

; Select a hash function for use in generating session ids.

; Possible Values

; 0 (MD5 128 bits)

; 1 (SHA-1 160 bits)

; http://www.php.net/manual/en/session.configuration.php#ini.session.hash-function

session.hash_function = 0

; Define how many bits are stored in each character when converting

; the binary hash data to something readable.

; Possible values:

; 4 (4 bits: 0-9, a-f)

; 5 (5 bits: 0-9, a-v)

; 6 (6 bits: 0-9, a-z, A-Z, "-", ",")

; Default Value: 4

; Development Value: 5

; Production Value: 5

; http://www.php.net/manual/en/session.configuration.php#ini.session.hash-bits-per-character

session.hash_bits_per_character = 5

; The URL rewriter will look for URLs in a defined set of HTML tags.

; form/fieldset are special; if you include them here, the rewriter will

; add a hidden <input> field with the info which is otherwise appended

; to URLs. If you want XHTML conformity, remove the form entry.

; Note that all valid entries require a "=", even if no value follows.

; Default Value: "a=href,area=href,frame=src,form=,fieldset="

; Development Value: "a=href,area=href,frame=src,input=src,form=fakeentry"

; Production Value: "a=href,area=href,frame=src,input=src,form=fakeentry"

; http://www.php.net/manual/en/session.configuration.php#ini.url-rewriter.tags

url_rewriter.tags = "a=href,area=href,frame=src,input=src,form=fakeentry"

[MSSQL]

; Allow or prevent persistent links.

mssql.allow_persistent = On

; Maximum number of persistent links. -1 means no limit.

mssql.max_persistent = -1

; Maximum number of links (persistent+non persistent). -1 means no limit.

mssql.max_links = -1

; Minimum error severity to display.

mssql.min_error_severity = 10

; Minimum message severity to display.

mssql.min_message_severity = 10

; Compatibility mode with old versions of PHP 3.0.

mssql.compatability_mode = Off

; Connect timeout

;mssql.connect_timeout = 5

; Query timeout

;mssql.timeout = 60

; Valid range 0 - 2147483647. Default = 4096.

;mssql.textlimit = 4096

; Valid range 0 - 2147483647. Default = 4096.

;mssql.textsize = 4096

; Limits the number of records in each batch. 0 = all records in one batch.

;mssql.batchsize = 0

; Specify how datetime and datetim4 columns are returned

; On => Returns data converted to SQL server settings

; Off => Returns values as YYYY-MM-DD hh:mm:ss

;mssql.datetimeconvert = On

; Use NT authentication when connecting to the server

mssql.secure_connection = Off

; Specify max number of processes. -1 = library default

; msdlib defaults to 25

; FreeTDS defaults to 4096

;mssql.max_procs = -1

; Specify client character set.

; If empty or not set the client charset from freetds.comf is used

; This is only used when compiled with FreeTDS

;mssql.charset = "ISO-8859-1"

[Assertion]

; Assert(expr); active by default.

; http://www.php.net/manual/en/info.configuration.php#ini.assert.active

;assert.active = On

; Issue a PHP warning for each failed assertion.

; http://www.php.net/manual/en/info.configuration.php#ini.assert.warning

;assert.warning = On

; Don't bail out by default.

; http://www.php.net/manual/en/info.configuration.php#ini.assert.bail

;assert.bail = Off

; User-function to be called if an assertion fails.

; http://www.php.net/manual/en/info.configuration.php#ini.assert.callback

;assert.callback = 0

; Eval the expression with current error_reporting(). Set to true if you want

; error_reporting(0) around the eval().

; http://www.php.net/manual/en/info.configuration.php#ini.assert.quiet-eval

;assert.quiet_eval = 0

[COM]

; path to a file containing GUIDs, IIDs or filenames of files with TypeLibs

; http://www.php.net/manual/en/com.configuration.php#ini.com.typelib-file

;com.typelib_file =

; allow Distributed-COM calls

; http://www.php.net/manual/en/com.configuration.php#ini.com.allow-dcom

;com.allow_dcom = true

; autoregister constants of a components typlib on com_load()

; http://www.php.net/manual/en/com.configuration.php#ini.com.autoregister-typelib

;com.autoregister_typelib = true

; register constants casesensitive

; http://www.php.net/manual/en/com.configuration.php#ini.com.autoregister-casesensitive

;com.autoregister_casesensitive = false

; show warnings on duplicate constant registrations

; http://www.php.net/manual/en/com.configuration.php#ini.com.autoregister-verbose

;com.autoregister_verbose = true

[mbstring]

; language for internal character representation.

; http://www.php.net/manual/en/mbstring.configuration.php#ini.mbstring.language

;mbstring.language = Japanese

mbstring.language= "UTF-8"

; internal/script encoding.

; Some encoding cannot work as internal encoding.

; (e.g. SJIS, BIG5, ISO-2022-*)

; http://www.php.net/manual/en/mbstring.configuration.php#ini.mbstring.internal-encoding

;mbstring.internal_encoding = EUC-JP

mbstring.internal_encoding= "UTF-8"

; http input encoding.

; http://www.php.net/manual/en/mbstring.configuration.php#ini.mbstring.http-input

;mbstring.http_input = auto

mbstring.http_input= "UTF-8"

; http output encoding. mb_output_handler must be

; registered as output buffer to function

; http://www.php.net/manual/en/mbstring.configuration.php#ini.mbstring.http-output

;mbstring.http_output = SJIS

mbstring.http_output= "UTF-8"

; enable automatic encoding translation according to

; mbstring.internal_encoding setting. Input chars are

; converted to internal encoding by setting this to On.

; Note: Do _not_ use automatic encoding translation for

; portable libs/applications.

; http://www.php.net/manual/en/mbstring.configuration.php#ini.mbstring.encoding-translation

;mbstring.encoding_translation = Off

; automatic encoding detection order.

; auto means

; http://www.php.net/manual/en/mbstring.configuration.php#ini.mbstring.detect-order

;mbstring.detect_order = auto

mbstring.detect_order= "UTF-8"

; substitute_character used when character cannot be converted

; one from another

; http://www.php.net/manual/en/mbstring.configuration.php#ini.mbstring.substitute-character

;mbstring.substitute_character = none;

; overload(replace) single byte functions by mbstring functions.

; mail(), ereg(), etc are overloaded by mb_send_mail(), mb_ereg(),

; etc. Possible values are 0,1,2,4 or combination of them.

; For example, 7 for overload everything.

; 0: No overload

; 1: Overload mail() function

; 2: Overload str*() functions

; 4: Overload ereg*() functions

; http://www.php.net/manual/en/mbstring.configuration.php#ini.mbstring.func-overload

;mbstring.func_overload = 0

; enable strict encoding detection.

;mbstring.strict_detection = Off

; This directive specifies the regex pattern of content types for which mb_output_handler()

; is activated.

; Default: mbstring.http_output_conv_mimetype=^(text/|application/xhtml\+xml)

;mbstring.http_output_conv_mimetype=

[gd]

; Tell the jpeg decode to ignore warnings and try to create

; a gd image. The warning will then be displayed as notices

; disabled by default

; http://www.php.net/manual/en/image.configuration.php#ini.image.jpeg-ignore-warning

;gd.jpeg_ignore_warning = 0

[exif]

; Exif UNICODE user comments are handled as UCS-2BE/UCS-2LE and JIS as JIS.

; With mbstring support this will automatically be converted into the encoding

; given by corresponding encode setting. When empty mbstring.internal_encoding

; is used. For the decode settings you can distinguish between motorola and

; intel byte order. A decode setting cannot be empty.

; http://www.php.net/manual/en/exif.configuration.php#ini.exif.encode-unicode

;exif.encode_unicode = ISO-8859-15

; http://www.php.net/manual/en/exif.configuration.php#ini.exif.decode-unicode-motorola

;exif.decode_unicode_motorola = UCS-2BE

; http://www.php.net/manual/en/exif.configuration.php#ini.exif.decode-unicode-intel

;exif.decode_unicode_intel = UCS-2LE

; http://www.php.net/manual/en/exif.configuration.php#ini.exif.encode-jis

;exif.encode_jis =

; http://www.php.net/manual/en/exif.configuration.php#ini.exif.decode-jis-motorola

;exif.decode_jis_motorola = JIS

; http://www.php.net/manual/en/exif.configuration.php#ini.exif.decode-jis-intel

;exif.decode_jis_intel = JIS

[Tidy]

; The path to a default tidy configuration file to use when using tidy

; http://www.php.net/manual/en/tidy.configuration.php#ini.tidy.default-config

;tidy.default_config = /usr/local/lib/php/default.tcfg

; Should tidy clean and repair output automatically?

; WARNING: Do not use this option if you are generating non-html content

; such as dynamic images

; http://www.php.net/manual/en/tidy.configuration.php#ini.tidy.clean-output

tidy.clean_output = Off

[soap]

; Enables or disables WSDL caching feature.

; http://www.php.net/manual/en/soap.configuration.php#ini.soap.wsdl-cache-enabled

soap.wsdl_cache_enabled=1

; Sets the directory name where SOAP extension will put cache files.

; http://www.php.net/manual/en/soap.configuration.php#ini.soap.wsdl-cache-dir

soap.wsdl_cache_dir="/tmp"

; (time to live) Sets the number of second while cached file will be used

; instead of original one.

; http://www.php.net/manual/en/soap.configuration.php#ini.soap.wsdl-cache-ttl

soap.wsdl_cache_ttl=86400

[sysvshm]

; A default size of the shared memory segment

;sysvshm.init_mem = 10000

; Local Variables:

; tab-width: 4

; End:

; php_value error_reporting 6143

Créé avec HelpNDoc Personal Edition: Création d'aide CHM, PDF, DOC et HTML d'une même source


Données SQL de test

SAdmins ›› Installation ›› Serveur web ››

Il existe un jeu de données SQL de test à trouver dans /application/config/install/testData.install.sql.

Ces données contiennent quelques utilisateurs, un établissement ainsi que des statistiques complètes.

login | NOM | Prénom | Rôles
BXX99899 | FONFEC | Sophie | Elève
BXX99799 | PTITGOUTT | Justine | Elève
BXX99999 | LAGAFFE | Gaston | sAdmin
BXX99699 | PTITGOUTT | Corinne | Chef d'établissement
BXX99599 | CHARLIE | Jesuis | Enseignant
BXX99499 | LALALALALALA | Strasky & Hutch | Enseignant
BXX99399 | PTITGOUTT | Anne | Enseignant
BXX99299 | TALUT | Jean | Enseignant

Pour vous connecter avec ces rôles, en développement uniquement, vous devez modifier le fichier de configuration :

  1. Choisir comme adaptateur d'authentification "development" (clef ['auth']['activeAdapters']['pr']).
  2. Indiquer dans la config de l'adaptateur le login choisi (clef ['auth']['adapters']['development']['config']['loginUID']).

Créé avec HelpNDoc Personal Edition: Créer des documents d'aide PDF facilement


Serveur de fichiers

SAdmins ›› Installation ››

Monter un serveur de fichiers externe à Médiacad

Si le serveur de fichiers est distinct du serveur web, vous devez obligatoirement respecter la structure de dossiers de /local/media.

Vous indiquerez dans le fichier de configuration le path permettant d'accéder aux médias.

Apache doit avoir les droits de lecture, exécution, modification et suppression sur tous les fichiers contenus dans /media.

Dans /local/config/application.cfg.array.php, modifier les entrées suivantes :

['medias']['uploadPath'] => path d'upload, sur le serveur web de Médiacad obligatoirement

['medias']['tmpPath'] => path pour les fichiers temporaires, sur le serveur de fichiers

['medias']['sourcePath'] => path pour les fichiers sources, sur le serveur de fichiers

['medias']['encodedPath'] => path pour les fichiers encodés, sur le serveur de fichiers

Les trois derniers dossiers doivent respecter chacun l'arborescence de /local/media/tmp, /local/media/source et /local/media/encoded

C'est tout : le serveur de fichiers externe est pris en compte.

Créé avec HelpNDoc Personal Edition: Créer des documents d'aide HTML facilement


Serveur(s) d'encodage

SAdmins ›› Installation ››

Monter un serveur d'encodage externe à Médiacad

Médiacad dispose de 4 webServices permettant d'obtenir le nombre de tâches d'encodage en cours ou une nouvelle tâche, et d'indiquer un succès ou une erreur d'encodage.

C'est via ces webServices que le serveur d'encodage va interagir avec Médiacad.

La répartition des rôles est très claire et doit être respectée à la lettre :

  • Médiacad gère tout le code métier de l'application : upload des fichiers, traitements, transfert vers le serveur de fichiers éventuel, génération des commandes d'encodage.
  • Le serveur d'encodage ne sert qu'à encoder et à rien d'autre : il demande une tâche à réaliser, il la réalise puis il indique à Médiacad si cette tâche a été réalisée avec succès ou a connu une erreur.
  • A la réception du message de succès ou d'erreur, Médiacad finalise l'encodage (gestion des erreurs, metadonnées, mise à disposition des médias...).

Un script python tournant sur le serveur d'encodage est disponible. Il gère toutes les opérations d'encodage externes.

Changer la configuration

Dans /local/config/application.cfg.array.php, modifier les entrées suivantes :

['medias']['isAllowedEncoding'] = false => Médiacad ne réalisera plus d'encodage

['medias']['maxParallelEncoding'] = XX => nombre maxi d'encodages en parallèle sur le serveur d'encodage

tous les paths de la partie ['medias']['encode'] concernent le serveur web de Médiacad, pas le serveur d'encodage

dans ['auth']['adapters']['salt']['config']['passwords'], ajouter une entrée pour le serveur d'encodage différente de Médiacad (ce sera le login), par exemple "encodeServer", et indiquer son mot de passe.

Dans /local/config/wsAcl.cfg.array.php, modifier les entrées suivantes :

dans ['ws']['encode']['getinprogresstaskcount'], ['getnexttask'], ['setencodesuccess'] et ['setencodeerror'], ajouter le login du serveur d'encodage ("encodeServer" dans notre exemple).

La documentation ci-dessous n'est utile que si vous ne souhaitez pas utiliser le script python fourni.

Requêter les webServices de Médiacad

Les webServices utilisent par défaut l'adaptateur d'authentification salt (= "grain de sel").

Le principe :

  1. le serveur d'encodage essaie de se connecter au ws ; l'accès est refusé et un salt (chaine aléatoire de 30 caractères) est délivré.
  2. le serveur d'encodage concatène son password au salt et hash le tout en sha256.
  3. le serveur d'encodage envoie à l'url demandée le login, le hash obtenu et les données éventuelles (en POST).

La connexion n'est valable que pour une seule action (la session est réinitialisée ensuite), tout nouvel appel au ws doit recommencer la procédure.

Pour information, voici les deux méthodes de l'adaptateur salt :

public function isAuth()

{

if (!isset($_POST['login']) or !isset($_POST['password'])

or !isset($this->_adapterOptions['passwords'][(string) $_POST['login']])

or is_null(App_Lib_Session::get('serviceAuth', 'salt'))) {

return new Zend_Auth_Result(Zend_Auth_Result::FAILURE, array());

}

$saltedPassword = hash('sha256', $this->_adapterOptions['passwords'][(string) $_POST['login']] . App_Lib_Session::get('serviceAuth', 'salt'));

App_Lib_Session::namespaceUnset('serviceAuth');

return (string) $_POST['password'] == $saltedPassword ? new Zend_Auth_Result(Zend_Auth_Result::SUCCESS, array('uid' => (string) $_POST['login']))

: new Zend_Auth_Result(Zend_Auth_Result::FAILURE, array());

}

public function authenticate()

{

$_SESSION = array();

// renvoi du grain de sel en Json

$appLibControllerActionHelperRandomString = new App_Lib_Controller_Action_Helper_RandomString();

$salt = $appLibControllerActionHelperRandomString->direct(30);

App_Lib_Session::set('serviceAuth', 'salt', $salt);

echo Zend_Json::encode(array('isSuccess' => true, 'data' => array('salt' => $salt)));

exit;

}

Médiacad utilise une classe (trunk/application/library/WebService.php) qui permet de requêter ses webServices.

Le code principal est le suivant :

public function requestWS($uri, $params = array())

{

// initialisation

$ch = curl_init($uri);

curl_setopt($ch, CURLOPT_POST, true);

curl_setopt($ch, CURLOPT_POSTFIELDS, array('data' => 'data'));

curl_setopt($ch, CURLOPT_RETURNTRANSFER, true);

curl_setopt($ch, CURLOPT_COOKIESESSION, true);

curl_setopt($ch, CURLOPT_COOKIEJAR, 'mediacadWSSession');

// récupération du salt

$result = curl_exec($ch);

if ($result === false) {

return array('isSuccess' => false, 'errorCode' => curl_error($ch), 'errorMessage' => curl_error($ch), 'data' => array());

}

$result = Zend_Json::decode($result, Zend_Json::TYPE_ARRAY);

if (!isset($result['data']['salt'])) {

$translate = Zend_Registry::get('Zend_Translate');

return array('isSuccess' => false, 'errorCode' => 'appLibWebServiceMissingSaltError', 'errorMessage' => $translate->_('appLibWebServiceMissingSaltError'), 'data' => array());

}

// login et requête

$params['login'] = $this->_login;

$params['password'] = hash('sha256', $this->_password . $result['data']['salt']);

curl_setopt($ch, CURLOPT_COOKIEFILE, 'mediacadWSSession');

curl_setopt($ch, CURLOPT_POSTFIELDS, $params);

curl_setopt($ch, CURLOPT_URL, $uri);

$result = curl_exec($ch);

if ($result === false) {

$message = array('isSuccess' => false, 'errorCode' => curl_error($ch), 'errorMessage' => curl_error($ch), 'data' => array());

} else {

$message = Zend_Json::decode($result, Zend_Json::TYPE_ARRAY);

}

curl_close($ch);

return $message;

}

Chaque webService renvoie un json de la forme suivante :

message de succès :

{"isSuccess":true,"data":{"key":"value"}}

ce qui, une fois décodé, donne en php :

array('isSuccess' => true,

'data' => array('key' => 'value'));

message d'erreur :

{"isSuccess":false,"errorCode":"wsEncodeError404","errorMessage":"Action introuvable.","data":[]}

ce qui, une fois décodé, donne en php :

array('isSuccess' => false,

'errorCode' => 'wsEncodeError404',

'errorMessage' => 'Action introuvable.',

'data' => array());

Messages d'erreurs possibles

Les messages d'erreurs possibles à la connexion sont :

errorCode | errorMessage | solution
wsEncodeError401 | Accès à cette action interdit. | problème d'ACL => revoir les configs
wsEncodeError404 | Action introuvable | revoir l'uri demandée

.

Demander une nouvelle tâche

webService

webService : getnexttask (path_de_mediacad/ws/encode/gestnexttask)

données à transmettre : aucune.

pas de tâche disponible

Médiacad renvoie un message de succès mais avec 'hasNewEncodingTask' == false.

Message de succès :

{"isSuccess":true,"data":{"hasNewEncodingTask":false}}

ce qui, une fois décodé, donne en php :

array('isSuccess' => true,

'data' => array(

'hasNewEncodingTask' => false));

une tâche est disponible

Médiacad renvoie les données nécessaires à l'accomplissement de la tâche.

Il y a 3 types de tâches possibles : copy, delete et encode.

tâche copy

Message de succès type :

{"isSuccess":true,"data":{"hasNewEncodingTask":true,"encodingTaskId":"68","task":"copy","sourceLocation":"##sourcePath##\/video\/17.mp4","destLocation":"##encodedPath##\/video\/17.mp4"}}

ce qui, une fois décodé, donne en php :

array('isSuccess' => true,

'data' => array(

'hasNewEncodingTask' => true,

'encodingTaskId' => '68',

'task' => 'copy',

'sourceLocation' => '##sourcePath##/video/17.mp4',

'destLocation' => '##encodedPath##/video/17.mp4'));

tâche delete

Message de succès type :

{"isSuccess":true,"data":{"hasNewEncodingTask":true,"encodingTaskId":"69","task":"delete","location":"##sourcePath##\/book\/18.odt"}}

ce qui, une fois décodé, donne en php :

array('isSuccess' => true,

'data' => array(

'hasNewEncodingTask' => true,

'encodingTaskId' => '69',

'task' => 'delete',

'location' => '##sourcePath##/book/18.odt'));

tâche encode

Message de succès type :

{"isSuccess":true,"data":{"hasNewEncodingTask":true,"encodingTaskId":"67","task":"encode","application":"ffmpeg","exe":"ffmpeg","command":"##applicationPath## -i \"##sourcePath##\/video\/17.mp4\" -vcodec libvpx -vb 700k -maxrate 8000k -bufsize 1000K -minrate 10k -qmin 3 -qmax 30 -rc_lookahead 16 -keyint_min 0 -g 360 -skip_threshold 0 -level 116 -preset slow -ab 192k \"##encodedPath##\/video\/17.webm\""}}

ce qui, une fois décodé, donne en php :

array('isSuccess' => true,

'data' => array(

'hasNewEncodingTask' => true,

'encodingTaskId' => '67',

'task' => 'encode',

'application' => 'ffmpeg',

'exe' => 'ffmpeg',

'command' => '##applicationPath## -i "##sourcePath##/video/17.mp4" -vcodec libvpx -vb 700k -maxrate 8000k -bufsize 1000K -minrate 10k -qmin 3 -qmax 30 -rc_lookahead 16 -keyint_min 0 -g 360 -skip_threshold 0 -level 116 -preset slow -ab 192k "##encodedPath##/video/17.webm"'));

réaliser la tâche

Avant de réaliser la tâche, il faut remplacer les ##xxxPath## des données renvoyées.

##applicationPath## : sera remplacé par le path de l'application sur le serveur d'encodage, en fonction des clefs 'application' et 'exe' (voir plus haut l'équivalent dans Médiacad (trunk/local/config/application.cfg.array.php), partie ['medias']['encode']).

##tmpPath##, ##sourcePath## et ##encodedPath## : sera remplacé par les paths correspondants (voir plus haut l'équivalent dans Médiacad (trunk/local/config/application.cfg.array.php), partie ['medias']).

Une fois la tâche réalisée, le serveur d'encodage doit requêter selon le cas "setencodesuccess" ou "setencodeerror".

Pour information, la méthode utilisée par Médiacad pour l'encodage (trunk/application/library/Media.php) est la suivante :

public function runNextEncodingTask()

{

$appModelEncodingTask = $this->_getAppModelEncodingTask();

// récupération des tâches inProgress avec timeout dépassé depuis plus de 5 min

$exceededTimeTaskRowset = $appModelEncodingTask->getExceededTimeTasks(5);

if (!is_null($exceededTimeTaskRowset)) {

// met les tâches en erreur

foreach ($exceededTimeTaskRowset as $exceededTimeTaskRow) {

$this->setEncodeError($exceededTimeTaskRow['encodingTaskId'], 'appLibMediaEncodingTimeout');

}

}

// récupération du nombre de tâches inProgress

$inProgressTaskCount = $appModelEncodingTask->getInProgressTasksCount();

// si ce nombre est < au nombre maxi => récupération de la tâche suivante en wait + passage à inProgress

$encodingTaskRow = null;

if ($inProgressTaskCount < $this->_localConfig['maxParallelEncoding']) {

$encodingTaskRow = $appModelEncodingTask->setInProgressForNextTask();

}

// pas de nouvelle tâche disponible => fin de la méthode

if (is_null($encodingTaskRow)) {

return null;

}

// envoi d un nouveau ping s il reste des tâches et que le max n est pas atteint

if (($inProgressTaskCount + 1) < $this->_localConfig['maxParallelEncoding']) {

$this->pingEncode();

}

// traitement de la tâche

// config php

ini_set('memory_limit', $this->_localConfig['encodingTaskMemoryLimit']);

set_time_limit($encodingTaskRow['maxInProgressDuration'] * 60);

// lancement de la tâche

$encodeCommand = Zend_Json::decode($encodingTaskRow['params']);

$beginTime = microtime(true);

// copy

if ($encodeCommand['task'] == 'copy') {

$errorMessage = 'appLibMediaFileCopyError';

$sourceLocation = str_replace('##tmpPath##', MEDIA_TMP_PATH, $encodeCommand['sourceLocation']);

$sourceLocation = str_replace('##sourcePath##', MEDIA_SOURCE_PATH, $sourceLocation);

$sourceLocation = str_replace('##encodedPath##', MEDIA_ENCODED_PATH, $sourceLocation);

$destLocation = str_replace('##tmpPath##', MEDIA_TMP_PATH, $encodeCommand['destLocation']);

$destLocation = str_replace('##sourcePath##', MEDIA_SOURCE_PATH, $destLocation);

$destLocation = str_replace('##encodedPath##', MEDIA_ENCODED_PATH, $destLocation);

$result = copy($sourceLocation, $destLocation);

// delete

} else if ($encodeCommand['task'] == 'delete') {

$errorMessage = 'appLibMediaFileDeleteError';

$location = str_replace('##tmpPath##', MEDIA_TMP_PATH, $encodeCommand['location']);

$location = str_replace('##sourcePath##', MEDIA_SOURCE_PATH, $location);

$location = str_replace('##encodedPath##', MEDIA_ENCODED_PATH, $location);

$result = unlink($location);

// encode

} else {

$errorMessage = 'appLibMediaEncodingTaskError';

$encodeCommand = str_replace('##applicationPath##', $this->_localConfig['encode']['applications'][$encodeCommand['application']][$encodeCommand['exe']]['applicationPath'], $encodeCommand['command']);

$encodeCommand = str_replace('##tmpPath##', MEDIA_TMP_PATH, $encodeCommand);

$encodeCommand = str_replace('##sourcePath##', MEDIA_SOURCE_PATH, $encodeCommand);

$encodeCommand = str_replace('##encodedPath##', MEDIA_ENCODED_PATH, $encodeCommand) . ' 2>&1';

$output = array();

$result = 0;

exec($encodeCommand, $output, $result);

$result > 0 ? $result = false : $result = true;

if (!$result) {

if (count($output) > 0) {

isset($encodingTaskRow['fileId']) ? $fileId = $encodingTaskRow['fileId'] : $fileId = 'xx';

$errorLog = 'appLibMediaEncodingTaskError - fileId=' . $fileId . ' - errorMessage=';

foreach ($output as $line) {

$errorLog .= $line;

}

App_Lib_Log::log($errorLog, Zend_Log::ERR);

}

}

}

$endTime = microtime(true);

// fin de l encodage

$result ? $this->setEncodeSuccess($encodingTaskRow['encodingTaskId'], $endTime - $beginTime) : $this->setEncodeError($encodingTaskRow['encodingTaskId'], $errorMessage);

// envoi d un nouveau ping

$this->pingEncode();

}

Messages d'erreurs possibles

Pas d'erreurs spécifiques au webService.

Le webService peut renvoyer les exceptions de l'application.

Signaler un encodage réussi

webService

webService : setencodesuccess(path_de_mediacad/ws/encode/setencodesuccess)

données à transmettre : (string) ['encodingTaskId'] et (float) ['encodeDuration'] (en secondes).

Message de succès

{"isSuccess":true,"data":[]}

ce qui, une fois décodé, donne en php :

array('isSuccess' => true,

'data' => array());

Messages d'erreurs possibles
errorCode | errorMessage | solution
wsEncodeSetEncodeSuccessRequestMustBePost | Les données doivent être envoyées en POST |
wsEncodeSetEncodeSuccessMissingPostFieldEncodingTaskId | Champs POST 'encodingTaskId' manquant. | renvoyer l'encodingTaskId reçu par gestnexttask
wsEncodeSetEncodeSuccessUnknownEncodingTaskId | EncodingTaskId inconnu. | soit l'encodingTaskId a été modifié par le serveur d'encodage, soit le webService a déjà été appelé pour ce même encodingTaskId
wsEncodeSetEncodeSuccessMissingPostFieldEncodeDuration | Champs POST 'encodeDuration' manquant. | renvoyer la durée d'encodage (float en secondes)

Le webService peut aussi renvoyer les exceptions de l'application.

Signaler une erreur d'encodage

webService

webService : setencodeerror(path_de_mediacad/ws/encode/setencodeerror)

données à transmettre : (string) ['encodingTaskId'] et (string) ['errorMessage'].

Message de succès

{"isSuccess":true,"data":[]}

ce qui, une fois décodé, donne en php :

array('isSuccess' => true,

'data' => array());

Messages d'erreurs possibles
errorCode | errorMessage | solution
wsEncodeSetEncodeErrorRequestMustBePost | Les données doivent être envoyées en POST. |
wsEncodeSetEncodeErrorMissingPostFieldEncodingTaskId | Champs POST 'encodingTaskId' manquant. | renvoyer l'encodingTaskId reçu par gestnexttask
wsEncodeSetEncodeErrorUnknownEncodingTaskId | EncodingTaskId inconnu. | soit l'encodingTaskId a été modifié par le serveur d'encodage, soit le webService a déjà été appelé pour ce même encodingTaskId
wsEncodeSetEncodeErrorMissingPostFieldErrorMessage | Champs POST 'errorMessage' manquant. | renvoyer le message d'erreur

Le webService peut aussi renvoyer les exceptions de l'application.

Créé avec HelpNDoc Personal Edition: Créer des documents d'aide PDF facilement


Documentation du script

SAdmins ›› Installation ›› Serveur(s) d'encodage ››

Dans la configuration de Médiacad on peut déléguer l'encodage à des serveurs tiers (voir la documentation adéquate).
Voici, en résumé, l'architecture choisie :

  • Médiacad conserve la responsabilité de l'ordonnancement des tâches
  • Médiacad met pour cela à disposition un webservice que des serveurs d'encodage peuvent interroger pour se renseigner si une tâche est en attente d'encodage, et le cas échéant la récupérer pour la prendre en charge

Un script unique est pour cela disponible, écrit en python .
Ce script peut être déployé sur plusieurs serveurs, qui indépendamment les uns des autres interrogent Médiacad, qui distribue les tâches d'encodage.
Le lancement du script crée un deamon qui interroge Médiacad à intervalles réguliers.

Le script doit être accompagné d'un fichier .ini contenant la configuration.
Ce fichier de configuration contient les sections suivantes :

  • applicationsPath : le chemin des application d'encodage
  • mediacad : les paramètres pour le webservice de Médiacad
  • filesPath : le chemin des fichiers temporaires, sources et encodés
  • launchParams : les paramètres d'exécution :
  • Le fichier de log
  • Le nombre max de process linux parallèle autorisé
  • L'intervalle d'attente entre chaque appel à Médiacad (en secondes)

Contenu du fichier .ini :

[applicationPath]

ffmpeg: /appli/ffmpeg/bin/ffmpeg

ffprobe: /appli/ffmpeg/bin/ffprobe

convert: /appli/imagemagick/bin/convert

ebookConvert: /usr/bin/xvfb-run /appli/calibre/ebook-convert

ebookMeta: /usr/bin/xvfb-run /appli/calibre/ebook-meta

unoconv: python /appli/unoconv/bin/unoconv

pdftk: /usr/local/bin/pdftk

[launchParams]

logFile: encodeDeamon.log

maxParallelThreads: 1

loopSleep: 1

[filesPath]

tmpPath: /mediacad/media/tmp

sourcePath: /mediacad/media/source

encodedPath: /mediacad/media/encoded

[mediacad]

url: http://med1.in.ac-bordeaux.fr/ws/encode/

login: encodeServer

password: maman

Le deamon peut être arrêté de deux manières :

  • proprement arrêté avec l'option --stop (le deamon s'arrêtera quand les encodages en cours seront terminés)
  • arrêté en force avec l'option --force

Créé avec HelpNDoc Personal Edition: Générateur d'aides Web gratuit


Script python d'encodage

SAdmins ›› Installation ›› Serveur(s) d'encodage ››

#!/usr/bin/python

# -*- coding: utf-8 -*-

from pyUnixDaemon import pyUnixDaemon

from time import sleep

import datetime

from os import getpid

import sys

import urllib2

from cookielib import CookieJar

import urllib

import time

import simplejson as json

import hashlib

import threading

import os

import getopt

import signal

import ConfigParser

class pyUnixDaemon:

""" This class implements a UNIX daemon. You can derived from it to build

your own daemon.

"""

def __init__(self, lockFilename = "/var/run/pyUnixDaemon.pid", user = (0, 0)):

""" This method initializes some internal variables and instancies an

object.

"""

self._user = user

self._lockFilename = lockFilename

def _daemonExists(self):

""" This method checks if the lock file exists.

"""

return os.path.exists(self._lockFilename)

def _lock(self):

""" This method creates the lock file and write the daemon pid.

"""

self._lockFile = open(self._lockFilename, "w")

self._lockFile.write("%d" % (os.getpid()))

self._lockFile.flush()

def _unlock(self):

""" This method closes and removes the lock file.

"""

self._lockFile.close()

os.unlink(self._lockFilename)

def _fork(self):

""" This method forks the daemon using the unix way.

"""

if (self._daemonExists()):

print "[Error] Could not be daemonized: already in memory"

sys.exit(1)

try:

pid = os.fork()

if (pid > 0):

sys.exit(0)

except OSError, e:

print "[Error] Fork #1 failed: %s (%d)" % (e.strerror, e.errno)

sys.exit(1)

os.chdir("/")

os.setsid()

os.umask(0)

try:

pid = os.fork()

if (pid > 0):

sys.exit(0)

except OSError, e:

print "[Error] Fork #2 failed: %s (%d)" % (e.strerror, e.errno)

sys.exit(1)

def _run(self):

""" This method must be derivated to do something.

"""

while(self._loop):

pass

def __signalHandler(self, signalNumber, frame):

""" This method sets an internal flag that permits to break the forever

loop.

"""

self._loop = False

def setOutput(self, output, error = None):

""" This method redirects stdout and stderr flows.

"""

self._stdout = sys.stdout

self._output = output

self._stderr = sys.stderr

if (error is not None):

self._error = error

else:

self._error = output

def setMaxThreads(self, maxThreads):

""" This method set the max number of parallel threads permitted.

"""

self._maxThreads = maxThreads

self._allocatedCPUs = 0

def launch(self):

""" This method prepares all required actions before lauching the background method '_run'.

"""

self._fork()

#os.setegid(self._user[1])

#os.seteuid(self._user[0])

self._lock()

self._loop = True

signal.signal(signal.SIGTERM, self.__signalHandler)

sys.stdout = self._output

sys.stderr = self._error

self._run()

sys.stdout = self._stdout

sys.stderr = self._stderr

self._unlock()

class mediacadEncodeDeamon(pyUnixDaemon):

def __init__(self, lockFilename, config):

pyUnixDaemon.__init__(self, lockFilename)

self._config=config

def _run(self):

now = time.strftime('%Y-%m-%d %H:%M:%S', time.localtime())

print "%s - %s" % (now, getpid())+" ; Lancement du deamon"

print "%s - %s" % (now, getpid())+" ; Le nombre maximum de processus en parallele sera : "+self._config.get("launchParams", "maxParallelThreads")

print "%s - %s" % (now, getpid())+" ; Le waiting time entre deux appels vers Mediacad est : "+self._config.get("launchParams", "loopSleep")+"s"

print "%s - %s" % (now, getpid())+" ; The url of the application Mediacad est : "+self._config.get("mediacad", "url")

while(self._loop):

try:

activeThreads = threading.activeCount()

if activeThreads < int(self._maxThreads)+1:

mc = mediacadEncode(self._config)

mc.start()

except Exception, error:

# Only for unexpected errors

print "%s ; FATAL ; %s"%(now, str(error))

self._loop = False

try:

mc._Thread__stop()

except UnboundLocalError:

pass

sys.stdout.flush()

time.sleep(int(self._config.get("launchParams","loopSleep")))

print "%s - %s" % (now, getpid())+" ; Arret du deamon"

class mediacadEncode(threading.Thread):

def __init__(self, config):

threading.Thread.__init__(self)

""" Initialisation des variables internes """

# Chemins des applications d'encodage :

self.applicationsPath = {

'ffmpeg': {

'ffmpeg': config.get("applicationPath","ffmpeg"),

'ffprobe': config.get("applicationPath","ffprobe")

},

'imageMagick': {

'convert': config.get("applicationPath","convert")

},

'calibre': {

'ebookConvert': config.get("applicationPath","ebookConvert"),

'ebookMeta': config.get("applicationPath","ebookMeta")

},

'unoconv': {

'unoconv': config.get("applicationPath","unoconv")

},

'pdftk': {

'pdftk': config.get("applicationPath","pdftk")

}

}

# login (to access the webservice)

self.login = config.get("mediacad","login")

self.clearPassword = config.get("mediacad","password")

# Path des fichiers temporaires (sur le serveur de fichiers)

self.tmpPath = config.get("filesPath","tmpPath")

# Path des sources (sur le serveur de fichier)

# after l'upload, Mediacad passe les fichiers de uploadPath vers sourcePath

self.sourcePath = config.get("filesPath","sourcePath")

# Path des fichiers encoded

self.encodedPath = config.get("filesPath","encodedPath")

# url du webservice de Mediacad :

self.url = config.get("mediacad","url")

def run(self):

try:

resultat = self.traiterNextTask()

if resultat == "notask":

# Ne rien faire

pass

elif resultat == "success":

self.success()

else:

self._printerr("run() ; Echec lors de l'appel a traiterNextTask()["+str(resultat)+"]")

self.error(resultat)

except Exception, error:

# Seulement pour les erreurs imprevues

self._printerr("run() ; Erreur fatale imprevue : "+str(error))

self._Thread__stop()

def _strNow(self):

return time.strftime('%Y-%m-%d %H:%M:%S', time.localtime())

def _printlog(self, log):

print self._strNow() + " INFO " + str(log)

return;

def _printerr(self, log):

print self._strNow() + " ERROR " + str(log)

return;

def _requestWS(self, path, params = {}):

""" Request un webservice """

#self._printlog("_requestWS() ; Operation demandee ["+path+"]")

# L'interrogation du webservice de Mediacad necessite de pouvoir

# recuperer le cookie recieved lors du 1er appel,

# et de le renvoyer lors du 2nd appel (la recuperation de la

# prochaine task)

cj = CookieJar()

opener = urllib2.build_opener(urllib2.HTTPCookieProcessor(cj))

# Get le salt :

#self._printlog("_requestWS() ; getting the salt")

try:

page = opener.open(self.url+path)

result = page.read()

# self._printlog("_requestWS() ; answer du premier appel : "+str(result))

fluxRetour = json.loads(result)

except urllib2.HTTPError, error:

return {'isSuccess': False, 'data': {}, 'errorMessage': str(error)}

try:

salt = fluxRetour["data"]["salt"]

except KeyError:

return {'isSuccess': False, 'data': {}, 'errorMessage': "Salt not found dans la answer du webservice"}

# Authentification :

password = hashlib.sha256(self.clearPassword + salt).hexdigest()

params['login'] = self.login

params['password'] = password

#self._printlog("_requestWS() ; Authentification")

data_encoded = urllib.urlencode(params)

try:

#for cookie in cj:

#self._printlog('_requestWS() ; cookie [%s --> %s]'%(cookie.name,cookie.value))

page = opener.open(self.url+path, data_encoded)

result = page.read()

reponse = json.loads(result)

#self._printlog("_requestWS() ; answer de l'authentification : "+str(reponse))

except urllib2.HTTPError, error:

return {'isSuccess': False, 'data': {}, 'errorMessage': str(error)}

#self._printlog("_requestWS() ; Exit")

return reponse

def traiterNextTask(self):

answerRequest = self._requestWS("getnexttask")

# Checking qu'il n'y ait pas eu d'erreur :

if answerRequest["isSuccess"] == False:

self._printlog("traiterNextTask() ; La answer est dans le state FALSE: " + str(answerRequest))

raise Exception("traiterNextTask() ; Erreur dans le getting de la prochaine task !")

# Stopper si il n'y aucune task en attente :

try:

if answerRequest["data"]["hasNewEncodingTask"] == False:

return "notask"

except KeyError:

raise Exception("traiterNextTask() ; inconsistency de la answer !")

# A partir d'ici, on ne peut plus se permettre de ne pas maitriser le traitement

# de la task que nous venons de recuperer :

# l'interrogation de l'operation "getnexttask" du webservice modifie

# le state de la task dans la database de Mediacad.

# Nous devons donc controler son traitement pour etre en mesure de renvoyer

# une boolean answer.

try:

# Log de la task :

self._printlog("traiterNextTask() ; A task was just found: " + str(answerRequest))

# Parsing de la tÃ¢che :

self.task = answerRequest["data"]["task"]

self.encodingTaskId = answerRequest["data"]["encodingTaskId"]

# Execute la commande

self.debut = time.time()

# Commande copy

if self.task == 'copy':

self._printlog("traiterNextTask() ; Copie")

sourceLocation = answerRequest["data"]["sourceLocation"]

destLocation = answerRequest["data"]["destLocation"]

sourceLocation = sourceLocation.replace("##tmpPath##", self.tmpPath)

sourceLocation = sourceLocation.replace("##sourcePath##", self.sourcePath)

sourceLocation = sourceLocation.replace("##encodedPath##", self.encodedPath)

destLocation = destLocation.replace("##tmpPath##", self.tmpPath)

destLocation = destLocation.replace("##sourcePath##", self.sourcePath)

destLocation = destLocation.replace("##encodedPath##", self.encodedPath)

from shutil import copyfile

self._printlog("traiterNextTask() ; Fichier source [" + sourceLocation + "]")

self._printlog("traiterNextTask() ; Fichier cible [" + destLocation+"]")

copyfile(sourceLocation, destLocation)

return 'success'

# Commande delete

elif self.task == 'delete':

self._printlog("traiterNextTask() ; Suppression")

location = answerRequest["data"]["location"]

location = location.replace("##tmpPath##", self.tmpPath)

location = location.replace("##sourcePath##", self.sourcePath)

location = location.replace("##encodedPath##", self.encodedPath)

self._printlog("traiterNextTask() ; Fichier to supprimer [" + location + "]")

os.remove(location)

return 'success'

# Commande encode

else:

self._printlog("traiterNextTask() ; Encodage")

commande = answerRequest["data"]["command"]

application = answerRequest["data"]["application"]

exe = answerRequest["data"]["exe"]

commande = commande.replace('##applicationPath##', self.applicationsPath[application][exe])

commande = commande.replace('##tmpPath##', self.tmpPath)

commande = commande.replace('##sourcePath##', self.sourcePath)

commande = commande.replace('##encodedPath##', self.encodedPath)

self._printlog("traiterNextTask() ; Commande [" + str(commande)+"]")

import commands

resultat = commands.getstatusoutput(commande) #

if resultat[0] != 0:

return "Erreur executing the command: " + resultat[1]

else:

#self._printlog("traiterNextTask() ; Retour de la sortie standard pour la task ["+self.encodingTaskId+"]: " + resultat[1])

return 'success'

except Exception, error:

return error

return "ERREUR : cette erreur n'aurait pas du remonter"

def success(self):

""" Informer Mediacad du success du traitement de la task """

self._printlog("success() ; La task [" + self.task + "] d'identifiant [" + self.encodingTaskId + "] s'est terminee avec success")

fin = time.time()

duree = fin - self.debut

#encodeDuration = datetime.timedelta(seconds=duree)

encodeDuration = str(duree)

self._printlog("success() ; Duree de l'encodage : " + encodeDuration)

# Envoi du SUCCESS

datasToTransfert = {'encodingTaskId': self.encodingTaskId, 'encodeDuration': encodeDuration}

answerRequest = self._requestWS("setencodesuccess", datasToTransfert)

if not answerRequest["isSuccess"]:

raise Exception("Echec dans l'envoi d'un SUCCESS to Mediacad ! ["+ str(answerRequest["errorMessage"]) + "]")

self._printlog("success() ; Envoi du SUCCESS to Mediacad: OK")

return

def error(self,resultatCommande = ""):

""" Informer Mediacad du failure du traitement de la task """

self._printerr("error() ; Une erreur s'est produite lors de l'execution de la task [" + self.encodingTaskId + "]")

# Envoi du ECHEC

datasToTransfert = {'encodingTaskId': self.encodingTaskId, 'errorMessage': resultatCommande}

answerRequest = self._requestWS("setencodeerror", datasToTransfert)

if not answerRequest["isSuccess"]:

raise Exception("Echec dans l'envoi d'un ECHEC to Mediacad ! ["+ str(answerRequest["errorMessage"]) + "]")

self._printlog("error() ; Envoi du ECHEC to Mediacad: OK")

return

#

# Partie principale

#

def main(argv):

# Nom du script courant :

currentScript = os.path.abspath(__file__)

if currentScript[-3:] != ".py":

print "Mauvaise extension de fichier ! (<filename>.py)"

sys.exit()

# Lire la configuration :

config = ConfigParser.ConfigParser()

config.read(currentScript[:-3]+".ini")

# pid file for the deamon :

hostname = os.getenv('HOSTNAME', 'unknown_hostname')

if hostname == 'unknown_hostname':

print "Variable linux HOSTNAME non disponible"

sys.exit()

pidFileName = currentScript[:-3]+"_"+hostname+".pid"

lofFileName = currentScript[:-3]+"_"+hostname+".log"

help = currentScript+" [--start] [--stop] [--force] [--help]"

try:

options, args = getopt.gnu_getopt(sys.argv, 'h', ["start","stop","force","help"])

except getopt.GetoptError:

print help

sys.exit(2)

for opt, arg in options:

if opt in ('-h', '--help'):

print help

elif opt == '--start':

daemon = mediacadEncodeDeamon(pidFileName,config)

daemon.setOutput(open(lofFileName, "a"))

print "Le fichier de log est : "+lofFileName

daemon.setMaxThreads(config.get("launchParams", "maxParallelThreads"))

daemon.launch()

elif opt == '--stop':

print "Graceful stop asked"

try:

pid = int(open(pidFileName, 'r').read())

except IOError:

print "No pid file available"

sys.exit()

os.kill(pid, signal.SIGTERM)

print "Graceful stop ended"

sys.exit()

elif opt == '--force':

print "Force stop asked"

try:

pidFile = open(pidFileName, 'r')

pid = int(pidFile.read())

except IOError:

print "No pid file available"

sys.exit()

os.kill(pid, signal.SIGKILL)

pidFile.close()

os.unlink(pidFileName)

print "Force stop ended"

sys.exit()

else:

assert False, "option incorrecte"

if __name__ == "__main__":

main(sys.argv[1:])

Créé avec HelpNDoc Personal Edition: Créer des documents d'aide facilement


Applications externes

SAdmins ›› Installation ››

Les applications externes doivent être installées à la fois sur le serveur web de Médiacad et sur tous les serveurs d'encodage.

Applications à installer

L'installation sous Red Hat est documentée .

ffmpeg

Installer la dernière version de ffmpeg ( http://www.ffmpeg.org/ ) avec tous les codecs disponibles.

ImageMagick

Installer la dernière version d'ImageMagick ( http://www.imagemagick.org/ ).

Ajouter Ghostscript ( http://www.ghostscript.com/download/gsdnld.html ) pour la lecture des pdf.

Calibre

Installer la dernière version de Calibre ( http://calibre-ebook.com/ ).

LibreOffice

Installer la dernière version de LibreOffice ( https://www.libreoffice.org/ ).

Unoconv

Installer la version master d'unoconv, pas le tag 0.6.0 (incompatible avec LibreOffice 4) ( https://github.com/dagwieers/unoconv ) pour interroger LibreOffice en ligne de commande.

PDFtk

Installer la dernière version de PDFtk ( https://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/ ) pour lire les informations sur les pdf.

Changer la configuration

Vous devez ensuite mettre à jour la configuration de Médiacad pour indiquer les path des applications sur le serveur web, dans /local/config/application.cfg.array.php, partie ['medias']['encode'].

Créé avec HelpNDoc Personal Edition: Sites web iPhone faciles


Installation sous Red Hat

SAdmins ›› Installation ›› Applications externes ››

INSTALLATION DE YASM

- Télécharger la dernière version stable de yasm (1.2.0 à ce jour) :

wget http://www.tortall.net/projects/yasm/releases/yasm-1.2.0.tar.gz

- Compiler et installer yasm :

mkdir /appli/yasm

tar -xvzf yasm-1.2.0.tar.gz

cd yasm-1.2.0

make

make install

ln -s /appli/yasm/bin/yasm /usr/local/bin/yasm

INSTALLATION DE LIBVPX

- Télécharger la dernière version stable de libvpx (1.2.0 à ce jour) :

git clone http://git.chromium.org/webm/libvpx.git

- Compiler et installer libvpx :

cd libvpx

git checkout v1.2.0

./configure --prefix=/appli/libvpx/

make

make install

ln -s /appli/libvpx/bin/* /usr/local/bin/

ln -s /appli/libvpx/include/* /usr/local/include/

ln -s /appli/libvpx/lib/* /usr/local/lib/

INSTALLATION DE LIBX264

- Télécharger la dernière version stable de libx264 sur le site officiel http://www.videolan.org/developers/x264.html :

git clone git://git.videolan.org/x264.git

- Compiler et installer libx264 :

cd x264/

./configure --prefix=/appli/libx264/ --enable-shared

make

make install

ln -s /appli/libx264/bin/* /usr/local/bin/

ln -s /appli/libx264/include/* /usr/local/include/

ln -s /appli/libx264/lib/* /usr/local/lib/

- Ajouter la ligne suivante au fichier /etc/ld.so.conf.d/custom-libs.conf :

/appli/libx264/lib

INSTALLATION DE LIBVO-AACENC

- Télécharger la dernière version stable de libvo-aacenc (0.1.3 à ce jour) sur le site officiel http://sourceforge.net/projects/opencore-amr/ :

wget http://downloads.sourceforge.net/project/opencore-amr/vo-aacenc/vo-aacenc-0.1.3.tar.gz?r=http%3A%2F%2Fsourceforge.net%2Fprojects%2Fopencore-amr%2Ffiles%2Fvo-aacenc%2F&ts=1380700540&use_mirror=optimate

- Compiler et installer libvo-aacenc :

mkdir /appli/libvo-aacenc

tar -xvzf vo-aacenc-0.1.3.tar.gz

cd vo-aacenc-0.1.3

./configure --prefix=/appli/libvo-aacenc/

make

make install

ln -s /appli/libvo-aacenc/include/vo-aacenc/* /usr/local/include/

- Ajouter la ligne suivante au fichier /etc/ld.so.conf.d/custom-libs.conf :

/appli/libvo-aacenc/lib

INSTALLATION DE FFMPEG

- Télécharger la dernière version stable de ffmpeg (2.0 à ce jour) sur le site officiel http://www.ffmpeg.org :

wget http://www.ffmpeg.org/releases/ffmpeg-2.0.tar.gz

- Compiler et installer ffmpeg :

tar -xvzf ffmpeg-2.0.tar.gz

cd ffmpeg-2.0

export LIBRARY_PATH=/appli/libx264/lib/:/appli/libvpx/lib/:/appli/libvo-aacenc/lib/:/usr/local/lib/

./configure --prefix=/appli/ffmpeg --enable-libvpx --enable-libx264 --enable-gpl --enable-libvorbis --enable-libvo-aacenc --enable-version3

make

make install

INSTALLATION DE IMAGEMAGICK

- Télécharger la dernière version stable de ImageMagick (6.8.6-5 à ce jour) sur le site officiel http://www.imagemagick.org :

wget http://www.imagemagick.org/download/ImageMagick.tar.gz

- Installer ImageMagick :

tar -xvzf ImageMagick.tar.gz

cd ImageMagick-6.8.6-5

./configure --prefix=/appli/imagemagick

make

make check

make install

INSTALLATION DE GHOSTSCRIPT

- Télécharger la dernière version stable de ghostscript (9.07 à ce jour) sur le site officiel http://www.ghostscript.com :

wget http://downloads.ghostscript.com/public/binaries/ghostscript-9.07-linux-x86_64.tgz

- Installer ghostscript :

tar -xvzf ghostscript-9.07-linux-x86_64.tgz

mkdir -p /appli/ghostscript/bin

cp ghostscript-9.07-linux-x86_64/gs-907-linux_x86_64 /appli/ghostscript/bin/

INSTALLATION DE CALIBRE

- Installer Calibre dans sa dernière version stable (0.9.39 à ce jour) :

python -c "import sys; py3 = sys.version_info[0] > 2; u = __import__('urllib.request' if py3 else 'urllib', fromlist=1); exec(u.urlopen('http://status.calibre-ebook.com/linux_installer').read()); main(install_dir='/appli')"

Automatically installing to: /appli

Using previously downloaded calibre-0.9.39-x86_64.tar.bz2

Extracting files to /appli/calibre ...

Extracting application files...

Creating symlinks...

Symlinking /appli/calibre/fetch-ebook-metadata to /usr/bin/fetch-ebook-metadata

Symlinking /appli/calibre/lrf2lrs to /usr/bin/lrf2lrs

Symlinking /appli/calibre/ebook-convert to /usr/bin/ebook-convert

Symlinking /appli/calibre/ebook-meta to /usr/bin/ebook-meta

Symlinking /appli/calibre/lrfviewer to /usr/bin/lrfviewer

Symlinking /appli/calibre/calibre to /usr/bin/calibre

Symlinking /appli/calibre/markdown-calibre to /usr/bin/markdown-calibre

Symlinking /appli/calibre/calibre-debug to /usr/bin/calibre-debug

Symlinking /appli/calibre/calibre-parallel to /usr/bin/calibre-parallel

Symlinking /appli/calibre/web2disk to /usr/bin/web2disk

Symlinking /appli/calibre/calibre-server to /usr/bin/calibre-server

Symlinking /appli/calibre/calibre-customize to /usr/bin/calibre-customize

Symlinking /appli/calibre/ebook-polish to /usr/bin/ebook-polish

Symlinking /appli/calibre/ebook-viewer to /usr/bin/ebook-viewer

Symlinking /appli/calibre/calibre-smtp to /usr/bin/calibre-smtp

Symlinking /appli/calibre/lrs2lrf to /usr/bin/lrs2lrf

Symlinking /appli/calibre/ebook-device to /usr/bin/ebook-device

Symlinking /appli/calibre/calibredb to /usr/bin/calibredb

Setting up command-line completion...

Installing bash completion to /etc/bash_completion.d/calibre

Setting up desktop integration...

Run "calibre" to start calibre

INSTALLATION DE LIBREOFFICE

- Télécharger la dernière version stable de LibreOffice (4.0.4 à ce jour) sur le site officiel http://www.libreoffice.org :

wget http://download.documentfoundation.org/libreoffice/stable/4.0.4/rpm/x86_64/LibreOffice_4.0.4_Linux_x86-64_rpm.tar.gz

- Installer LibreOffice :

tar -xvzf LibreOffice_4.0.4_Linux_x86-64_rpm.tar.gz

yum install LibreOffice_4.0.4.2_Linux_x86-64_rpm/RPMS/*.rpm

INSTALLATION DE UNOCONV

- Télécharger la dernière version stable de unoconv (9.07 à ce jour) sur le site officiel http://dag.wieers.com/home-made/unoconv/ :

wget https://github.com/dagwieers/unoconv/archive/master.zip

- Installer unoconv :

unzip master

mkdir -p /appli/unoconv/bin

cp unoconv-master/unoconv /appli/unoconv/bin/

INSTALLATION DE PDFTK

- Télécharger la dernière version stable de pdftk (9.07 à ce jour) sur le site officiel http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/ :

wget http://www.pdflabs.com/tools/pdftk-the-pdf-toolkit/pdftk-2.01-src.zip

- Installer pdftk :

unzip pdftk-2.01-src.zip

cd pdftk-2.01-dist/pdftk

make -f Makefile.Redhat

make -f Makefile.Redhat install

Créé avec HelpNDoc Personal Edition: Créer des documents d'aide CHM facilement


Adaptateur d'authentification

SAdmins ›› Installation ››

Médiacad fonctionne avec des adaptateurs d'authentification.

Créer un adaptateur d'authentification

Il y a trois possibilités de localisation des adaptateurs d'authentification :

  • 'core' : dans /application/library/Auth/Adapter/ : respecte la convention de nommage pour l'autoloader
  • 'external' : dans /library/ ; ne respecte pas forcément les conventions de nommage, ce qui impose en config le path et le fileName
  • 'local' : dans /local/library/Auth/Adapter/ : doit respecter la convention de nommage pour l'autoloader

L'adaptateur doit étendre la classe App_Lib_Auth_Adapter_Abstract.

Vous pouvez prendre pour modèle l'un des adaptateurs déjà présents.

Modifier la configuration

Les adaptateurs d'authentification sont configurés dans /local/configs/application.cfg.array.php , clef 'auth'.

L'adaptateur actif est renseigné dans 'activeAdapter'.

Créé avec HelpNDoc Personal Edition: Écrire des livres électroniques ePub pour l'iPad


Adaptateur et formateur d'annuaire

SAdmins ›› Installation ››

Médiacad fonctionne avec des adaptateurs d'annuaire pour la création et la mise à jour des établissements et des utilisateurs.

Workflow des données d'annuaire

  1. Les données sont récupérées brutes par un adaptateur d'annuaire.
  2. Ces données brutes sont formatées dans un format accepté par Médiacad par un formateur d'annuaire.
  3. Ces données formatées sont validées par un valideur (unique dans Médiacad).

Si vous souhaitez créer une nouvelle source de données d'annuaire, vous devez donc développer un adaptateur et son formateur associé.

Créer un adaptateur et un formateur d'annuaire

Il y a trois possibilités de localisation des adaptateurs et formateurs d'annuaire :

  • 'core' : dans /application/library/Directory/Adapter et /Format : respecte la convention de nommage pour l'autoloader
  • 'external' : dans /library/ ; ne respecte pas forcément les conventions de nommage, ce qui impose en config le path et le fileName
  • 'local' : dans /local/library/Directory/Adapter et /Format : doit respecter la convention de nommage pour l'autoloader

L'adaptateur doit étendre la classe App_Lib_Directory_Adapter_Abstract.

Vous pouvez prendre pour modèle l'un des adaptateurs déjà présents.

Le formateur doit étendre la classe App_Lib_Directory_Format_Abstract.

Vous pouvez prendre pour modèle l'un des formateurs déjà présents.

Les XML reçus par l'adaptateur Sarapis pour un établissement test sont fournis (dans /dev/sAdmins/install/directory/adapters/sarapis).

Modifier la configuration

Les adaptateurs et formateurs d'annuaire sont configurés dans /local/configs/application.cfg.array.php , clef 'directory'.

L'adaptateur actif est renseigné dans 'activeAdapter'.

Créé avec HelpNDoc Personal Edition: Générateur complet de livres électroniques Kindle


Fichiers de configuration

SAdmins ›› Installation ››

Emplacement des fichiers de configuration

Tous les fichiers de configurations modifiables se trouvent dans /local/config.

Vous ne devez en aucun cas modifier un fichier de configuration en dehors de /local/config sous peine d'obtenir un comportement indéterminé de l'application.

Modification des fichiers de configuration

Une fois les fichiers de configuration modifiés, vous devez supprimer le cache pour qu'ils soient pris en compte par Médiacad : connecté en sAdmin, menu Application > Maintenance puis Nettoyer le cache.

application.cfg.array.php

Ce fichier contient la configuration principale de l'application.

Lors d'un processus de mise à jour de l'application, les nouvelles clefs de configuration sont ajoutées à ce fichier avec les valeurs par défaut contenues dans /application/config/application.cfg.array.php.

clefs |  |  |  |  |  | description | type | valeur par défaut
publicBaseUri |  |  |  |  |  | baseUri de tous les fichiers existants "physiquement" et de la zone publique SANS le / final | string | http://www.mediacad.local
protectedBaseUri |  |  |  |  |  | baseUri des actions à protéger (module 'pr') SANS le / final | string | http://www.mediacad.local
internalWSBaseUri |  |  |  |  |  | baseUri des interne des webServices SANS le / final | string | http:// . $_SERVER['SERVER_NAME']
useMinify |  |  |  |  |  | Utiliser les fichiers CSS et JS combinés et minifiés | boolean | true
isDemo |  |  |  |  |  | cette instance est-elle une instance de démonstration ? Si true, tous les médias n'appartenant pas aux superMods et aux sAdmins seront supprimés par maintenance. | boolean | false
isActiveApplication |  |  |  |  |  | suspend l'accès à l'application si == false | boolean | true
debugLevel |  |  |  |  |  | niveau de log de debug injecté dans App_Lib_Log | integer | development : 8 ; production : 5
logFilePath |  |  |  |  |  | path des fichiers de log SANS LE / FINAL | string | /log/mediacad
applicationName |  |  |  |  |  | nom de l'application qui sera indiqué sur le logo | string | Médiacad
demoApplicationName |  |  |  |  |  | nom de l'application qui sera indiqué sur le logo si isDemo == true | string | Médiacad-démo
serverName |  |  |  |  |  | nom de l'instance ; la première lettre doit être en majuscules | string | Académie de ***
isMediacadPingMaintenance |  |  |  |  |  | Médiacad doit-il lancer les tâches journalières de maintenance ? Si false, un service externe doit d'en charger. | boolean | false
connectionLogsKeepingDuration |  |  |  |  |  | Durée de conservation des logs de connexion(en jours) | integer | 90
oldUsersKeepingDuration |  |  |  |  |  | Durée de conservation des users non inscrits en établissement (en jours) | integer | 90
reportedMediasKeepingDuration |  |  |  |  |  | Durée de conservation des médias signalés (en jours) | integer | 365
mediacadSourceWebSiteUri |  |  |  |  |  | Uri du serveur vitrine de Médiacad. | string | http://web.ac-bordeaux.fr/mediacad
lastRevisionFileUri |  |  |  |  |  | Uri du fichier indiquant la dernière révision disponible de Médiacad | string | http://web.ac-bordeaux.fr/mediacad/download/lastRevision.js
lastRevisionUploadUri |  |  |  |  |  | Uri de la page permettant l'upload de la dernière révision disponible de Médiacad | string | http://web.ac-bordeaux.fr/mediacad/telecharger.php
confidential |  |  |  |  |  | Partie données affichées sur la page default::application::confidential | array |
 | cnil |  |  |  |  | partie déclaration CNIL | array |
 |  | number |  |  |  | numéro de la déclaration | string |
 |  | declarationDate |  |  |  | date de la déclaration (format AAAA-MM-JJ) | string |
 |  | returnDate |  |  |  | date de retout du récépissé de la déclaration (format AAAA-MM-JJ) | string |
 | contact |  |  |  |  | partie contact pour la modification des données personnelles | array |
 |  | address |  |  |  | adresse postale | string |
 |  | email |  |  |  | courriel | string |
mailingList |  |  |  |  |  | partie liste de diffusion Médiacad | array |
 | listEmail |  |  |  |  | adresse mail de la liste des utilisateurs de Médiacad | string | liste.mediacad@ac-bordeaux.fr
 | listEmailLabel |  |  |  |  | nom de la liste | string | liste.mediacad
 | listEmailServer |  |  |  |  | url complète du serveur de liste (pour inscription) | string | http://listes.ac-bordeaux.fr/sympa/info/liste.mediacad
 | listDevEmail |  |  |  |  | adresse mail de la liste des sAdmins et développeurs de Médiacad | string | liste.mediacad-dev@ac-bordeaux.fr
 | listDevEmailLabel |  |  |  |  | nom de la liste | string | liste.mediacad-dev
 | listDevServer |  |  |  |  | url complète du serveur de liste (pour inscription) | string | http://listes.ac-bordeaux.fr/sympa/info/liste.mediacad-dev
 | contactEmail |  |  |  |  | email de contact pour les messages avec des données personnelles | string |
sendMail |  |  |  |  |  | envoi de mails par Médiacad | array |
 | mail |  |  |  |  | adresse mail | string | noreply-mediacad@…
 | name |  |  |  |  | nom de l'expéditeur | string | Médiacad
 | usePhpConfig |  |  |  |  | utiliser les paramètres internes de php ? Si false, se connectera à un serveur SMTP avec la config suivante | boolean | true
 | useSsl |  |  |  |  | pour l'envoi via SMTP : utiliser SSL ? | boolean | true
 | sslPort |  |  |  |  | pour l'envoi via SMTP : port SSL | integer | 465
 | uri |  |  |  |  | pour l'envoi via SMTP : uri du serveur SMTP | string |
 | userName |  |  |  |  | pour l'envoi via SMTP : nom d'utilisateur | string |
 | password |  |  |  |  | pour l'envoi via SMTP : mot de passe | string |
database |  |  |  |  |  | section base de données | array |
 | type |  |  |  |  | connecteur | string | pdo_mysql
 | host |  |  |  |  | adresse de l'host | string | localhost
 | dbName |  |  |  |  | nom de la base de données | string | mediacad
 | users |  |  |  |  | utilisateurs | array |
 |  | normal |  |  |  | utilisateur pour le fonctionnenent habituel de l'application (droits SELECT, INSERT, UPDATE, DELETE) | array |
 |  |  | username |  |  | nom d'utilisateur | string | mediacad
 |  |  | password |  |  | mot de passe | string | test
 |  | update |  |  |  | utilisateur pour l'installation et la mise à jour de l'application (droits ALL PRIVILEGES) | array |
 |  |  | username |  |  | nom d'utilisateur | string | mediacad
 |  |  | password |  |  | mot de passe | string | test
auth |  |  |  |  |  | section authentification | array |
 | activeAdapters |  |  |  |  | adaptateur d'authentification (doit être la même chaine que l'une des clefs de 'adapters') | array |
 |  | pr |  |  |  | adaptateur d'authentification pour le module pr | string | shibboleth
 |  | ws |  |  |  | adaptateur d'authentification pour le module ws | string | password
 | adapters |  |  |  |  | config des adaptateurs | array |
 |  | shibboleth |  |  |  | config de l'adaptateur shibboleth | array |
 |  |  | location |  |  | localisation de la classe OBLIGATOIRE ('core' | 'external' | 'local') | string | core
 |  |  | className |  |  | nom de la classe OBLIGATOIRE | string | App_Lib_Auth_Adapter_Shibboleth
 |  |  | path |  |  | uniquement si 'location' == 'external' : path du fichier de la class, sans les '/' initial et final | string | pour LIBRARY_PATH . '/monAuthAdapt/adapt.php', indiquer 'monAuthAdapt'
 |  |  | fileName |  |  | uniquement si 'location' == 'external' : nom du fichier de la class | string | pour LIBRARY_PATH . '/monAuthAdapt/adapt.php', indiquer 'adapt.php'
 |  |  | config |  |  | options | array |
 |  |  |  | HTTP_X_FORWARDED_HOST |  | header renvoyé par Shibboleth | string | ***
 |  | salt |  |  |  | adaptateur salt (interne) | array |
 |  |  | location |  |  | localisation de la classe OBLIGATOIRE ('core' | 'external' | 'local') | string | core
 |  |  | className |  |  | nom de la classe OBLIGATOIRE | string | App_Lib_Auth_Adapter_Salt
 |  |  | config |  |  | options | array |
 |  |  |  | passwords |  | Logins et mots de passe | array |
 |  |  |  |  | mediacad | mot de passe pour le login mediacad | string | ***
 |  |  |  |  | encodeServer | mot de passe pour le login encodeServer | string | ***
 |  | password |  |  |  | adaptateur password (interne) | array |
 |  |  | location |  |  | localisation de la classe OBLIGATOIRE ('core' | 'external' | 'local') | string | core
 |  |  | className |  |  | nom de la classe OBLIGATOIRE | string | App_Lib_Auth_Adapter_Password
 |  |  | config |  |  | options | array |
 |  |  |  | passwords |  | Logins et mots de passe | array |
 |  |  |  |  | mediacad | mot de passe pour le login mediacad | string | ***
 |  |  |  |  | encodeServer | mot de passe pour le login encodeServer | string | ***
directory |  |  |  |  |  | section annuaire (création et mise à jour d'établissements) | array |
 | updateSchoolDelay |  |  |  |  | délai entre deux mises à jour (en jours) | integer | 1
 | updateMemoryLimit |  |  |  |  | memory limit pour la mise à jour ('-1' = pas de limite) | string | '-1'
 | updateTimeLimit |  |  |  |  | time limit pour la mise à jour de chaque établissement (en secondes) (0 = pas de limite) | integer | 60
 | isAllowedAutoUpdateAllSchools |  |  |  |  | la mise à jour automatique de tous les établissements par tâche de maintenance est autorisée | boolean | true
 | useSchoolWhiteList |  |  |  |  | utiliser une liste blanche d'établissements autorisés ? | boolean | true
 | schoolWhiteList |  |  |  |  | liste blanche d'établissements autorisés (sous la forme array('uai1','uai2') | array | empty
 | allowedStaffFunctions |  |  |  |  | liste des function autorisées pour l'import des personnels | array | array('ADA','ADF','ADM','AED','CFC','COP','CTR','DIR','DOC','EDU','ENS','FCA','FIJ','INJ','INS','MAD','MDS','ORI','PPA','SUR','TEC')
 | activeAdapter |  |  |  |  | nom de l'adaptateur d'annuaire actif (doit être la même chaine que l'une des clefs de 'adapters') | string | sarapis
 | adapters |  |  |  |  | config des adaptateurs | array |
 |  | sarapis |  |  |  | adaptateur Sarapis (académie de Bordeaux) | array |
 |  |  | location |  |  | localisation de la classe OBLIGATOIRE ('core' | 'external' | 'local') | string | core
 |  |  | className |  |  | nom de la classe OBLIGATOIRE | string | App_Lib_Directory_Adapter_Sarapis
 |  |  | path |  |  | uniquement si 'location' == 'external' : path du fichier de la class, sans les '/' initial et final | string | pour LIBRARY_PATH . '/monDirAdapt/adapt.php', indiquer 'monDirAdapt'
 |  |  | fileName |  |  | uniquement si 'location' == 'external' : nom du fichier de la class | string | pour LIBRARY_PATH . '/monDirAdapt/adapt.php', indiquer 'adapt.php'
 |  |  | config |  |  | options | array |
 |  |  |  | client |  | login | string | ***
 |  |  |  | cleApi |  | mot de passe | string | ***
 |  |  |  | url |  | url du webService de Sarapis | string | ***
 |  |  |  | requestMethodName |  | table de concordance méthodes Médiacad / méthodes Sarapis | array |
 |  |  |  |  | getSchoolsByUserUid | établissements de l'user | string | getEtablissementsByUID
 |  |  |  |  | getSchoolBySchoolDirectoryId | données établissement | string | getEtablissementByRne
 |  |  |  |  | getStudentsBySchoolDirectoryId | données élèves | string | getAllElevesByRneWithMefstats
 |  |  |  |  | getStaffBySchoolDirectoryId | données personnels | string | getAllProfesseursByRne
 |  |  | format |  |  | classe de formatage des données d'annuaire | array |
 |  |  |  | className |  | nom de la classe OBLIGATOIRE | string | App_Lib_Directory_Format_Sarapis
 |  |  |  | path |  | uniquement si 'location' == 'external' : path du fichier de la class, sans les '/' initial et final | string | pour LIBRARY_PATH . '/monDirFormatAdapt/format.php', indiquer 'monDirFormatAdapt'
 |  |  |  | fileName |  | uniquement si 'location' == 'external' : nom du fichier de la class | string | pour LIBRARY_PATH . '/monDirFormatAdapt/format.php', indiquer 'format.php'
medias |  |  |  |  |  | section médias | array |
 | toDeleteDuration |  |  |  |  | durée de conservation des médias abandonnés par leur propriétaire (en jours) | integer | 60
 | encodingErrorDuration |  |  |  |  | durée de conservation des médias avec des erreurs d'encodage (en jours) | integer | 30
 | toApproveSubscriptionDuration |  |  |  |  | durée de validité d'une demande d'approbation de partage (en jours) | integer | 15
 | uploadPath |  |  |  |  | path de l'upload (obligatoirement sur le serveur web) | string | \var\mediacad\local\media\upload
 | tmpPath |  |  |  |  | path des fichiers temporaires (sur le serveur de fichiers) | string | \var\mediacad\local\media\tmp
 | sourcePath |  |  |  |  | path des sources (sur le serveur de fichier) | string | \var\mediacad\local\media\source
 | encodedPath |  |  |  |  | path des fichiers encodés (sur le serveur de fichier) | string | \var\mediacad\local\media\encoded
 | mimeTypeMagicFilePath |  |  |  |  | path du fichier magic pour la vérification du mime type | null(= emplacement par défaut)|array | /usr/share/misc/magic.mgc
 | isAllowedEncoding |  |  |  |  | encodage autorisé pour l'application ? Si false, l'encodage doit être réalisé par un processus externe | boolean | false
 | maxParallelEncoding |  |  |  |  | nombre maximal d'encodages simultanés | integer | 5
 | encodingTaskMemoryLimit |  |  |  |  | memory limit pour une encodingTask ('-1' = pas de limite) | string | '-1'
 | keepFileSource |  |  |  |  | garder les fichiers sources ? | boolean | true
 | defaultIndexingLanguage |  |  |  |  | langue par défaut pour l'indexation | string | fr
 | media |  |  |  |  | partie média (vidéo, son, image, livre numérique) | array |
 |  | uploadMaxFileSize |  |  |  | poids maxi de l'upload (en octets) | integer | 100 * 1024 * 1024
 |  | maxInProgressDuration |  |  |  | durée maximale de l'encodage (en minutes) (maxi = 999) | integer | 30
 | thumbnail |  |  |  |  | partie vignette | array |
 |  | uploadMaxFileSize |  |  |  | poids maxi de l'upload (en octets) | integer | 2 * 1024 * 1024
 |  | maxInProgressDuration |  |  |  | durée maximale de l'encodage (en minutes) (maxi = 999) | integer | 30
 | pedagogicCard |  |  |  |  | partie fiche pédagogique | array |
 |  | uploadMaxFileSize |  |  |  | poids maxi de l'upload (en octets) | integer | 5 * 1024 * 1024
 |  | maxInProgressDuration |  |  |  | durée maximale de l'encodage (en minutes) (maxi = 999) | integer | 30
 | quotas |  |  |  |  | section quotas de stockage | array |
 |  | mediaQuotaCalcul |  |  |  | calcul de l'affectation du quota pour un média ; min = le plus petit poids | max = le plus grand poids | uploaded = le poids de l'upload | encoded = le poids de l'encodage | string | encoded
 |  | baseQuota |  |  |  | quota de base, pour tous les users (en octets) | integer | 1 * 1024 * 1024 * 1024
 |  | incrementStepQuota |  |  |  | taille ajouté au quota à chaque augmentation (en octets) | integer | 500 * 1024 * 1024
 |  | maxIncrementStepQuotaByRole |  |  |  | nombre maximal d'augmentations de quota en fonction du rôle ; quota maximal = baseQuota + (maxIncrementStepQuotaByRole[role] x incrementStepQuota) | array |
 |  |  | teacher |  |  | enseignant | integer | 1
 |  |  | schoolMod |  |  | modérateur établissement | integer | 4
 |  |  | acadMod |  |  | modérateur académique | integer | 8
 |  |  | superMod |  |  | super modérateur | integer | 18
 |  | maxRemainingQuotaToIncrement |  |  |  | quota restant maximum à partir duquel l'user peut obtenir une augmentation de quota (en octets) | integer | 100 * 1024 * 1024
 | encode |  |  |  |  | section encodage | array |
 |  | applications |  |  |  | paths des applications d'encodage NE PAS OUBLIER LES GUILLEMETS DOUBLES | array |
 |  |  | ffmpeg |  |  | audio + video | array |
 |  |  |  | ffmpeg |  | encodage vidéo + audio | array |
 |  |  |  |  | applicationPath | path | string | "C:\dev\apps\ffmpeg\bin\ffmpeg.exe"
 |  |  |  | ffprobe |  | infos sur video + audio | array |
 |  |  |  |  | applicationPath | path | string | "C:\dev\apps\ffmpeg\bin\ffprobe.exe"
 |  |  | imageMagick |  |  | images | array |
 |  |  |  | convert |  | encodage images | array |
 |  |  |  |  | applicationPath | path | string | "C:\dev\apps\imageMagick\convert.exe"
 |  |  | calibre |  |  | livres numériques | array |
 |  |  |  | ebookConvert |  | encodage books | array |
 |  |  |  |  | applicationPath | path | string | "C:\dev\apps\Calibre2\ebook-convert.exe"
 |  |  |  | ebookMeta |  | modification des metadata ebooks | array |
 |  |  |  |  | applicationPath | path | string | "C:\dev\apps\Calibre2\ebook-meta.exe"
 |  |  | unoconv |  |  | LibreOffice | array |
 |  |  |  | unoconv |  | conversion documents textes | array |
 |  |  |  |  | applicationPath | path | string | "C:\dev\apps\LibreOffice 4\program\python.exe" "C:\dev\apps\unoconv\unoconv"
 |  |  | pdftk |  |  | infos sur pdf | array |
 |  |  |  | pdftk |  | lecture d'infos sur pdf | array |
 |  |  |  |  | applicationPath | path | string | "C:\dev\apps\pdftk\bin\pdftk.exe"
 |  | ressources |  |  |  | gestion des ressources du serveur d'encodage | array |
 |  |  | video |  |  | video | array |
 |  |  |  | threads |  | nombre de threads à allouer à chaque tâche d'encodage | array |
 |  |  |  |  | webm | threads pour l'encodage en webm | integer | 4
 |  |  |  |  | mp4 | threads pour l'encodage en mp4 | integer | 4
 | search |  |  |  |  | section recherche | array |
 |  | lockIndexDuration |  |  |  | durée maximale de verrouillage de l'index (en secondes) | integer | 15
 |  | cache |  |  |  | cache de recherche | array |
 |  |  | useSearchCache |  |  | utiliser le cache de recherche | boolean | true
 |  |  | publicZone |  |  | cache de la zone publique | array |
 |  |  |  | defaultSearchDateSortCacheLifeTime |  | lifetime pour la recherche par défaut, classement par date de modification (en secondes) | integer | 15 * 24 * 60 * 60
 |  |  |  | defaultSearchViewSortCacheLifeTime |  | lifetime pour la recherche par défaut, classement par vues (en secondes) | integer | 15 * 60
 |  |  |  | customSearchScoreSortCacheLifeTime |  | lifetime pour les recherches personnalisées, classement par pertinence (en secondes) | integer | 15 * 60
 |  |  |  | customSearchDateSortCacheLifeTime |  | lifetime pour les recherches personnalisées, classement par date de modification (en secondes) | integer | 15 * 60
 |  |  |  | customSearchViewSortCacheLifeTime |  | lifetime pour les recherches personnalisées, classement par vues (en secondes) | integer | 15 * 60
 |  |  | loggedZone |  |  | cache de la zone connectée | array |
 |  |  |  | sortCacheLifeTime |  | lifetime pour toutes les recherches, classement par pertinence (en secondes) | integer | 15 * 60
 |  |  |  | dateSortCacheLifeTime |  | lifetime pour toutes les recherches, classement par date de modification (en secondes) | integer | 15 * 60
 |  |  |  | viewSortCacheLifeTime |  | lifetime pour toutes les recherches, classement par vues (en secondes) | integer | 15 * 60
statistics |  |  |  |  |  | partie statistiques | array |
 | schoolYearFirstMonth |  |  |  |  | premier mois de l'année scolaire | integer | 9

Créé avec HelpNDoc Personal Edition: Générateur complet de livres électroniques Kindle


Contrôles d'accès (ACL)

SAdmins ›› Installation ››

Les contrôles d'accès (ACL) sont définis dans le fichier de config /application/config/acl.cfg.array.php.

Vous ne devez pas modifier ce fichier sous peine de perdre ces modifications à la mise à jour.

Si vous souhaitez modifier ces ACL par défaut, copiez le fichier dans /local/config puis faites les modifications souhaitées : elles surchargeront la config par défaut.

Vous pouvez ne copier que la partie du tableau à modifier, à condition de respecter la structure du modèle.

Créé avec HelpNDoc Personal Edition: Générateur de documentation d'aide HTML gratuit


Tâches de maintenance

SAdmins ›› Installation ››

Médiacad est prévu pour mettre à jour tout seul les établissements et les utilisateurs, nettoyer les données et les médias, enregistrer les données statistiques, verrouiller l'index pendant la sauvegarde...

Pour cela, il existe différents web services à requêter.

Un script python gère toutes ces actions.

Les résultats détaillés de chaque tâche sont enregistrés dans les logs applicatifs.

Changer la configuration

Dans /local/config/application.cfg.array.php, partie ['auth']['adapters']['salt']['config']['passwords'], ajouter une entrée pour le serveur de maintenance différente de Médiacad (ce sera le login), par exemple "encodeServer", et indiquer son mot de passe.

Dans /local/config/wsAcl.cfg.array.php, modifier les entrées suivantes :

dans ['ws']['application']['maintenance], ['lockindex'], ['unlockindex'] et ['updateschools'], ajouter le login du serveur de maintenance ("encodeServer" dans notre exemple).

Maintenance automatique

Le web service est un simple ping qui lance la maintenance interne.

Il suffit donc d'appeler l'uri uri_de_mediacad/ws/application/maintenance. Médiacad ferme tout de suite la connexion, sans rien renvoyer, puis lance toutes les opérations de maintenance automatique.

Principales tâches de maintenance exécutées :

  • Nettoyage des utilisateurs :
    • suppression des comptes non utilisés depuis plus de x jours (config 'oldUsersKeepingDuration') ;
  • Nettoyage des médias :
    • suppression des médias abandonnés depuis plus de x jours (config 'toDeleteDuration') ;
    • suppression des médias en erreur d'encodage depuis plus de x jours (config 'encodingErrorDuration') ;
    • suppression des médias sans propriétaires ;
    • suppression des demandes d'approbations de partages posées depuis plus de x jours (config 'toApproveSubscriptionDuration') ;
    • ajout des statistiques correspondantes.
  • Nettoyage de l'index :
    • nettoyage des doublons et des incohérences éventuelles.
  • Enregistrement des statistiques :
    • enregistrement de toutes les statistiques journalières.
  • Nettoyage des logs de connexion :
    • suppression des logs de connexion de plus de x jours (config 'connectionLogsKeepingDuration') ;
  • Suppression des médias :
    • suppression de tous les médias pour les instances de démonstration (config 'isDemo').

Ces tâches ne peuvent être réalisées d'une seule fois par jour. Si vous lancez une deuxième fois la maintenance, seules les tâches qui auraient échoué seront relancées, les autres ne seront pas impactées.

A Bordeaux, nous lançons donc la tâche à 23h30 puis 23h45 par sécurité. Nous avons choisi de les lancer avant minuit pour que les dates des statistiques soient correctes.

Mise à jour des établissements et des utilisateurs

Le web service est un simple ping qui lance la mise à jour interne.

Il suffit donc d'appeler l'uri uri_de_mediacad/ws/application/updateschools. Médiacad ferme tout de suite la connexion, sans rien renvoyer, puis lance toutes les opérations de mise à jour des établissements et des utilisateurs.

Principales tâches de mise à jour exécutées :

Les tâches de mise à jour utilisent les méthodes des classes d'annuaire (/application/library/Directory/...).

  • Mise à jour des établissements et de leurs utilisateurs qui ont été modifiés depuis la dernière mise à jour.
  • Création automatique des établissements pour les utilisateurs sans établissement à moins de x jours de leur suppression (config 'oldUsersKeepingDuration').

Verrouillage / déverrouillage de l'index

Dans le cadre des opérations de sauvegarde, il faut s'assurer de la cohérence de l'index sauvegardé. Pour cela, deux web services permettent de verrouiller puis de déverrouiller l'index.

Le verrouillage se fait par l'appel de uri_de_mediacad/ws/application/lockindex, le déverrouillage par l'appel de uri_de_mediacad/ws/application/unlockindex.

Ces deux web services renvoient un json avec un message de succès ou d'erreur.

La durée maximale de verrouillage de l'index est fixée par la la config 'lockIndexDuration'. Passée cette durée, l'index n'est plus considéré comme verrouillé, même si unlockindex n'a pas été appelé.

Créé avec HelpNDoc Personal Edition: Générateur d'aide complet


Documentation du script

SAdmins ›› Installation ›› Tâches de maintenance ››

En exploitation certaines tâches de maintenance doivent être lancées automatiquement.
Aperçu de la crontab du serveur de production applicative :

# Lancer la maintenance sur Mediacad

30,45 23 * * * /appli/script/medadmin/mediacadAdministration.py --maintenance 2>&1 /log/mediacad/mediacadAdministration.log

15 02 * * * /appli/script/medadmin/mediacadAdministration.py --updateschools 2>&1 /log/mediacad/mediacadAdministration.log

Mais ça n'est pas tout, ce script permet aussi de vérouiller/dévérouiller l'index du Zend Search Lucene pour ses sauvegardes.
Il est ainsi appelé en prefetch par la procédure de sauvegarde (sous TSM chez nous) avec les options --lockindex/--unlockindex.

Le script doit être accompagné d'un fichier .ini contenant la configuration.
Ce fichier de configuration contient la section suivante :

  • mediacad : les paramètres pour le webservice de Médiacad

Contenu du fichier .ini :

[mediacad]

url: http://med1.in.ac-bordeaux.fr/ws/application/

login: encodeServer

password: maman

Créé avec HelpNDoc Personal Edition: Créer des documents d'aide PDF facilement


Script python de maintenance

SAdmins ›› Installation ›› Tâches de maintenance ››

#!/usr/bin/python

# -*- coding: utf-8 -*-

from time import sleep

import datetime

import sys

import urllib2

from cookielib import CookieJar

import urllib

import time

import simplejson as json

import hashlib

import getopt

import os

import ConfigParser

class mediacadAdministration():

def __init__(self, config):

""" Initialisation des variables internes """

# login (to access the webservice)

self.login = config.get("mediacad","login")

self.clearPassword = config.get("mediacad","password")

# url du webservice de Mediacad :

self.url = config.get("mediacad","url")

def maintenance(self):

""" This method runs the maintenance operations.

"""

answerRequest = self._requestWS("maintenance")

if answerRequest is not None:

self._printlog("maintenance() ; Resultat de l'appel a la maintenance: " + str(answerRequest))

def updateSchools(self):

""" This method update the users of the schools.

"""

answerRequest = self._requestWS("updateschools")

if answerRequest is not None:

self._printlog("updateschools() ; Resultat de l'appel a updateschools: " + str(answerRequest))

def lockIndex(self):

""" This method locks the index of Mediacad in order to able its backup.

"""

answerRequest = self._requestWS("lockindex")

if answerRequest is not None:

self._printlog("lockIndex() ; Resultat de l'appel a lockindex(): " + str(answerRequest))

def unLockIndex(self):

""" This method unlocks the index of Mediacad.

"""

answerRequest = self._requestWS("unlockindex")

if answerRequest is not None:

self._printlog("unLockIndex() ; Resultat de l'appel a unlockindex(): " + str(answerRequest))

def _strNow(self):

return time.strftime('%Y-%m-%d %H:%M:%S', time.localtime())

def _printlog(self, log):

print self._strNow() + " INFO " + str(log)

return;

def _printerr(self, log):

print self._strNow() + " ERROR " + str(log)

return;

def _requestWS(self, path, params = {}):

""" Request un webservice """

#self._printlog("_requestWS() ; Operation demandee ["+path+"]")

# L'interrogation du webservice de Mediacad necessite de pouvoir

# recuperer le cookie recieved lors du 1er appel,

# et de le renvoyer lors du 2nd appel (la recuperation de la

# prochaine task)

cj = CookieJar()

opener = urllib2.build_opener(urllib2.HTTPCookieProcessor(cj))

# Get le salt :

#self._printlog("_requestWS() ; getting the salt")

try:

page = opener.open(self.url+path)

result = page.read()

# self._printlog("_requestWS() ; answer du premier appel : "+str(result))

fluxRetour = json.loads(result)

except urllib2.HTTPError, error:

return {'isSuccess': False, 'data': {}, 'errorMessage': str(error)}

try:

salt = fluxRetour["data"]["salt"]

except KeyError:

return {'isSuccess': False, 'data': {}, 'errorMessage': "Salt not found dans la answer du webservice"}

# Authentification :

password = hashlib.sha256(self.clearPassword + salt).hexdigest()

params['login'] = self.login

params['password'] = password

#self._printlog("_requestWS() ; Authentification")

data_encoded = urllib.urlencode(params)

try:

#for cookie in cj:

#self._printlog('_requestWS() ; cookie [%s --> %s]'%(cookie.name,cookie.value))

page = opener.open(self.url+path, data_encoded)

result = page.read()

if result is not None and result != "":

reponse = json.loads(result)

else:

reponse = None

#self._printlog("_requestWS() ; answer de la request : "+str(reponse))

except urllib2.HTTPError, error:

return {'isSuccess': False, 'data': {}, 'errorMessage': str(error)}

#self._printlog("_requestWS() ; Exit")

return reponse

#

# Partie principale

#

def main(argv):

# Nom du script courant :

currentScript = os.path.abspath(__file__)

if currentScript[-3:] != ".py":

print "Mauvaise extension de fichier ! (<filename>.py)"

sys.exit()

# Lire la configuration :

config = ConfigParser.ConfigParser()

config.read(currentScript[:-3]+".ini")

help = currentScript+" [--help] [--maintenance] [--lockindex] [--unlockindex] [--updateschools]"

try:

options, args = getopt.gnu_getopt(sys.argv, 'h', ["help","maintenance","lockindex","unlockindex","updateschools"])

except getopt.GetoptError:

print help

sys.exit(2)

for opt, arg in options:

mc = mediacadAdministration(config)

if opt in ('-h', '--help'):

print help

elif opt == '--maintenance':

mc.maintenance()

elif opt == '--lockindex':

mc.lockIndex()

elif opt == '--unlockindex':

mc.unLockIndex()

elif opt == '--updateschools':

mc.updateSchools()

else:

assert False, "option incorrecte"

if __name__ == "__main__":

main(sys.argv[1:])

Créé avec HelpNDoc Personal Edition: Générateur de documentation d'aide HTML gratuit


Mise à jour de l'application

SAdmins ››

Suivre les instructions générales (1ère partie), puis les instructions particulières à chaque révision.

Instructions générales

Vous devez suivre ces instruction à chaque mise à jour des fichiers de Médiacad.

La mise à jour de la base de données est automatique, quelle que soit la différence entre la version ancienne et la nouvelle version de l'application.

Il est très fortement recommandé de réaliser d'abord la mise en jour en local ou sur un serveur de pré-prod, avec les données de la sauvegarde élaborée au point 4.

Vous testez ensuite l'absence de problèmes, et enfin vous pouvez mettre à jour le serveur de production.

1) Prévenez les utilisateurs de la future mise à jour de l'application (liste de diffusion, mails...).

2) Environ 1/4 d'heure avant la mise à jour, modifiez les variables d'environnement :

SetEnv APPLICATION_MODE update

SetEnv APPLICATION_UPDATE_STEP warning

Ceci affiche un message d'alerte sur toutes les pages de Médiacad, invitant les utilisateurs à se déconnecter, et interdit l'ajout et la modification des médias (pour purger les tâches d'encodage).

3) Dans Médiacad, avec le compte sAdmin, allez dans le menu Application > Mettre à jour Médiacad. La page indique le nombre de tâches d'encodage en cours et en attente.

VOUS NE DEVEZ PAS PASSER A LA MISE A JOUR TANT QUE DES FICHIERS NE SONT PAS ENCODES (sinon l'index sera incohérent).

Attendez et actualisez la page jusqu'à ce qu'elle indique en vert "Vous pouvez procéder à la mise à jour des fichiers.".

4) Modifiez de nouveau les variables d'environnement :

SetEnv APPLICATION_UPDATE_STEP files

Plus personne ne peut se connecter, et les utilisateurs encore connectés sont redirigés vers une page de maintenance.

5) IMPERATIF : faites une sauvegarde complète de la base de données, conservée hors du serveur.

6) IMPERATIF : faites une sauvegarde complète du dossier /local, conservée hors du serveur.

7) Notez le numéro de révision ancien de Médiacad (affiché en footer de chaque page, ou dans /application/library/Version.php, ligne 30, const REVISION = 'XXX';).

8) Uploadez les nouvelles sources (version de production) sur les serveur (en écrasant les anciens fichiers). Vous devez copier uniquement les dossiers /application, /library et /public, ***PAS LE DOSSIER /LOCAL***.

9) Suivez si disponibles les instructions particulières ci-dessous.

10) Modifiez de nouveau les variables d'environnement :

SetEnv APPLICATION_UPDATE_STEP database

Tout le monde peut à nouveau se connecter, mais seul un sAdmin peut travailler, les autres utilisateurs sont encore redirigés vers la page de maintenance.

11) Connectez-vous avec votre compte de sAdmin. Vous serez automatiquement dirigé vers la page de mise à jour de l'application.

12) Cliquez sur le bouton de mise à jour et patientez... Un message indique que la mise à jour s'est déroulée correctement. Vous devrez éventuellement refaire plusieurs fois la même action si votre installation était ancienne.

13) Repassez les variables d'environnement à leurs valeurs habituelles :

SetEnv APPLICATION_MODE normal

SetEnv APPLICATION_UPDATE_STEP warning

La mise à jour est terminée.

Instructions particulières pour chaque mise à jour

Ces instructions sont complémentaires aux instructions générales. La plupart du temps, les instructions générales suffisent.

Vous devez respecter toutes les instructions ultérieures à la version ancienne de l'application (le numéro que vous avez noté au point 7 ci-dessus).

La nouvelle révision est celle située en dernier de cette liste.

Par exemple, si l'application en était à la révision #180, vous devez suivre toutes les instructions particulières depuis le #181 jusqu'à la fin de la liste.

#522 27/12/2013

1) Modifier le virtualhost pour tenir compte des fichiers css et js gzipés :

AddEncoding x-gzip .gz

<FilesMatch ".css.gz$">

ForceType text/css

</FilesMatch>

<FilesMatch ".js.gz$">

ForceType application/javascript

</FilesMatch>

#582 18/02/2014

1) Ôter les droits d'écriture pour Apache sur /public/js/. Sur tout le dossier /public, Apache doit avoir uniquement les droits de lecture/exécution, pas de droits d'écriture/suppression.

#680 28/01/2015

1) Dans le virtualhost, modifier le path de mod_xsendfile.

Passer de XSendFilePath [...]/media/encoded à XSendFilePath [...]/media

#724 06/02/2015

1) Modifier éventuellement le lien de logout de l'ENT dans ['auth']['adapters'][nom_de_l_adaptateur]['logoutUri']. Laisser à NULL si pas de lien.

Nouveautés apportées par les scripts d'update

#330 22/10/2013

1) Modifications de la structure de la table maintenancetask (création d'un index PRIMARY).

#331 22/10/2013

1) Suppression de la table moderatorviewlog.

2) Suppression des champs isDeleted, deletedDate, isDeletedByModerator, deletedByModeratorName, deletedByModeratorMessage de la table media.

3) Ajout de la config ['media']['toDeleteDuration'] dans application.cfg.array.php.

#344 28/10/2013

1) Transfert de /local/config/schoolWhiteList.cfg.array.php vers /local/config/application.cfg.array.php.

#346 29/10/2013

1) Changement des cascades de delete sur publicSchoolSubscription.

2) Ajout du champ toApproveDate aux tables academicSubscription, publicSubscription et publicSchoolSubscription.

#348 29/10/2013

1) Transfert de /local/config/database.cfg.array.php vers /local/config/application.cfg.array.php.

2) Ajout de la config ['media']['toApproveSubscriptionDuration'] dans application.cfg.array.php.

#357 30/10/2013

1) Mise à jour de la config pour l'adaptateur d'authentification password + les tâches de maintenance.

#360 30/10/2013

1) Mise à jour de la config pour les nouveaux ACL des webServices + la maintenance + les pages application + help.

#388 06/11/2013

1) Mise à jour de la config pour les fonctions autorisées pour le staff lors de l'update d'établissement + encodingErrorDuration.

#418 17/11/2013

1) Création des tables pour les statistiques : statisticFile, statisticFileCount, statisticMediaEncode, statisticMediaCount,

statisticMediaView, statisticMediaReport, statisticMediaDelete, statisticSubscriptionRequest, statisticSubscriptionResponse,

statisticQuotaMax, statisticQuotaUsed, statisticSchoolCount, statisticUserCount.

#421 17/11/2013

1) Modification de la valeur locale de incrementStepQuota.

#438 22/11/2013

1) Mise à jour de la config pour les nouveaux ACL des webServices.

2) Mise à jour de la config : ajout de 'lockIndexDuration', 'statistics', 'schoolYearFirstMonth', 'logFilePath', threads.

#454 30/11/2013

1) Ajout du champ threadsCount aux tables encodingtask et statisticfile.

#474 08/12/2013

1) Création de la table schoolzone.

2) Modification de la table school (schoolZoneId).

3) Création d'une zone fictive affectée aux établissements existants (contrainte de clef étrangère) + impose une mise à jour des établissements.

4) Modification des types d'établissements (tables school et statisticschoolcount).

5) Modification de la table statisticusercount (activeStudentCount, activeTeacherCount).

#490 15/12/2013

1) Modification de la valeur locale de la liste de diffusion.

2) Mise à jour de la config ('isSchoolNeedsToUpdate', 'isAllowedAutoUpdateAllSchools').

3) Mise à jour de la config pour les nouveaux ACL des WS.

#500 17/12/2013

1) Modification des COLLATE des label pour les tables tables mediaauthor, mediacollection, mediaproject et mediapublisher.

#515 25/12/2013

1) Modification des tables statisticschoolcount et statisticusercount.

#522 27/12/2013

1) Ajout de la config 'internalWSBaseUri', 'reportedMediasKeepingDuration'.

#540 12/01/2014

1) Modification de la valeur locale de la déclaration CNIL.

#564 28.01.2014

1) Ajout de la config 'isDemo'.

#582 18/02/2014

1) Ajout de configs dans application.cfg.array.php.

#652 24.01.2015

1) Ajout de la config 'useMinify'.

#657 26.01.2015

1) Ajout d'un index sur la table school_user.isTeacher.

2) Création de la table staff.

3) Remplissage de la table staff.

#690 01/02.2015

1) Suppression des configs 'displayResultCount' et 'maxCountSearchHits'.

#724 06/02/2015

1) Ajout de la config 'logoutUri' dans la partie auth.

Créé avec HelpNDoc Personal Edition: Créer de la documentation iPhone facilement


Diffusion des médias

SAdmins ››

Il est possible d'utiliser Médiacad comme diffuseur de médias depuis une autre application ou un autre site web.

Il y a deux possibilités pour cela : diffuser via une iframe ou obtenir un json / jsonp.

Diffusion d'un média dans une iframe

Pour diffuser un média dans une application externe ou un site web, il suffit de copier le code iframe présent dans l'onglet Liens quand on affiche le média dans Médiacad.

Si vous rajoutez le paramètre /a/[ce_que_vous_voulez], la vidéo ou le son sera joué en autoplay.

Obtenir un json / jsonp

Médiacad peut aussi renvoyer un json / jsonp pour obtenir des informations sur un média donné. Bien entendu, seuls les utilisateurs ayant les droits d'accès au média obtiendront ce json / jsonp.

Url d'appel du json / jsonp

L'url d'appel pour obtenir un json est de la forme :

##mediacadBaseUrl##/default/media/display/m/##mediaId##/d/j

L'url d'appel pour obtenir un jsonp est de la forme :

##mediacadBaseUrl##/default/media/display/m/##mediaId##/d/j?callback=##javascriptCallbackFunction##

Avec :

##mediacadBaseUrl## : url du serveur de Médiacad (ex : https://ent2d.ac-bordeaux.fr/mediacad)

##mediaId## : identifiant du média désiré (ex : 728)

##javascriptCallbackFunction## : nom de la fonction de callback ajoutée dans le jsonp ; ce nom ne doit pas être un nom réservé par javascript et passer la regex suivante : '#^[a-zA-Z$_]{1}[a-zA-Z0-9$_]{0,}$#'

Json / jsonp obtenu

Médiacad renvoie une page avec comme header : "Content-type: application/javascript;charset=utf-8".

Attention !

Aucune valeur du json n'est échappée. Il appartient à l'application cliente de correctement échapper les données fournies pour éviter notamment des failles XSS.

Format et valeurs du json

Le json respecte la norme oembed 1.0.

Clef | Médias | Valeurs possibles | Valeur par défaut | Remarques
version | tous | "1.0" | "1.0" | Version de oembed
is_displayable | tous | true | false | true | Le média est-il affichable ?
no_displayable_code | tous | null "401" "mediaIsNotFinishedEncoding" "mediaHasEncodingError" | null | Code d'affichage impossible
no_displayable_message | tous | null "Accès impossible à ce média. Soit ce média n'existe pas, soit vous n'y avez pas ou plus accès." "Ce média est encore en cours d'encodage. Veuillez patienter quelques minutes." "Ce média a connu des erreurs lors de son encodage." | null | Message d'affichage impossible
type | tous | null | "video" | "audio" | "image" | "book" | null | null si no_displayable_code == "401" Type de média
title | tous | null | string | null | null si no_displayable_code == "401"
author_name | tous | null | "" | string | null | null si no_displayable_code == "401" Vaut "" si le média n'est pas indexé ; forcément valorisé sinon.
description | tous | null | "" | string | null | null si no_displayable_code == "401" Vaut "" si le média n'est pas indexé ; forcément valorisé sinon.
provider_name | tous | string | App_Lib_Config::getConfig('application', 'applicationName') | Par défaut : "Médiacad"
provider_url | tous | string | PUBLIC_BASE_URI |
thumbnail_url | tous | null | string | null | null si is_displayable == "false" ou si thumbnailType == "default" Url de la vignette ; peut être intégrée directement dans une balise <img>.
thumbnail_width | tous | null | integer | null | null si is_displayable == "false" ou si thumbnailType == "default"
thumbnail_height | tous | null | integer | null | null si is_displayable == "false" ou si thumbnailType == "default"
html | tous | null | string | null | null si is_displayable == "false" Code iframe complet pour afficher ce média.
permalink | tous | null | string | null | null si no_displayable_code == "401"
width | video | image | null | integer | null | Largeur du média (en pixels)
height | video | image | null | integer | null | Hauteur du média (en pixels)
url | image | null | string | null | Url de l'image ; peut être intégrée directement dans une balise <img>.

Format du jsonp

Le jsonp est de la forme :

/**/##javascriptCallbackFunction##(##json##);

Créé avec HelpNDoc Personal Edition: Créer des aides HTML, DOC, PDF et des manuels depuis une même source


Développeurs

Créé avec HelpNDoc Personal Edition: Générateur d'aide complet


Mise à jour des scripts externes

Développeurs ››

Pour tous les scripts

  1. Mettre à jour le numéro de version dans default.csv, clef "defaultApplicationAboutFrameworkText".
  2. Générer les tmx.

Zend Framework

  1. Ecraser les fichiers présents avec les nouvelles sources.
  2. Commenter tous les require_once sauf ceux de /Loader/Autoloader.php et de /Application.php.

Créé avec HelpNDoc Personal Edition: Éditeur complet de livres électroniques ePub


TODO nouvelle version

Développeurs ››

Avant l'élaboration du tag

  1. Mettre à jour les scripts externes (voir la page Mise à jour de l'application ).
  2. Tester complètement l'application pour détecter des régressions éventuelles.
  3. Vérifier dans cette documentation que les pages " Mise à jour de l'application " et " What's new ? " sont bien à jour.
  4. Générer la base de données de test + le SQL correspondant (pour la prod, laisser uniquement INSERT INTO `schoolzone` (`schoolZoneId`, `label`) VALUES (1, 'defaultZone'); et INSERT INTO `version` (`revision`) VALUES (571);).
  5. Ajouter des pages éventuelles dans la documentation en fonction des modifications introduites dans la nouvelle version.
  6. Mettre à jour la classe de version (/application/library/Version.php) avec la bonne version (nom de la version).
  7. Générer les fichiers css et js combinés et minifiés (exécuter le fichier /library/minify/minify.cmd).

Test de pré-prod

  1. Mettre à jour l'application sur le serveur de pré-prod.
  2. Tester complètement l'application (surtout les nouvelles fonctionnalités).
  3. Noter les bugs éventuels (fichiers de log...).
  4. S'il y a des bugs, les corriger puis recommencer toute la procédure.

Création du tag SVN

  1. Créer un nouveau tag via SVN.
  2. Faire un update to head des sources.
  3. Commiter à nouveau pour ajouter le tag en local.

Élaboration des sources pour distribution

  1. Réaliser un export des sources vers les sources de dév.
  2. Supprimer tous les médias de /local/media/.
  3. Supprimer tous les fichiers de /local/cache/.
  4. Supprimer tous les fichiers de /local/index/.
  5. Supprimer tous les fichiers de /local/log/.
  6. Remplacer /local/config/application.cfg.array.php par /application/config/application.cfg.array.php.
  7. Copier les nouvelles sources vers les sources de prod.
  8. Supprimer des sources de prod les dossiers /dev et /doc.
  9. Générer les fichiers compressés en .zip et .tar.gz.

Publier les sources

  1. Uploader les sources sur le site vitrine.
  2. Mettre à jour /download/lastRevision.js.
  3. Mettre à jour la page telechargement.php.

Créé avec HelpNDoc Personal Edition: Créer des documents d'aide PDF facilement


Conventions de codage

Développeurs ››

Médiacad suit les conventions de codage du Zend_Framework 1.12. Une version de ces conventions est disponible dans les sources en format pdf (/dev/developpers/CodingStandard.pdf).

Conventions complémentaires :

Tous les noms (variables, classes, méthodes, propriétés, fonctions, constantes...) sont en anglais (éviter le franglais), même si c'est parfois de l'anglais de cuisine ;o).

Les noms doivent être assez explicites, quitte à les rallonger. Par exemple, le tableau de résultat d'une requête sur school_user sera nommé $schoolUserRowset plutôt que $result.

Les variables contenant des objets portent le nom complet de l'objet (par exemple, $appModelSchoolUser, $zendTranslate...).

Règles de codage :

Aucune configuration codée en dur. Toutes les configurations se trouvent dans /application/configs/ pour les configurations de l'application susceptibles de changer lors de mises à jour (liste des disciplines, des langues...), et dans /local/configs/ pour celles liées à l'instance (codes d'accès à la base de données...).

Les configs sont sont

sous forme d'array pour les configs chargées à chaque page afin d'alléger la charge serveur ; leur nom est de la forme [nomConfig].cfg.array.php ;

sous forme de fichier XML pour les configs mises en cache en production ; leur nom est de la forme [nomConfig].cfg.xml ;

Aucun code ne doit être dupliqué (principe DRY = Don't Repeat Yourself). Tout code dupliqué doit être déplacé soit dans une classe dédiée (classe Application_Library_Media par exemple), soit dans un actionHelper, un viewHelper ou un frontControllerPlugin.

Aucune modification des libraries externes, mais extension des classes (dans /application/library/). Les classes utilisées souvent (Zend_Form, Zend_Translate...) sont étendues par défaut même si aucune modification n'est apportée dans un premier temps.

Aucune chaîne de caractère de vue codée en dur : l'application est internationalisée, avec des fichiers TMX (dans /application/languages/). Voir la documentation complémentaire sur les traductions.

Créé avec HelpNDoc Personal Edition: Créer des livres électroniques facilement


Nouvelles traduction

Développeurs ››

Pour ajouter une nouvelle langue :

  1. Ajouter les traductions dans les fichiers de traduction (/application/languages/*).
  2. Ajouter un fichier de langue pour tous les champs d'indexations (/application/config/indexing/*).
  3. Ajouter un fichier stopwords (/application/config/indexing/stopwords/).

Créé avec HelpNDoc Personal Edition: Créer des documents d'aide HTML facilement


Tables de la base de données

Développeurs ››

Documentation non mise à jour

Modèle conceptuel de données et scripts SQL

Le MCD de Médiacad est disponible aux formats pdf (source:trunk/docs/developpers/database/MCD_mediacad.pdf) et mwb (source:trunk/docs/developpers/database/MCD_mediacad.mwb) (MySQL Workbench 5.2 CE) dans la partie docs/developpers/database/ des sources (source:trunk/docs/developpers/database).

Les scripts SQL de la base de données de départ (tables (source:trunk/application/configs/install/tables.install.sql) et triggers (source:trunk/application/configs/install/triggers.install.sql)) sont disponibles dans la partie application/configs/install/ des sources (source:trunk/application/configs/install).

Encodage et formats de tables

La base de données et les tables sont encodées en utf8_unicode_ci.

Toutes les tables sont au format InnoDB.

Conventions de nommage

Tous les noms sont en anglais (tables, champs, enum...) pour éviter le franglais (getEleveById... par exemple).

Noms de tables

Les noms de tables sont en minuscules.

Seules les tables de jointure comportent des underscores (_) de la forme table1_table2 (dans l'ordre 1 -> n).

Nom des champs

Tous les champs sont en notation camelCase (sauf les clefs primaires des tables de jointure : voir ci-dessous).

La clef primaire (quand elle existe) est de la forme nomDeLaTableId (en camelCase). Par exemple, la clef primaire de la table moderatorviewlog est moderatorViewLogId.

Par exception, la clef primaire d'une table de jointure est de la forme nomDeLaTable1_nomDeLaTable2_id. Par exemple, la clef primaire de la table school_user est school_user_id.

Les champs suffixés par Id sont des clefs étrangères avec des contraintes associées (ON UPDATE CASCADE, ON DELETE CASCADE ou SET NULL selon les cas). Par exemple, media.ownerUserId est une clef étrangère pointant vers user.userId.

Les champs suffixés par Code sont des identifiants externes à la base, gérés par des fichiers de configuration de l'application. Par exemple, media_language.languageCode fait référence au code que l'on trouve dans /application/config/language.cfg.array.php.

Les champs préfixés par is, has ou must sont des champs "booleens" (ENUM ('0','1')), et inversement.

Description des tables

Description analytique

Nom de la table Description

academicsubscription Abonnements académiques (y compris publics)

connectionlog Logs des connexions au module pr (private)

encodingtask Tâches d'encodage (médias et fiches pédagogiques) en attente et en cours (tâche de fond)

group Groupes (divisions)

group_school_user Table de jointure groupes / utilisateurs en établissements

maintenancetask Dates des maintenances automatiques de l'application

media Médias

mediaauthor Auteurs (indexation)

mediacollection Collections (indexation)

mediapublisher Editeurs (indexation)

media_audience Table de jointure média / public (clefs externes à la base /application/config/audience.cfg.array.php)

media_discipline Table de jointure média / matières enseignées (clefs externes à la base /application/config/discipline.cfg.array.php)

media_keyword Table de jointure média / mots clefs du thesaurus UNESCO (clefs externes à la base /application/config/keyword.cfg.array.php)

media_language Table de jointure média / langues (clefs externes à la base /application/config/language.cfg.array.php)

media_mediaauthor Table de jointure média / auteurs

media_mediacollection Table de jointure média / collections

media_mediapublisher Table de jointure média / éditeurs

media_type Table de jointure média / genres (clefs externes à la base /application/config/type.cfg.array.php)

moderatorviewlog Logs des affichages de médias par le superMod quand il n'y a normalement pas accès

personalsubscription Abonnements personnels (favoris)

publicschoolsubscription Abonnements établissements publics

request Demandes d'abonnements établissements publics, académiques et académiques publics, de suppression définitive et de signalements

school Etablissements

schoolsubscription Abonnements établissements

schoolsubscription_audience Table de jointure abonnement établissement / public (clefs externes à la base /application/config/audience.cfg.array.php)

schoolsubscription_group Table de jointure abonnement établissement / groupes (divisions)

school_user Table de jointure établissement / utilisateur (+ rôles établissement)

statisticvisit Statitiques de visites (connexions + anonymes)

user Utilisateur (+ rôles généraux)

userconfig Configuration utilisateur (signature charte...)

version Version de la structure de la base de données (numéro de révision) pour l'update de l'application

Description synthétique

La table user regroupe les fiches uniques de tous les users de l'application. La jointure avec l'annuaire académique se fait via user.uid, surdimensionné (VARCHAR(15)) pour s'adapter à d'autres UID que l'académie de Bordeaux. La jointure avec les autres tables de l'application se fait via user.userId. La table contient aussi les rôles au niveau de l'application (acadMod, superMod, sAdmin). Le champs user.schoolRegisteredCount indique le nombre d'établissements dans lequel l'user est inscrit (table school_user) pour faciliter la maintenance de la base (par exemple, supprimer les users inscrits dans aucun établissement depuis plus de 6 mois (champs user.lastUpdateDate)). La cohérence des données entre user et school_user est assurée par les deux triggers after_insert_school_user et after_delete_school_user.

La table userconfig contient les configurations personnelles de chaque user, userconfig.label étant le nom de la config et userconfig.value sa valeur. Par exemple : userconfig.label == "hasValidatedCharter" indique si l'user a validé ou non la charte d'utilisation (userconfig.value == '1' ou '0').

La table connexionlog contient les logs de connections ;o).

La table school regroupe tous les établissements de l'application. La jointure avec l'annuaire académique se fait via school.uai (ex RNE). La jointure avec les autres tables de l'application se fait via school.schoolId.

La table school_user fait la jointure entre school et user dans une relation n:m. La table contient aussi les rôles au niveau de l'établissement (student, teacher, schoolMod).

La table group contient tous les groupes de l'application (en fait, les divisions uniquement). La jointure avec l'annuaire académique se fait via group.label. Le code MefStat5, conservé pour mémoire dans group.mefStatCode, permet d'affecter le groupe aux niveaux de l'application (group.groupLevelCode) via une table de concordance.

La table group_school_user fait la jointure entre group et school_user dans une relation n:m. Avec les contraintes de foreign key (ON DELETE CASCADE), tout user désinscrit d'un établissement (school_user) sera automatiquement supprimé des groupes de l'établissement (group_school_user). Le champ group_school_user.userType permet d'indiquer si l'user est un student ou un teacher dans le groupe.

La table media est la table centrale de l'application, sa clef primaire (media.mediaId) étant référencée dans 15 autres tables de l'application. Chaque média dispose d'une entrée dans cette table, qui contient aussi des caractéristiques techniques, les conditions de suppression, une partie de l'indexation (celles de relation 1:0,1), les statistiques de consultation et de téléchargement entre autres.

La table encodingtask contient les tâches d'encodage en attente et en cours, effectuées en tâches de fond.

Les tables mediaauthor, mediapublisher et mediacollection regroupent respectivement les listes d'auteurs, d'éditeurs et de collections. Ces listes sont saisies par les users (si l'item n'est pas déjà disponible), et modérées par le superMod (correction ou fusion d'items).

Les tables media_mediaauthor, media_mediapublisher et media_mediacollection sont les tables de jointure entre les tables ci-dessus et la table media, dans une relation n:m.

Les tables media_type (genres), media_language (langues), media_keyword (mots clefs du thesaurus UNESCO), media_discipline (matières enseignées) et media_audience (public) sont les tables de jointure entre des clefs externes à la base (que l'on peut trouver dans application/config/[key].cfg.array.php) et la table media dans une relation n:m.

La table moderatorviewlog contient les logs des consultations de médias auxquels normalement le superMod n'a pas accès.

Les tables []subscription concernent les abonnements aux médias.

La table personnalsubscription contient les abonnements personnels (favoris), liés à la foreign key user.userId. Les abonnements personnels ne sont donc pas supprimés au départ d'un user d'un établissement (suppression de school_user.school_user_id).

La table schoolsubscription contient les abonnements établissements. Elle est liée à la table media par une relation n:m. La foreign key schoolsubscription.school_user_id avec la contrainte ON DELETE CASCADE entraine la suppression des abonnements établissement quand l'user quitte l'établissement.

La table schoolsubscription_audience est la table de jointure entre les abonnements établissement et le public (clefs externes à la base que l'on peut trouver dans application/config/audience.cfg.array.php) dans une relation n:m.

La table schoolsubscription_group est la table de jointure entre les abonnements établissement et les groupes dans une relation n:m.

La table publicschoolsubscription contient les abonnements établissements publics. La foreign key publicschoolsubscription.school_user_id a pour contrainte ON DELETE SET NULL : quand le schoolMod quitte l'établissement, l'abonnement n'est pas supprimé.

La table academicsubscription contient les abonnements académiques et académiques publics (même ligne). Les foreign keys academicsubscription.userId et academicsubscription.publicUserId ont pour contrainte ON DELETE SET NULL : quand l'acadMod ou le superMod est supprimé de l'application, les abonnements ne sont pas supprimés.

La table request contient toutes les demandes possibles dans l'application (demande d'abonnement établissement public, académique, académique public, de suppression, de signalement). Le champ request.mediaId peut être NULL en cas de signalement d'un média par un user n'y ayant pas accès (il devra dans request.requestMessage indiquer suffisamment de détails pour que le destinataire trouve le média). Les destinataires sont indiqués dans request.requestRecipient.

La table statisticvisit contient les statistiques journalières de connections (student et teacher) et de consultation (anonym).

La table maintenancetask contient les dates des maintenances automatiques de l'application (réalisées à la première connection d'un user de la journée).

La table version contient la version de la base de données (numéro de commit du SVN), à comparer avec application/library/Version.php pour s'assurer de la concordance version de la base de données <-> version des scripts. En cas de différence, une mise à jour automatique des tables est effectuée via pr::sadmin::update.

Triggers

Les triggers (source:trunk/application/configs/install/triggers.install.sql) sont les suivants :

Table school_user :

after_insert_school_user : incrémente user.schoolRegisteredCount et modifie user.lastUpdateDate à NOW() pour l'user correspondant.

after_delete_school_user : décrémente user.schoolRegisteredCount et modifie user.lastUpdateDate à NOW() pour l'user correspondant.

Créé avec HelpNDoc Personal Edition: Environnement de création d'aide complet


Indexation et recherche

Développeurs ››

Créé avec HelpNDoc Personal Edition: Environnement de création d'aide complet


Champs d'indexation

Développeurs ›› Indexation et recherche ››

Documentation non mise à jour

Champs d'indexation des médias

Champ Description Type Remarques

mediaId mediaId keyword integer

title titre text

author auteurs text noms des auteurs concaténés avec virgules

publisher éditeur text noms des éditeurs concaténés avec virgules

collection collection text noms des collections concaténés avec virgules

source source text pas de recherche pour le moment

publicationDate date de publication text pas de recherche pour le moment

language langues text noms des langues selon la locale concaténés avec virgules

keyword catégories text noms des catégories selon la locale concaténés avec virgules

description description text à tronquer dans la présentation des résultats

discipline disciplines text noms des disciplines selon la locale concaténés avec virgules

audience public visé text nom des publics selon la locale concaténés avec virgules

type genres text noms des genres selon la locale concaténés avec virgules

extractOf extrait de text

ownerUserId propriétaire keyword userId

ownerName propriétaire text string

duration durée du média keyword hh:mm:ss

size taille de l'image keyword

pageCount nombre de pages keyword integer

lastChangeDate dernière modification keyword AAAA-MM-JJ HH-MM-SS

mediaType type de média keyword

thumbnailType type de vignette keyword

hasPedagogicCard il y a une fiche pédagogique keyword '0' | '1'

isFastIndexed Indexé rapidement keyword '0' | '1'

isToDelete actuellement sans owner keyword '0' | '1'

isFinishedEncoding encodage terminé keyword '0' | '1'

hasEncodingError erreurs d'encodage keyword '0' | '1'

totalViewCount nombre total de vues keyword integer

subscription abonnements text voir plus bas

Champ subscription

Dans l'indexation, les "_" sont remplacés par des "àà" sinon les codes sont tokenisés entre chaque _.

Par exemple, o_973 est indexé ààoàà973.

Abonnement Format Remarques

owner ààoàà[userId] pour accès + info

personalSubscription ààperso pour accès + info

ààpsààouàà[userId] pour accès + info

schoolSubscription ààschool pour accès + info

ààsààsàà[schoolId] pour accès

ààsààsàà[schoolId]ààaàà[audienceCode] pour accès

ààsààgàà[groupId] pour accès

ààsààsuàà[school_user_id] pour accès (users autorisés)

ààsààosuàà[school_user_id] pour info (créateur du subscription)

publicSchoolSubscription àànapssààsàà[schoolId] partage non encore approuvé

ààpss pour accès

ààpssààosuàà[school_user_id] pour info

staffAcademicSubscription ààstaffacad pour accès

ààsaààuàà[userId] pour accès (users autorisés)

ààsaààouàà[userId] pour info (créateur du subscription)

academicSubscription àànaacad partage non encore approuvé

ààacad pour accès

ààacadààstudent pour accès

ààaààaàà[audienceCode] pour accès

ààaààouàà[userId] pour info

publicSubscription àààànapublic partage non encore approuvé

ààààpublic pour accès

ààpààouàà[userId] pour info

Exemples

Exemple 1 :

Valeur du champ : ' ps_ou_973 ps_ou_1258 s_s_125_a_0100 s_s_125_a_2110 s_g_25478 s_osu_123456 '

Explications :

' ps_ou_973 ps_ou_1258 ' : les users #973 et #1258 ont un personalSubscription

' s_s_125_a_0100 s_s_125_a_2110 ' : l'établissement #125 a un schoolSubscription pour tous les enseignants (audienceCode = '0100') et pour tous les élèves de 6e (audienceCode = '2110')

' s_g_25478 ' : le groupe #25478 a un schoolSubscription

' s_osu_123456 ' : le school_user #123456 a créé un schoolSubscription.

Exemple 2 :

Valeur du champ : ' ps_ou_973 pss pss_osu_753951 '

Explications :

' ps_ou_973 ' : l'user #973 a un personalSubscription

' pss ' : il y a (au moins) un publicSchoolSubscription

' pss_osu_753951 ' : le school_user #753951 a créé un publicSchoolSubscription.

Exemple 3 :

Valeur du champ : ' ps_ou_973 a_a_0100 a_ou_973 '

Explications :

' ps_ou_973 ' : l'user #973 a un personalSubscription

' a_a_0100 ' : il y a un academicSubscription pour tous les enseignants (audienceCode = '0100')

' a_ou_973 ' : l'user #973 a créé l'academicSubscription.

Exemple 4 :

Valeur du champ : ' ps_ou_973 a_a_0100 a_ou_973 public p_ou_973'

Explications :

' ps_ou_973 ' : l'user #973 a un personalSubscription

' a_a_0100 ' : il y a un academicSubscription pour tous les enseignants (audienceCode = '0100')

' a_ou_973 ' : l'user #973 a créé l'academicSubscription

' public ' : il y a un publicSubscription

' p_ou_973 ' : l'user #973 a créé le publicSubscription.

Créé avec HelpNDoc Personal Edition: Créer des documents d'aide PDF facilement


Recherche

Développeurs ›› Indexation et recherche ››

Documentation non mise à jour

Recherche

Différentes recherches possibles

recherche uri données POST tri remarques

default [default|pr]/index/index ['sort'] date (défaut) | view page d'accueil des différentes zones

personalSubscription pr/index/index/mode/pS ['sort'] date (défaut) | view dans le menu de navigation

subscription pr/index/index/mode/s ['sort'] date (défaut) | view dans le menu de navigation

owner pr/index/index/mode/o ['sort'] date (défaut) | view dans le menu de navigation

ownerPrivate pr/index/index/mode/oP ['sort'] date (défaut) | view dans le menu de navigation

rapid [default|pr]/index/index/mode/r 'query', ['sort'] score (défaut) |date|view en barre de menu

advanced [default|pr]/index/advanced '...', ['sort'] score (défaut) |date|view

expert [default|pr]/index/advanced '...', ['sort'] score (défaut) |date|view

history [default|pr]/index/index/mode/h/id/[userSearchId] -- l'ordre de tri de la recherche

bookmark pr/index/index/mode/b -- score (défaut) |date|view

Tri

Les trois critères de tri possible sont par pertinence , par date de dernière modification et par nombre de vues.

Affichage des résultats de recherche

Les résultats de recherche (pagination) sont renvoyés en ajax pour soulager les ressources serveur et pour accélérer le temps de chargement visible de la page.

La recherche est réellement effectuée lors du premier affichage de la pagination.

L'uri pour la requête ajax est du type /default/index/index/page/[pageNumber].

Performances et mise en cache des résultats de recherche

Toutes les recherches et leurs résultats sont mis en cache via Zend_Cache (zone publique pour les recherches par défaut) et en session (pour toutes les autres, avec un lifetime court).

Mise en cache

Données mises en cache et en session

objet résultats de recherche ($hits)

données du form advanced (advanced ou expert search) ou query (rapid search)

numéro d'ordre (userSearchId)

titre de la recherche

zone

ordre de tri

type de recherche

Créé avec HelpNDoc Personal Edition: Créer des livres électroniques facilement


Droits de consultation

Développeurs ›› Indexation et recherche ››

Documentation non mise à jour

Un média n'est intégré dans la liste des résultats de recherche que si l'user (connecté ou non) a le droit de les consulter.

Ces droits sont déterminés par les subscriptions (abonnements / partages / favoris) et dépendent des abonnements, de la zone (publique, académique, établissement) et de l'user (student ou teacher, classe...).

Les droits sont cumulatifs : il suffit qu'une seule condition soit satisfaite pour que l'user accède au média.

Lors de la recherche, la base de donnée n'est pas utilisée : les droits sont stockés dans le champ 'subscription' de l'index. L'index est donc mis à jour à chaque modification des abonnements.

Détermination des droits d'accès

Zone publique

user abonnement(s) nécessaire(s) exemple de champ 'subscription' remarques

anonyme, teacher, student publicSubscription ' public '

Zone académique

En zone académique :

un user a le rôle de 'teacher' s'il est teacher ou schoolMod ou acadMod dans au moins un établissement

un user a le rôle de 'student' s'il est student dans au moins un établissement. S'il appartient à plusieurs établissements, il a les droits relatifs à chacune des classes dont il fait partie. Par exemple, si dans un établissement il est inscrit en CPGE et dans un autre en BTS, il pourra accéder en zone académique aux médias destinés à ces deux classes.

Les rôles sont cumulatifs : un même user peut théoriquement être en zone académique à la fois un student et un teacher (un assistant d'éducation (rôle = teacher) inscrit en BTS (rôle = student) dans un autre établissement par exemple).

Dans le tableau ci-dessous, le student est élève d'un établissement en classe de 5eB.

user abonnement(s) nécessaire(s) exemple de champ 'subscription' remarques

superMod peut consulter tout média de la zone académique ' a_a_*' tous les audienceCode

teacher peut consulter tout média de la zone académique ' a_a_*' tous les audienceCode

student academicSubscription avec public = 'tous les élèves' ' a_a_0200 ' audienceCode = '0200' => 'tous les élèves'

academicSubscription avec public = 'tous les élèves de XXX' ' a_a_2000 ' audienceCode = '2000' => 'tous les élèves de collège'

academicSubscription avec public = '[niveau YYY]' ' a_a_2120 ' audienceCode = '2120' => '5e'

Rappel : pour le student, un seul des trois abonnements possibles est nécessaire pour donner l'accès au média.

Zone établissement

En zone établissement, les droits dépendent de l'établissement sélectionné par l'user. Un média visible dans l'un des établissements pourra ne pas être accessible dans un autre. Dans le tableau ci-dessous, l'établissement a pour schoolId #125, le student est élève de cet établissement en classe de 5eB (groupId = #123456).

user abonnement(s) nécessaire(s) exemple de champ 'subscription' remarques

superMod peut consulter tout média de toutes les zones établissements ' s_s_*'

schoolMod peut consulter tout média disposant d'un schoolSubscription, quel qu'il soit ' s_s_125_*'

teacher schoolSubscription avec public = 'tous les enseignants' ' s_s_125_a_0100 ' audienceCode = '0100' => 'tous les enseignants'

owner + au moins un schoolSubscription ' o_973 s_s_125_a_* '

student schoolSubscription avec public = 'tous les élèves' ' s_s_125_a_0200 ' audienceCode = '0200' => 'tous les élèves'

schoolSubscription avec public = 'tous les élèves de XXX' ' s_s_125_a_2000 ' audienceCode = '2000' => 'tous les élèves de collège'

schoolSubscription avec public = '[niveau YYY]' ' s_s_125_a_2120 ' audienceCode = '2120' => '5e'

schoolSubscription avec groupe = '[groupeId]' ' s_s_125_g_123456 ' groupId = '123456' => '5eB'

Cas particuliers

publicSchoolSubscription

Le publicSchoolSubscription permet l'accès au média sans authentification (via le site web de l'établissement par exemple). En revanche, il ne change pas les résultats de recherche dans Médiacad. Par exemple, un média ayant un publicSchoolSubscription mais aucun autre abonnement sera accessible directement (par exemple via l'url http://mediacad.ac-bordeaux.fr/pr/media/display/mediaId/1234), même non authentifié, mais ne sera jamais renvoyé par une recherche.

Favoris

Une recherche spécifique par favoris est possible. Elle est tient compte des zones et des abonnements disponibles (mêmes droits que pour une recherche classique, un filtre est seulement rajouté).

user abonnement(s) nécessaire(s) exemple de champ 'subscription' remarques

teacher personalSubscription + abonnements selon la zone ' pS_u_973 ' +... userId = #973

Mes médias

Comme pour les favoris, une recherche spécifique pour les médias de l'user est possible. Elle est tient compte des zones et des abonnements disponibles (mêmes droits que pour une recherche classique, un filtre est seulement rajouté).

user abonnement(s) nécessaire(s) exemple de champ 'subscription' remarques

teacher owner + abonnements selon la zone ' o_973 ' +... userId = #973

Mes médias privés

Un média privé est un média qui n'a aucun abonnement (mis à part le personalSubscription de l'owner).

Créé avec HelpNDoc Personal Edition: Écrire des livres électroniques ePub pour l'iPad


Versions

Créé avec HelpNDoc Personal Edition: Générateur de documentation d'aide HTML gratuit


What's new ?

Versions ››

Version 2.0.0 du XX/XX/2015

1) CORRECTIONS DE BUGS

2) AMELIORATIONS

- Amélioration du formateur d'annuaire Sarapis.

- Amélioration du memory-limit pour les statistiques.

- Amélioration du temps de premier affichage d'un média.

3) COMPLEMENTS

- Ajout des scripts d'exemple produits par l'adaptateur d'annuaire Sarapis.

4) NOUVELLES FONCTIONNALITES

5) MISE A JOUR DES SCRIPTS EXTERNES

Version 2.0.0 RC1 du 11/02/2015

1) CORRECTIONS DE BUGS

- Correction d'une faille SQL injection sur deux champs d'indexation.

- Correction bug download de fichiers avec des caractères interdits dans le titre.

2) AMELIORATIONS

- Amélioration de la qualité des posters pour les vidéos (merci Sébastien).

- Utilisation du script "Minify" de Sébastien Monbrun pour combiner et minifier automatiquement les fichiers CSS et JS via Node.js.

- Chargement des noms des personnels en AJAX pour les partages pour quelques personnels de l'académie, et pour l'affectation des rôles (espace sAdmin).

- Les médias avec un partage pour un accès sans authentification n'apparaissent plus dans les résultats de recherches des utilisateurs de l'établissement.

- Une icône précise les médias indexés dans les résultats de recherche.

- Amélioration de quelques graphiques de l'espace sAdmin.

- Les médias peuvent maintenant être partagés sans attendre la fin de l'encodage.

- Lien vers la déconnexion globale de l'ENT dans la page de déconnexion (merci Philippe).

- Les boutons d'action sont maintenant désactivés après un clic (pour éviter de soumettre plusieurs fois un formulaire) avec un message d'attente.

- La vérification des UAI en liste blanche est désormais insensible à la casse.

- La vignette est maintenant affichée dans le player pour les sons ; les boutons de contrôle sont toujours affichés.

- Amélioration du javascript pour la prise en charge du player audio.

- Les médias diffusés en iframe peuvent être affichés en plein écran.

- Meilleure adaptation du player en cas de redimensionnement de la fenêtre à la volée quand le média est diffusé en iframe.

3) COMPLEMENTS

- Ajout des adaptateurs d’authentification et d'annuaire Cleartrust pour l'Académie de Rouen (merci Jérôme).

- Mise à jour des tutoriels.

- Ajout d'un tutoriel "Comment dupliquer l'indexation et les partages d'un média en quelques clics ?".

- Mise à jour de la FAQ.

- Mise à jour de la documentation technique sAdmins et développeurs.

- Ajout de données SQL pour une installation de test.

4) NOUVELLES FONCTIONNALITES

- Choix de l'affichage des résultats de recherches : par vignettes ou par liste.

- Choix du nombre de médias affichés par page (de 8 à tous les médias).

- Gestion des médias par lots :

- Duplication de l'indexation sur plusieurs médias à partir d'un média modèle.

- Duplication des partages sur plusieurs médias à partir d'un média modèle.

- Suppression des partages de plusieurs médias.

- Suppression de plusieurs médias.

- Le téléchargement du fichier source du média est désormais possible (cela permet par exemple de mettre un epub3 à disposition même s'il est encodé en epub2) (merci Elsa et Stéphane).

- Ajout d'un lecteur epub intégré dans Médiacad (merci Sébastien).

- Renvoi d'un JSON ou d'un JSONP avec des informations sur les médias pour utilisation par des applications tierces type Argos 2.0 (merci Sébastien).

- Ajout de l'argument optionnel autoplay pour la diffusion des vidéos et sons (merci Sébastien).

5) MISE A JOUR DES SCRIPTS EXTERNES

- Passage au Zend_Framework 1.12.10.

- Passage à Bootstrap 3.3.2.

- Passage à Cerulean de Bootswatch 3.3.2.

- Passage à Font-Awesome 4.3.0.

- Passage à jQuery 1.11.2.

- Passage à jQuery UI 1.11.2.

- Passage à Chosen 1.3.0.

- Passage à Smooth Zoom Pan 1.7.0.

- Passage à ScreenFull 2.0.0.

- Passage à Highcharts 4.0.4 et Highstock 2.0.4.

- Intégration de Select2. 4.0.0 Beta 3.

- Intégration de epub.js 0.2.5.

Version 1.0.0 du 08/05/2014

1) CORRECTIONS DE BUGS

- Affichage des médias publics en zone connectée (merci Joffrey).

2) AMELIORATIONS

- Optimisation globale du Zend_Framework (cache de plugin + lazy loading).

- Amélioration du permalink : plus court, ne change plus avec les partages publics.

- Amélioration de l'affichage d'une erreur si on tente de partager un média en cours d'encodage (merci Jean-Robert).

- Détection automatique d'une nouvelle version de Médiacad.

- Intégration en cache des fichiers d'auto complétion (amélioration de la sécurité) (merci Steve et Sébastien).

- Délégation à Apache du gzippage des css et js.

- Amélioration de l'accès aux pages statiques pendant la mise à jour de l'application.

- Ajout de boutons d'actions dans les onglets d'affichage d'un média (indexation, partage). Le menu "Média" n'est pas modifié (merci Michel et Stéphane).

- Amélioration du renvoi de la tâche suivante pour s'assurer de l'absence d'accès concurrents.

- Amélioration de la sécurité des formulaires (affichage des erreurs).

- Ajout de la reconnaissance vocale pour les inputs type text (Chrome 25+).

- Cryptage des adresses mail dans les pages d'aide (méthode anti-spam) (merci Jean-Pierre).

- Intégration aux ACLs de l'affichage dans les résultats de recherche des médias avec partage établissement public.

- Amélioration de la mise à jour du fichier de config pour tenir compte des clefs présentes dans le fichier local et pas dans le fichier modèle.

3) COMPLEMENTS

4) NOUVELLES FONCTIONNALITES

5) MISE A JOUR DES SCRIPTS EXTERNES

- Passage au Zend_Framework 1.12.6.

- Passage à HighchartsPHP 1.0.

- Passage à Bootstrap 3.1.1.

- Passage à Cerulean de Bootswatch 3.1.1.

- Passage à jQuery 1.11.1.

- Passage à Chosen 1.1.0.

- Passage à Highcharts 4.0.1 et Highstock 2.0.1.

Version 1.0.0 RC2 du 29/01/2014

1) CORRECTIONS DE BUGS

- Coquilles dans les fichiers de traduction (merci Jean-Pierre).

- Mise à jour de l'index lors de l'affichage concurrent d'un média (merci Stéphane).

- Encodage 3gp -> webm avec un audio bitrate source très faible (8k).

2) AMELIORATIONS

- Suppression d'un média : remplacement du select par deux submits (abandon / suppression) (merci Yves).

- Diminution de la latence lors de l'affichage gzip des css/js.

- Autorisation des partages pour un accès sans authentification sans modération du schoolMod + accès à tous les users de l'établissement.

- Nettoyage de la FAQ et des tutoriels (droits des modérateurs...).

- Ajout du champ ReplyTo: aux mails envoyés par Médiacad.

- Les médias avec partage public ne sont plus affichés pour tous en zone connectée ; les droits du partage académique automatiquement créé prévalent.

3) COMPLEMENTS

- Ajout de FAQs sur les rôles, les droits et les partages.

4) NOUVELLES FONCTIONNALITES

- Ajout d'un code json pour intégrer un média dans une extension de LMS (par exemple pour Wordpress) (merci Joffrey).

- Possibilité de créer une instance de démonstration : suppression par maintenance des médias n'appartenant pas aux superMods et sAdmins, warning pour media::add et media::edit.

- Nettoyage complet de l'index (médias absents ou doublonnés dans l'index, ou absents dans la base de données) par maintenance automatique (optimisé) ou par action de sAdmin (total).

5) MISE A JOUR DES SCRIPTS EXTERNES

- Passage à jQuery 1.11.0.

- Passage à jQuery UI 1.10.4.

- Passage à Projekktor 1.3.09.

- Passage à Highcharts 3.0.9 et Highstock 1.3.9.

Version 1.0.0 RC1 du 12/01/2014

1) CORRECTIONS DE BUGS

- Erreur lors de la tentative de création d'un auteur, collection, éditeur ou projet déjà existant avec uniquement une différence d'accent (merci Nadine).

- Erreur lors de la création / mise à jour d'un lycée.

- Suppression des arrays numériques lors du nettoyage des fichiers de config (merci Julien).

2) AMELIORATIONS

- Amélioration de la mise à jour des établissements (moins de requêtes d'update pour les élèves).

- Meilleure lisibilité des graphiques statistiques (passage d'aires à histogramme, suppression des groupements des valeurs).

- Passage en config de l'url appelée quand Médiacad requête ses propres web services.

- Gestion des encodages pendant une mise à jour de l'application.

3) COMPLEMENTS

- Statistiques : ajout de 18 graphiques (établissements, utilisateurs, médias).

- Charte d'utilisation personnels et élèves.

4) NOUVELLES FONCTIONNALITES

- Récupération et création / mise à jour des établissements des utilisateurs non inscrits dans un établissement 5 jours avant leur suppression par maintenance automatique (évite la perte des médias pour un personnel inscrit dans aucun établissement et ne s'étant pas connecté depuis 3 mois).

- Combinaison, minification et gzipage des fichiers css et js. Pour les CSS, on passe de 8 fichiers (216 ko) à 1 fichier (29 ko), pour les JS on passe de 14 fichiers (1,55 Mo) à 1 fichier (198 ko).

Créé avec HelpNDoc Personal Edition: Générateur de documentation complet